View Issue Details

This bug affects 1 person(s).
 12
IDProjectCategoryView StatusLast Update
18461Bug reportsErgonomypublic2022-11-28 11:08
ReporterMazi Assigned Togabrieljenik  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version3.28.x 
Summary18461: Survey groups at survey list screen should be listed alphabetically
Description

At systems with many survey groups, finding a certain survey group becomes tricky because survey groups at the dropdown seem to be filtered by ID or some other details and not by the actual group name, see screenshot.

Steps To Reproduce

Steps to reproduce

Create survey groups with name Z, M, A.
Check the survey list screen and the survey groups dropdown filter.

Expected result

Survey groups should be filtered by name (A, M, Z)

Actual result

Sorting within dropdown seems to be done by ID or creation date which is not very helpful.

TagsNo tags attached.
Bug heat12
Complete LimeSurvey version number (& build)3.28.32
I will donate to the project if issue is resolvedNo
Browser
Database type & versionMariaDB 10.1.48
Server OS (if known)
Webserver software & version (if known)
PHP VersionPHP 7.4

Relationships

related to 18462 acknowledged Missing option to search for survey groups at list survey screen 

Users monitoring this issue

User List DenisChenu

Activities

Mazi

Mazi

2022-11-05 13:06

updater  

image.png (28,722 bytes)   
image.png (28,722 bytes)   
DenisChenu

DenisChenu

2022-11-05 18:40

developer   ~72575

+1
But feature ?
Else : select2 ?

https://gitlab.com/SondagesPro/coreAndTools/select2ForAdmin/-/commit/65cafc6554113b6dc731121458bfa0aca6d2d0f7

ollehar

ollehar

2022-11-07 11:46

administrator   ~72595

Agree. Also small enough to be a bug fix, since it should reasonably be a one-line fix.

gabrieljenik

gabrieljenik

2022-11-14 15:28

manager   ~72721

LTS: https://github.com/LimeSurvey/LimeSurvey/pull/2723
Master: https://github.com/LimeSurvey/LimeSurvey/pull/2724

DenisChenu

DenisChenu

2022-11-14 15:35

developer   ~72723

Maybe need current Default at 1st position ?

DenisChenu

DenisChenu

2022-11-14 15:40

developer   ~72724

@Mazi opinion about default position at top ?

gabrieljenik

gabrieljenik

2022-11-14 15:42

manager   ~72725

Well Default is just another group. Actually its title can be changed.
I wouldn't mess with that. At least not on this ticket.

The idea was to review the order as a quick fix.

Mazi

Mazi

2022-11-15 12:10

updater   ~72741

I wouldn't set Default to the first position. That would be confusing if the rest is ordered alphabetically.

gabrieljenik

gabrieljenik

2022-11-21 11:53

manager   ~72833

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=34051

LimeBot

LimeBot

2022-11-28 11:08

administrator   ~72908

Fixed in Release 5.4.13+221128

Related Changesets

LimeSurvey: 3.x-LTS c913c90d

2022-11-21 11:13:51

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 18461 Survey groups at survey list screen should be listed alphabetically (#2723)

Co-authored-by: lapiudevgit <devgit@lapiu.biz>
Affected Issues
18461
mod - application/models/SurveysGroups.php Diff File

Issue History

Date Modified Username Field Change
2022-11-05 13:06 Mazi New Issue
2022-11-05 13:06 Mazi File Added: image.png
2022-11-05 13:13 Mazi Relationship added related to 18462
2022-11-05 18:39 DenisChenu Issue Monitored: DenisChenu
2022-11-05 18:39 DenisChenu Bug heat 0 => 2
2022-11-05 18:40 DenisChenu Note Added: 72575
2022-11-05 18:40 DenisChenu Bug heat 2 => 4
2022-11-07 11:46 ollehar Priority none => normal
2022-11-07 11:46 ollehar Note Added: 72595
2022-11-07 11:46 ollehar Bug heat 4 => 6
2022-11-07 14:24 gabrieljenik Status new => confirmed
2022-11-08 19:23 gabrieljenik Assigned To => gabrieljenik
2022-11-08 19:23 gabrieljenik Status confirmed => assigned
2022-11-14 15:28 gabrieljenik Assigned To gabrieljenik => DenisChenu
2022-11-14 15:28 gabrieljenik Status assigned => ready for code review
2022-11-14 15:28 gabrieljenik Note Added: 72721
2022-11-14 15:28 gabrieljenik Bug heat 6 => 8
2022-11-14 15:35 DenisChenu Note Added: 72723
2022-11-14 15:40 DenisChenu Status ready for code review => in testing
2022-11-14 15:40 DenisChenu Note Added: 72724
2022-11-14 15:42 gabrieljenik Note Added: 72725
2022-11-15 10:29 DenisChenu Assigned To DenisChenu =>
2022-11-15 10:29 DenisChenu Status in testing => ready for merge
2022-11-15 12:10 Mazi Note Added: 72741
2022-11-15 12:10 Mazi Bug heat 8 => 10
2022-11-16 14:23 gabrieljenik Assigned To => ollehar
2022-11-21 11:53 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS c913c90d
2022-11-21 11:53 gabrieljenik Note Added: 72833
2022-11-21 11:53 gabrieljenik Assigned To ollehar => gabrieljenik
2022-11-21 11:53 gabrieljenik Resolution open => fixed
2022-11-28 11:08 LimeBot Note Added: 72908
2022-11-28 11:08 LimeBot Status ready for merge => closed
2022-11-28 11:08 LimeBot Bug heat 10 => 12