View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
18351Bug reportsExpression Managerpublic2022-09-21 08:49
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version5.3.x 
Summary18351: Extra token placeholder show as invalid in expression
Description

Extra token attribute lik completed, remindercount cabn be used but shown as red in survey or in email.

Steps To Reproduce

Steps to reproduce

Import includes survey
Update email to your email for NOTCOMPLETED : send reminder (show You already 1 reminder).
Launch survey for both token : no issue (great)
Close browser or log out (clean EM session)
Check survey logic file
Validate expression of reminder

Expected result

Show static variable

Actual result

Show red variable : unknow variable

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)5.4.0 and 3.28.28
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database type & versionnot relevant
Server OS (if known)not relevant?
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 18345 closedDenisChenu Missing email placeholder for "Reminder count" 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2022-09-14 15:50

developer  

DenisChenu

DenisChenu

2022-09-14 15:51

developer   ~71754

If you check after testing : it's OK : get it in Session

DenisChenu

DenisChenu

2022-09-15 11:26

developer   ~71759

3.X : https://github.com/LimeSurvey/LimeSurvey/pull/2601
master : https://github.com/LimeSurvey/LimeSurvey/pull/2600

DenisChenu

DenisChenu

2022-09-16 12:32

developer   ~71785

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33880

LimeBot

LimeBot

2022-09-19 11:02

administrator   ~71813

Fixed in Release 5.4.1+220919

DenisChenu

DenisChenu

2022-09-21 08:49

developer   ~71861

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33897

Related Changesets

LimeSurvey: master b66b921d

2022-09-16 12:32:40

DenisChenu


Committer: GitHub Details Diff
Fixed issue 18351: Extra token placeholder show as invalid in expression (#2600)

Dev: add completed to fixed columns
Dev: use all in expression validator since Script use all token->attributes
Affected Issues
18351
mod - application/helpers/common_helper.php Diff File
mod - application/helpers/expressions/em_manager_helper.php Diff File

LimeSurvey: 3.x-LTS 10fcdca6

2022-09-21 08:49:20

DenisChenu


Committer: GitHub Details Diff
Fixed issue 18351: Extra token placeholder show as invalid in expression (#2601)

Dev: add completed to fixed columns
Dev: use all in expression validator since Script use all token->attributes
Affected Issues
18351
mod - application/helpers/common_helper.php Diff File
mod - application/helpers/expressions/em_manager_helper.php Diff File

Issue History

Date Modified Username Field Change
2022-09-14 15:50 DenisChenu New Issue
2022-09-14 15:50 DenisChenu File Added: Capture d’écran du 2022-09-14 15-49-06.png
2022-09-14 15:50 DenisChenu File Added: survey_archive_TOKENEXTRAATTRIBUTES.lsa
2022-09-14 15:51 DenisChenu Note Added: 71754
2022-09-14 15:51 DenisChenu Bug heat 0 => 2
2022-09-14 15:51 DenisChenu Assigned To => DenisChenu
2022-09-14 15:51 DenisChenu Status new => assigned
2022-09-14 15:51 DenisChenu Relationship added related to 18345
2022-09-15 11:26 DenisChenu Note Added: 71759
2022-09-15 11:26 DenisChenu Assigned To DenisChenu =>
2022-09-15 11:26 DenisChenu Status assigned => ready for code review
2022-09-16 12:32 DenisChenu Changeset attached => LimeSurvey master b66b921d
2022-09-16 12:32 DenisChenu Note Added: 71785
2022-09-16 12:32 DenisChenu Assigned To => DenisChenu
2022-09-16 12:32 DenisChenu Resolution open => fixed
2022-09-19 11:02 LimeBot Note Added: 71813
2022-09-19 11:02 LimeBot Status ready for code review => closed
2022-09-19 11:02 LimeBot Bug heat 2 => 4
2022-09-21 08:49 DenisChenu Changeset attached => LimeSurvey 3.x-LTS 10fcdca6
2022-09-21 08:49 DenisChenu Note Added: 71861