View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
17872Bug reportsResponse browsingpublic2022-08-08 09:16
ReporterAiophe Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.25.19 
Summary17872: Answerfilters reset after pagination changed
Description

Hi,

we have a survey with multiple answers, where we want to filter the answers and sometimes change the pagination (Show XX Entries). After changing the pagination, the filters reset. It's not clear if that's actually wanted.

I will attach a .lsa after we have anonymized a few things.

Steps To Reproduce

Steps to reproduce

  1. Go to /responses/sa/browse
  2. Set a Filter (e.g.: "completed" [Yes])
  3. Change pagination (e.g.: From "Show 10 Answers per Page" to "Show 20 Answers per Page")

Expected result

Expected are filtered results with the new pagination

Actual result

Actually, one is presented the new pagination without the set filter

TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)3.27.28
I will donate to the project if issue is resolvedNo
Browser
Database type & version MariaDB 10.5.13
Server OS (if known)
Webserver software & version (if known)
PHP Version 7.4.26

Users monitoring this issue

User List Aiophe

Activities

Aiophe

Aiophe

2022-02-07 13:24

reporter   ~68224

gabrieljenik

gabrieljenik

2022-05-02 17:59

manager   ~69349

Confirmed

gabrieljenik

gabrieljenik

2022-05-05 19:19

manager   ~69435

PR: https://github.com/LimeSurvey/LimeSurvey/pull/2403

gabrieljenik

gabrieljenik

2022-05-19 17:57

manager   ~69874

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33500

gabrieljenik

gabrieljenik

2022-05-20 21:40

manager   ~69945

Master PR: https://github.com/LimeSurvey/LimeSurvey/pull/2437

gabrieljenik

gabrieljenik

2022-05-20 21:40

manager   ~69946

Added fix for master

LimeBot

LimeBot

2022-05-23 11:36

administrator   ~69981

Fixed in Release 3.28.12+220524

gabrieljenik

gabrieljenik

2022-05-23 14:25

manager   ~69987

Reopening for testing the master PR

Aiophe

Aiophe

2022-06-27 16:38

reporter   ~70570

Seems to be working for me :)
ty!

gabrieljenik

gabrieljenik

2022-06-27 17:00

manager   ~70574

@Aiophe tested on master?

Aiophe

Aiophe

2022-06-27 17:02

reporter   ~70575

tested on master with tag "3.28.12+220524" (https://github.com/LimeSurvey/LimeSurvey/releases/tag/3.28.12%2B220524)

gabrieljenik

gabrieljenik

2022-06-27 17:05

manager   ~70576

OK, that's LTS :)
Master is v5

Aiophe

Aiophe

2022-06-27 17:07

reporter   ~70577

sorry, thought master branch in git

gabrieljenik

gabrieljenik

2022-07-05 15:01

manager   ~70725

Tested it OK on Master (v5)

gabrieljenik

gabrieljenik

2022-07-19 21:28

manager   ~71028

To be tested again on master as new solution is thrown

gabrieljenik

gabrieljenik

2022-08-03 16:47

manager   ~71313

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33706

LimeBot

LimeBot

2022-08-08 09:16

administrator   ~71369

Fixed in Release 5.3.30+220808

Related Changesets

LimeSurvey: 3.x-LTS 427fe31c

2022-05-19 17:51:19

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17872: Answerfilters reset after pagination changed (#2403) Affected Issues
17872
mod - application/views/admin/responses/listResponses_view.php Diff File

LimeSurvey: master 739ac13b

2022-08-03 16:47:11

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17872: Answerfilters reset after pagination changed (#2437)

Co-authored-by: encuestabizdevgit <devgit@encuesta.biz>
Affected Issues
17872
mod - application/extensions/LimeGridView/LimeGridView.php Diff File
mod - application/views/admin/token/browse.php Diff File
mod - application/views/questionAdministration/listquestions.php Diff File
mod - application/views/questionGroupsAdministration/listquestiongroups.php Diff File
mod - application/views/responses/listResponses_view.php Diff File

Issue History

Date Modified Username Field Change
2022-02-07 13:18 Aiophe New Issue
2022-02-07 13:24 Aiophe Note Added: 68224
2022-02-07 13:24 Aiophe File Added: 2022-02-07_13h11_14.mp4
2022-02-07 13:24 Aiophe Bug heat 0 => 2
2022-02-07 14:02 ollehar Product Version => 3.25.19
2022-02-07 15:02 Aiophe Issue Monitored: Aiophe
2022-02-07 15:02 Aiophe Bug heat 2 => 4
2022-04-28 16:31 gabrieljenik Assigned To => gabrieljenik
2022-04-28 16:31 gabrieljenik Status new => assigned
2022-05-02 17:59 gabrieljenik Note Added: 69349
2022-05-02 17:59 gabrieljenik Bug heat 4 => 6
2022-05-05 19:19 gabrieljenik Status assigned => ready for testing
2022-05-05 19:19 gabrieljenik Note Added: 69435
2022-05-19 17:51 c_schmitz Status ready for testing => resolved
2022-05-19 17:51 c_schmitz Resolution open => fixed
2022-05-19 17:57 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS 427fe31c
2022-05-19 17:57 gabrieljenik Note Added: 69874
2022-05-20 21:40 gabrieljenik Note Added: 69945
2022-05-20 21:40 gabrieljenik Status resolved => ready for testing
2022-05-20 21:40 gabrieljenik Note Added: 69946
2022-05-23 11:36 LimeBot Note Added: 69981
2022-05-23 11:36 LimeBot Status ready for testing => closed
2022-05-23 11:36 LimeBot Bug heat 6 => 8
2022-05-23 14:25 gabrieljenik Status closed => ready for testing
2022-05-23 14:25 gabrieljenik Note Added: 69987
2022-06-27 16:38 Aiophe Note Added: 70570
2022-06-27 17:00 gabrieljenik Note Added: 70574
2022-06-27 17:02 Aiophe Note Added: 70575
2022-06-27 17:05 gabrieljenik Note Added: 70576
2022-06-27 17:07 Aiophe Note Added: 70577
2022-07-05 15:01 gabrieljenik Status ready for testing => ready for merge
2022-07-05 15:01 gabrieljenik Note Added: 70725
2022-07-05 15:01 gabrieljenik Assigned To gabrieljenik => c_schmitz
2022-07-19 21:28 gabrieljenik Status ready for merge => ready for testing
2022-07-19 21:28 gabrieljenik Note Added: 71028
2022-07-27 16:11 gabrieljenik Status ready for testing => ready for merge
2022-07-27 16:15 gabrieljenik Issue cloned: 18285
2022-07-27 16:18 gabrieljenik Issue cloned: 18286
2022-08-03 16:47 gabrieljenik Changeset attached => LimeSurvey master 739ac13b
2022-08-03 16:47 gabrieljenik Note Added: 71313
2022-08-03 16:47 gabrieljenik Assigned To c_schmitz => gabrieljenik
2022-08-04 12:42 ollehar Status ready for merge => resolved
2022-08-08 09:16 LimeBot Note Added: 71369
2022-08-08 09:16 LimeBot Status resolved => closed