View Issue Details

This bug affects 1 person(s).
 14
IDProjectCategoryView StatusLast Update
18141Bug reports_ Unknownpublic2022-08-11 20:40
Reporterritapas Assigned Togabrieljenik  
PrioritynoneSeveritypartial_block 
Status ready for testingResolutionfixed 
Product Version3.28.x 
Summary18141: changing display mode from extended to compact in survey responses windows causes freeze
Description

changing display mode from extended to compact in survey responses windows causes freeze. You have to refresh the page to regain control

Steps To Reproduce

Steps to reproduce

open responses windows in survey with responses. Change display mode to Extended. Change again to compact

Expected result

switch to compact mode

Actual result

screen frozen, mouse cursor in "wait mode"

also happens in 3.28.11

TagsNo tags attached.
Bug heat14
Complete LimeSurvey version number (& build)3.28.8 (build 220426)
I will donate to the project if issue is resolvedNo
BrowserMozilla Firefox, Google Chrome, Edge
Database type & versionphp-mysql-5.4.16
Server OS (if known)Red Hat Enterprise Linux Server release 7.5 (Maipo)
Webserver software & version (if known)httpd-2.4.6-80
PHP Versionrh-php71

Relationships

has duplicate 15567 closedgabrieljenik Access response table - change from exted to compact mode 1 or 2 times - the page does not load anymore 

Users monitoring this issue

User List cdorin, ritapas

Activities

gabrieljenik

gabrieljenik

2022-06-24 17:43

manager   ~70521

Reproduction: https://drive.google.com/file/d/1-1GPJtdvjicrQizbXl-BbJgHuEBuNIEC/view?usp=sharing

gabrieljenik

gabrieljenik

2022-07-05 14:35

manager   ~70715

LTS: https://github.com/LimeSurvey/LimeSurvey/pull/2499
Master: https://github.com/LimeSurvey/LimeSurvey/pull/2500

It wasn't easy to reproduce the issue, but it was easy to make it malfunction (getting heavier and heavier over time, and with the overlay getting whiter). That's fixed, and I think that was the reason it was crashing.

gabrieljenik

gabrieljenik

2022-07-11 18:48

manager   ~70878

Tested OK Master.
LTS is pending.

gabrieljenik

gabrieljenik

2022-07-14 15:16

manager   ~70936

Merged master. Pending test on LTS

gabrieljenik

gabrieljenik

2022-07-14 15:20

manager   ~70937

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33645

LimeBot

LimeBot

2022-07-18 10:32

administrator   ~70987

Fixed in Release 5.3.25+220718

gabrieljenik

gabrieljenik

2022-07-18 14:42

manager   ~70998

LTS is pending to be tested.

Related Changesets

LimeSurvey: master 24d8dd98

2022-07-14 15:15:22

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 18141: changing display mode from extended to compact in survey responses windows causes freeze Affected Issues
18141
mod - assets/scripts/admin/listresponse.js Diff File

Issue History

Date Modified Username Field Change
2022-05-23 01:48 ritapas New Issue
2022-06-22 14:58 ritapas Issue Monitored: ritapas
2022-06-22 14:58 ritapas Bug heat 0 => 2
2022-06-22 16:27 gabrieljenik Assigned To => gabrieljenik
2022-06-22 16:27 gabrieljenik Status new => acknowledged
2022-06-24 17:39 gabrieljenik Status acknowledged => confirmed
2022-06-24 17:43 gabrieljenik Note Added: 70521
2022-06-24 17:43 gabrieljenik Bug heat 2 => 4
2022-07-05 14:35 gabrieljenik Status confirmed => ready for code review
2022-07-05 14:35 gabrieljenik Note Added: 70715
2022-07-05 15:04 gabrieljenik Assigned To gabrieljenik => DenisChenu
2022-07-06 15:17 DenisChenu Assigned To DenisChenu => gabrieljenik
2022-07-06 15:17 DenisChenu Status ready for code review => ready for testing
2022-07-11 18:48 gabrieljenik Note Added: 70878
2022-07-14 15:16 gabrieljenik Note Added: 70936
2022-07-14 15:20 gabrieljenik Changeset attached => LimeSurvey master 24d8dd98
2022-07-14 15:20 gabrieljenik Note Added: 70937
2022-07-14 15:20 gabrieljenik Resolution open => fixed
2022-07-18 10:32 LimeBot Note Added: 70987
2022-07-18 10:32 LimeBot Status ready for testing => closed
2022-07-18 10:32 LimeBot Bug heat 4 => 6
2022-07-18 14:42 gabrieljenik Status closed => ready for testing
2022-07-18 14:42 gabrieljenik Note Added: 70998
2022-08-11 20:39 gabrieljenik Relationship added related to 15567
2022-08-11 20:40 gabrieljenik Relationship replaced has duplicate 15567
2022-08-11 20:40 gabrieljenik Bug heat 6 => 12
2022-08-11 20:40 gabrieljenik Issue Monitored: cdorin
2022-08-11 20:40 gabrieljenik Bug heat 12 => 14