View Issue Details

IDProjectCategoryView StatusLast Update
14933Bug reports[All Projects] Translationpublic2019-10-25 15:18
Reporterc_schmitz Assigned ToLouisGac  
PriorityimmediateSeveritymajor 
Status resolvedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary14933: Several strings (from twig files) are not available for translation / are not translated
Description

This is a collective bug report for several bugs reports we received in the last couple months regarding missing translations / untranslated text in LimeSurvey.

The reason for this is that our server function used to extract the translation from Twig files does not correctly work and misses alot of strings.

Additional Information

@LouisGac The regex is not properly grepping all translations.
I suggest we use this solution instead:

https://twig-extensions.readthedocs.io/en/latest/i18n.html#using-xgettext-or-poedit-1

Please implement as soon as possible. Thank you.

TagsNo tags attached.
Complete LimeSurvey version number (& build)All 3.x or later versions
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version.
Server OS (if known).
Webserver software & version (if known).
PHP Version.

Relationships

has duplicate 13583 closedLouisGac Some string are not in po (translate.limesurvey.org) 
has duplicate 14906 closeddominikvitt the sharing panel (new in 4.x) not translated 
has duplicate 13522 closedc_schmitz Translation panel - references link does not work for texts from Twig templates 
has duplicate 14925 closedc_schmitz German translation for Export these respones as PDF / to QXML: missing? 
has duplicate 13217 closedmarkusfluer MISSING TRANSLATION 
has duplicate 13577 closedmarkusfluer Missing strings in PO files - some strings not translated and not available for translation either. 
has duplicate 13627 closedLouisGac missing translation 
has duplicate 14483 closedc_schmitz Error page have not translatable string 
has duplicate 14702 closedc_schmitz missing quick translations for admin notifications 
related to 14129 newLouisGac wrong translation table in German version 
related to 14901 closeddominikvitt broken translation 
related to 15145 closedp_teichmann missing ranslation 

Activities

Mazi

Mazi

2019-06-24 15:42

partner   ~52508

@cdorin, FYI, this also affects a lot of users/customers. One of our customers reported https://bugs.limesurvey.org/view.php?id=14129.

Mazi

Mazi

2019-08-21 13:53

partner   ~53216

@cdorin, I see lots of related bugs being marked as closed? Are they all fixed or is that because you keep this single ticket open? To me this looks like the issue is still not fixed, at least not at Version 3.17.9+190731?

@c_schmitz, I pinged you about that one on Skype back in June or July. Maybe you can threaten some people to finally get this monkey off our back?

Mazi

Mazi

2019-09-02 16:18

partner   ~53389

@c_schmitz
@cdorin
@LouisGac
...sorry to bother you, but again I was asked by the customer when a fix can be expected. Any news?

LouisGac

LouisGac

2019-09-02 16:24

manager   ~53393

pratically done

c_schmitz

c_schmitz

2019-09-19 18:53

administrator   ~53659

Last edited: 2019-09-22 17:00

View 2 revisions

It should be fixed now - at least the strings are available for translations now.
If you see strings that are not in the translation file and their source is in a .twig file feel free to reopen this issue.
In any other case please open a new issue.

Mazi

Mazi

2019-10-25 15:15

partner   ~54227

@c_schmitz, I have re-opened ticket 14129 because that issue is still not fixed, see new screenshot.

LouisGac

LouisGac

2019-10-25 15:18

manager   ~54231

Mazi: I close it because it's not the same issue. Here, it's related to twig views for survey taking, and this bug is solved. The one in 14129 is in backend, and it's related to vuejs.

Issue History

Date Modified Username Field Change
2019-05-23 15:00 c_schmitz New Issue
2019-05-23 15:00 c_schmitz Status new => assigned
2019-05-23 15:00 c_schmitz Assigned To => LouisGac
2019-05-23 15:01 c_schmitz Relationship added has duplicate 13583
2019-05-23 15:01 c_schmitz Relationship added has duplicate 14906
2019-05-23 15:02 c_schmitz Relationship added has duplicate 13522
2019-05-23 15:02 c_schmitz Relationship added has duplicate 14925
2019-05-23 15:02 c_schmitz Priority none => immediate
2019-05-23 15:04 c_schmitz Relationship added has duplicate 14129
2019-05-23 15:05 c_schmitz Relationship added has duplicate 13217
2019-05-23 15:05 c_schmitz Relationship added has duplicate 13577
2019-05-23 15:05 c_schmitz Relationship added has duplicate 13627
2019-05-23 15:07 c_schmitz Relationship added has duplicate 14483
2019-05-23 15:08 c_schmitz Relationship added has duplicate 14702
2019-05-23 15:12 c_schmitz Relationship added related to 14901
2019-06-24 15:42 Mazi Note Added: 52508
2019-06-24 16:04 cdorin Relationship replaced related to 14129
2019-08-12 14:03 p_teichmann Relationship added related to 15145
2019-08-21 13:53 Mazi Note Added: 53216
2019-09-02 16:18 Mazi Note Added: 53389
2019-09-02 16:24 LouisGac Note Added: 53393
2019-09-19 18:50 c_schmitz Status assigned => resolved
2019-09-19 18:50 c_schmitz Resolution open => fixed
2019-09-19 18:50 c_schmitz Fixed in Version => 3.17.x
2019-09-19 18:53 c_schmitz Note Added: 53659
2019-09-22 17:00 c_schmitz Note Edited: 53659 View Revisions
2019-10-25 15:15 Mazi Note Added: 54227
2019-10-25 15:18 LouisGac Note Added: 54231