View Issue Details

IDProjectCategoryView StatusLast Update
14129Bug reports[All Projects] Translationpublic2019-06-24 16:04
ReporterwolfganghuefferAssigned ToLouisGac 
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version3.12.x 
Target VersionFixed in Version3.15.x 
Summary14129: wrong translation table in German version
Description

Enclosed screenshots shows that there is a wrong translation for some buttons. Possibly the translation function is not connected correctly at these points.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.13.0+180628
I will donate to the project if issue is resolvedNo
BrowserMozilla Firefox
Database & DB-VersionMS SQL 2012 SP4
Server OS (if known)Red Hat Enterprise Linux Server Release 7.4
Webserver software & version (if known)Apache/2.4.6
PHP VersionPHP 5.4.16

Relationships

related to 14340 assignedLouisGac Untranslatable string in print response view 
related to 13583 closedLouisGac Some string are not in po (translate.limesurvey.org) 
related to 14933 assignedLouisGac Several strings (from twig files) are not available for translation / are not translated 

Activities

wolfganghueffer

wolfganghueffer

2018-10-04 13:04

reporter  

LimeSurvey_Bug01.JPG (38,283 bytes)
LimeSurvey_Bug01.JPG (38,283 bytes)
LimeSurvey_Bug02.JPG (38,103 bytes)
LimeSurvey_Bug02.JPG (38,103 bytes)
LimeSurvey_Bug03.JPG (21,097 bytes)
LimeSurvey_Bug03.JPG (21,097 bytes)
Mazi

Mazi

2018-10-05 12:24

partner   ~49250

I can still reproduce this at v3.14.11.

guest

guest

2018-11-12 17:33

viewer   ~49619

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28509

Mazi

Mazi

2019-02-20 10:49

partner   ~50647

"Predefined label set" ist still not translated properly (screenshot: https://bugs.limesurvey.org/file_download.php?file_id=10786&type=bug). I just tested at demo.limesurvey.org

Mazi

Mazi

2019-04-05 08:33

partner   ~51355

@c_schmitz, this one was reported by a long term customer. They really wonder why such a simple thing like a missing translation takes half a year to fix. Any chance to get the fix included at the next release?

Mazi

Mazi

2019-04-05 09:27

partner   ~51368

The pre-filled "Same example answer option" also seems to not be translated yet.



image002.png (9,938 bytes)
image002.png (9,938 bytes)
DenisChenu

DenisChenu

2019-04-05 11:49

developer   ~51377

twig translation …

Mazi

Mazi

2019-04-15 11:08

partner   ~51467

The customer needs a fix so we will take over this one due to missing feedback by the development team.

DenisChenu

DenisChenu

2019-04-15 11:20

developer   ~51468

@Mazi : maybe the best for such situation (quickest way) is to add some "unused" call to gT("the string in twig") in https://github.com/LimeSurvey/LimeSurvey/blob/master/application/controllers/admin/questions.php#L420

For example : this sentence https://github.com/LimeSurvey/LimeSurvey/blob/d2adb9703d9f2847413239509525e9c682fbc47d/application/helpers/SurveyRuntimeHelper.php#L1128 are not used in twig …

This more an hack but … it work …

bismark

bismark

2019-05-03 09:25

reporter   ~51747

There is a yii event "onMissingTranslation" you can use to get noticed about missing translations:

in application/config.php add the folowing snippet within the components array,

'messages' => array(
    'onMissingTranslation' => function ($event) {
        var_dump($event->message); // you should log into a file instead
    }
),
bismark

bismark

2019-05-03 09:27

reporter   ~51748

by the way I sent a mail to translations@limesurvey.org to ask some workflow questions regarding translations

bismark

bismark

2019-05-03 10:35

reporter   ~51750

Translation of LimeSurvey 3.x.x in German

This file is distributed under the same license as the LimeSurvey 3.x.x package.

msgid ""
msgstr ""
"PO-Revision-Date: 2019-04-30 08:11:33+0000\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=n != 1;\n"
"X-Generator: GlotPress/2.2.2\n"
"Language: de\n"
"Project-Id-Version: LimeSurvey 3.x.x\n"

msgid "Predefined label sets…"
msgstr "Vordefinierte Beschriftungssets"

msgid "Some example answer option"
msgstr "Beispielantwort"

msgid "Subquestion"
msgstr "Teilfrage"

bismark

bismark

2019-05-03 10:37

reporter   ~51751

msgcat.exe limesurvey-3-de.po consulting-3-de.po -o merge.po

compile merge.po to de.mo

c_schmitz

c_schmitz

2019-05-03 12:06

administrator   ~51753

@LouisGac The regex is not properly grepping all translations.
I suggest we use this solution instead:

https://twig-extensions.readthedocs.io/en/latest/i18n.html#using-xgettext-or-poedit-1

Please implement. Thank you.

Mazi

Mazi

2019-05-07 17:20

partner   ~51812

@LouisGac, the customer would love to see this at the next release. Can you give it a try?
Thanks!

Related Changesets

LimeSurvey: master 413b5b05

2018-11-12 17:28:53

Dominik Vitt

Details Diff
Fixed issue 14129: wrong translation table in German version Affected Issues
14129
mod - application/views/admin/survey/Question/answerOptionsEdit_view.twig Diff File
mod - application/views/admin/survey/Question/question_subviews/_modals.twig Diff File
mod - application/views/admin/survey/Question/subquestionsAndAnswers/_answer_option.twig Diff File

Issue History

Date Modified Username Field Change
2018-10-04 13:04 wolfganghueffer New Issue
2018-10-04 13:04 wolfganghueffer File Added: LimeSurvey_Bug01.JPG
2018-10-04 13:04 wolfganghueffer File Added: LimeSurvey_Bug02.JPG
2018-10-04 13:04 wolfganghueffer File Added: LimeSurvey_Bug03.JPG
2018-10-05 12:24 Mazi Note Added: 49250
2018-10-05 12:24 Mazi Assigned To => dominikvitt
2018-10-05 12:24 Mazi Status new => assigned
2018-11-12 17:33 Changeset attached => LimeSurvey master 413b5b05
2018-11-12 17:33 guest Note Added: 49619
2018-11-12 17:33 guest Resolution open => fixed
2018-11-12 17:43 dominikvitt Status assigned => resolved
2018-11-12 17:43 dominikvitt Fixed in Version => 3.15.x
2019-02-20 10:49 Mazi Status resolved => assigned
2019-02-20 10:49 Mazi Note Added: 50647
2019-04-05 08:33 Mazi Note Added: 51355
2019-04-05 09:27 Mazi File Added: image002.png
2019-04-05 09:27 Mazi Note Added: 51368
2019-04-05 11:49 DenisChenu Note Added: 51377
2019-04-05 11:49 DenisChenu Relationship added related to 14340
2019-04-05 11:50 DenisChenu Relationship added related to 13583
2019-04-15 11:08 Mazi Assigned To dominikvitt => Mazi
2019-04-15 11:08 Mazi Note Added: 51467
2019-04-15 11:20 DenisChenu Note Added: 51468
2019-05-03 09:25 bismark Note Added: 51747
2019-05-03 09:27 bismark Note Added: 51748
2019-05-03 10:35 bismark Note Added: 51750
2019-05-03 10:37 bismark Note Added: 51751
2019-05-03 10:57 cdorin Assigned To Mazi => c_schmitz
2019-05-03 12:04 c_schmitz Assigned To c_schmitz => LouisGac
2019-05-03 12:06 c_schmitz Note Added: 51753
2019-05-07 17:20 Mazi Note Added: 51812
2019-05-23 15:04 c_schmitz Relationship added duplicate of 14933
2019-05-23 15:04 c_schmitz Status assigned => closed
2019-05-23 15:04 c_schmitz Resolution fixed => duplicate
2019-06-24 16:04 cdorin Relationship replaced related to 14933