View Issue Details

IDProjectCategoryView StatusLast Update
07967Bug reports[All Projects] Accessibilitypublic2016-09-21 16:34
Reporternicola_86 
Assigned Toc_schmitz 
PrioritynormalSeverityminor 
Status closedResolutionno change required 
Product Version2.00+ 
Target Version2.05 RCFixed in Version2.05 RC 
Summary07967: Without javascript there are still present button that don't work in the survey : back, clear the survey, send it incomplete.
DescriptionWhile using the survey without javascript in the browser, the user cannot use the buttons that are on the interface: back, clear the survey and the one to send it incomplete. Another issue is the progress bar on the top, without the progress bar it's not clear why is present: "0% 100%"
Steps To Reproducedisable javascript, put the survey in a way to show one question for page and excute the survey
TagsNo tags attached.
Complete LimeSurvey version number (& build)130428
I will donate to the project if issue is resolvedNo
BrowserMozilla Firefox
Database & DB-VersionOracle
Operating System (Server)CentOS
Webserver software & versionApache/2.2.15
PHP VersionPHP/5.3.3,

Relationships

related to 07991 closedsammousa No js file included in welcome page 
parent of 08121 closedDenisChenu Missing classes for "resume later" button cause template elements to look different 
parent of 08186 closedDenisChenu Can not use "language changer" without javascript 
parent of 10079 closedLouisGac Without javascript there are still present button that don't work in the survey : back, clear the survey, send it incomplete. 

Activities

Mazi

2013-07-04 09:53

developer   ~25704

I think there should be a warning message if JavaScript is turned off, because you can't run a survey without activated JS at all.

DenisChenu

2013-07-04 10:07

developer   ~25707

We can run a survey without javascript .....
 And WE have too ...

Mazi

2013-07-04 10:23

developer   ~25708

How can that work? There is JS used for submitting the buttons and what about conditions? JS is used for on page validation.

DenisChenu

2013-07-04 10:28

developer   ~25709

Last edited: 2013-07-04 10:52

View 2 revisions

Default behaviour : move = movenext.

For condition : js + PHP.

Try it : it work. Best is to use :
- First question
- Second question, mandatory but hidden by condition on the first question

Have other bug/feature request for condition :
http://bugs.limesurvey.org/view.php?id=7959

DenisChenu

2013-07-12 10:45

developer   ~25770

Question:

IE6 don't manage good button. It can be reviewed in javascript . But for PHP: what to do ?
If $move!="" and !(in_array($move,$aAcceptedMove)){
$move='movenext'/'movesubmit";
}

Hard to find the best way ...

Think it's better to have accessibility for all button without javascript except for IE6. But IE6 need default value here. Don't want to add an input hidden just for IE6 ....

DenisChenu

2013-07-12 10:46

developer   ~25771

Add the relationship because can not do test with IE6 with no js in welcome page.

DenisChenu

2013-07-12 19:57

developer   ~25780

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=12737

DenisChenu

2013-07-12 19:57

developer   ~25781

Partial : need save/load
Partial put some js for IE6, but no tested

DenisChenu

2013-07-13 02:20

developer   ~25782

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=12739

DenisChenu

2013-08-10 11:26

developer   ~25951

Problem for save .... Need rewrite ....

Put some comment here.

- Actual 2.05 system work good on all browser, this can be added for Save button except for one think.

If we have only one input:text question, if user click on "ENTER" without javbascript : it's take the first button (or first input submit).

IN navigator, i add a button move value="next" at start of navogator. This fix problem, a user "ENTER" think he go next.
But Save (or clear all) can be before navigator(prev/next) then default behaviour are "Save".


An idea can be:
- Adding a display:none button at start of navigator.pstpl (think replacement helper can knwo if we are at navigator.pstpl).
- This button can have value="default": default behaviour can be : movenext OR dontmove and send alert (maybe in plugin for 2.06).

It's OK like that ?
Assign it to me after reading and advice.

c_schmitz

2013-09-15 18:50

administrator   ~26232

We do not support IE6 anymore so there is no special IE6 workaround needed.

I really don't understand why they did not find a solution for this in HTML5.
I think the invisible navigator button is the best option although I still hate it ;).

DenisChenu

2013-09-16 08:40

developer   ~26249

Yes,

After reflexion, think best is to have:
I replacement:
call navigator.pstp do this:
<button name="move" value="default" style="display:none;"></button>
And after put the content of navigator.pstpl.
Then we are sur we have allways value default for move result.

Like i say : the only problem is for "only one text question" and send ENTER.
Some of our user use LS like "Input Assistant"

tpartner

2013-09-22 16:33

developer   ~26312

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13037

tpartner

2013-09-22 16:36

developer   ~26313

Just fixed a couple of broken paths Denis :)

DenisChenu

2013-09-24 12:52

developer   ~26336

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=13048

DenisChenu

2013-09-24 13:00

developer   ~26337

Please nicola_86 : try with the last 2.05 version (or wait for next 2.05 beta release to test).

c_schmitz

2013-10-11 11:08

administrator   ~26709

2.05RC2 released

DenisChenu

2016-09-07 13:33

developer   ~40714

See https://github.com/LimeSurvey/LimeSurvey/commit/fd5ca4333388f092d69c0133f3a46f323c330d00

c_schmitz

2016-09-07 13:42

administrator   ~40715

We do not support survey taking without JavaScript anymore.

DenisChenu

2016-09-07 13:49

developer   ~40716

I know for some situation.

But here : we have a working solution, the new solution just need to use a modal in replace of old confirm : i's a "decoration solution".

DenisChenu

2016-09-10 12:20

developer   ~40747

IE11 : Settings--> Internet Options --> Security --> Custom Level --> "Allow scripting of Microsoft web browser control"

jelo

2016-09-10 13:29

reporter   ~40748

Denis: What is the intention of posting this option of IE? It's not about Javascript support itself, it's about use the IE inside other windows applications.

The issue relating with this option is not confirmed from others.
https://www.limesurvey.org/de/foren/installation-a-update-issues/104844-unable-to-select-multiple-choice-answers
It still looks like a hardened IT environment, where certain features are deactivated. Even though this still might be a bug inside Limesurvey I see no indication that javascript is the issue here.


I am using NoScript everywhere. So I am in favour of keeping a non javascript survey mode in Limesurvey. The question is if the userbase LimeSurvey GmbH is aiming at is the same as the userbase of longtime partners and external codeproviders. And if not, what conclusion can be drawn from that.

c_schmitz

2016-09-21 16:34

administrator   ~40897

I have said it in the past that we will not put any efforts into no-js compatibility.

If someone wants to put time into it, fine, but we cannot guarantee any longterm availablity for the solution. We are not deliberately damaging such a solution but it will also not be considered if there are any changes.

Related Changesets

LimeSurvey: 2.05 cd16db1d

2013-07-12 17:52:52

DenisChenu

Details Diff
Fixed issue 07967: Accessibility of button without javascript : previous and clear
Dev: todo : save / load
Dev: Fixed issue : double inclusion of js and css
Dev: Fixed a lot of js in qanda after 4a2d74dd2efc0f0af63e01bc59d5706ee465d6c4
mod - application/controllers/survey/index.php Diff File
mod - application/helpers/frontend_helper.php Diff File
mod - application/helpers/qanda_helper.php Diff File
mod - application/helpers/replacements_helper.php Diff File
add - scripts/array-totalsum.js Diff File
add - scripts/navigator-countdown.js Diff File
mod - scripts/survey_runtime.js Diff File

LimeSurvey: 2.05 3b59b81e

2013-07-13 00:10:17

DenisChenu

Details Diff
Fixed issue 07967: Accessibility of button without javascript : index
Dev: Ols javascript of index don't work : move it in survey_runtime function
mod - application/helpers/SurveyRuntimeHelper.php Diff File
mod - application/helpers/common_helper.php Diff File
mod - application/helpers/frontend_helper.php Diff File
mod - scripts/navigator-countdown.js Diff File
mod - scripts/survey_runtime.js Diff File

LimeSurvey: 2.05 79f112c3

2013-09-22 14:33:44

tpartner

Details Diff
Fixed issue 07967: Without javascript there are still present button that don't work in the survey : back, clear the survey, send it incomplete.
Dev: Fixed a few paths to /styles-public/
mod - application/helpers/qanda_helper.php Diff File

LimeSurvey: 2.05 151d03b4

2013-09-24 10:52:23

DenisChenu

Details Diff
Fixed issue 07967: Without javascript there are still present button that don't work in the survey
Dev: except for change language and index : all work without JS in IE7
Dev: except for change language : all work without JS on modern browser
mod - application/controllers/survey/index.php Diff File
mod - application/helpers/SurveyRuntimeHelper.php Diff File
mod - application/helpers/frontend_helper.php Diff File
mod - application/helpers/replacements_helper.php Diff File
mod - scripts/survey_runtime.js Diff File

Issue History

Date Modified Username Field Change
2013-07-03 09:17 nicola_86 New Issue
2013-07-04 09:52 Mazi Assigned To => DenisChenu
2013-07-04 09:52 Mazi Status new => assigned
2013-07-04 09:53 Mazi Note Added: 25704
2013-07-04 10:07 DenisChenu Note Added: 25707
2013-07-04 10:08 DenisChenu Target Version => 2.05 RC
2013-07-04 10:23 Mazi Note Added: 25708
2013-07-04 10:28 DenisChenu Note Added: 25709
2013-07-04 10:52 DenisChenu Note Edited: 25709 View Revisions
2013-07-12 10:45 DenisChenu Note Added: 25770
2013-07-12 10:46 DenisChenu Relationship added related to 07991
2013-07-12 10:46 DenisChenu Note Added: 25771
2013-07-12 10:46 DenisChenu Priority urgent => normal
2013-07-12 19:57 DenisChenu Changeset attached => LimeSurvey 2.05 cd16db1d
2013-07-12 19:57 DenisChenu Note Added: 25780
2013-07-12 19:57 DenisChenu Resolution open => fixed
2013-07-12 19:57 DenisChenu Note Added: 25781
2013-07-13 02:20 DenisChenu Changeset attached => LimeSurvey 2.05 3b59b81e
2013-07-13 02:20 DenisChenu Note Added: 25782
2013-08-10 11:26 DenisChenu Note Added: 25951
2013-08-10 11:27 DenisChenu Assigned To DenisChenu => c_schmitz
2013-08-10 11:27 DenisChenu Status assigned => feedback
2013-09-02 13:56 DenisChenu Relationship added parent of 08121
2013-09-15 18:50 c_schmitz Note Added: 26232
2013-09-15 18:50 c_schmitz Assigned To c_schmitz => DenisChenu
2013-09-15 18:50 c_schmitz Status feedback => assigned
2013-09-16 08:40 DenisChenu Note Added: 26249
2013-09-22 16:33 tpartner Changeset attached => LimeSurvey 2.05 79f112c3
2013-09-22 16:33 tpartner Note Added: 26312
2013-09-22 16:33 tpartner Assigned To DenisChenu => tpartner
2013-09-22 16:36 tpartner Assigned To tpartner => DenisChenu
2013-09-22 16:36 tpartner Note Added: 26313
2013-09-24 12:52 DenisChenu Changeset attached => LimeSurvey 2.05 151d03b4
2013-09-24 12:52 DenisChenu Note Added: 26336
2013-09-24 12:59 DenisChenu Relationship added parent of 08186
2013-09-24 13:00 DenisChenu Note Added: 26337
2013-09-24 13:00 DenisChenu Status assigned => resolved
2013-09-24 13:00 DenisChenu Fixed in Version => 2.05 RC
2013-10-11 11:08 c_schmitz Note Added: 26709
2013-10-11 11:08 c_schmitz Status resolved => closed
2015-12-07 09:13 DenisChenu Relationship added parent of 10079
2016-09-07 13:33 DenisChenu Assigned To DenisChenu => markusfluer
2016-09-07 13:33 DenisChenu Note Added: 40714
2016-09-07 13:33 DenisChenu Status closed => feedback
2016-09-07 13:33 DenisChenu Resolution fixed => reopened
2016-09-07 13:42 c_schmitz Note Added: 40715
2016-09-07 13:42 c_schmitz Status feedback => closed
2016-09-07 13:42 c_schmitz Resolution reopened => fixed
2016-09-07 13:49 DenisChenu Assigned To markusfluer => c_schmitz
2016-09-07 13:49 DenisChenu Note Added: 40716
2016-09-07 13:49 DenisChenu Status closed => feedback
2016-09-07 13:49 DenisChenu Resolution fixed => reopened
2016-09-10 12:20 DenisChenu Note Added: 40747
2016-09-10 13:29 jelo Note Added: 40748
2016-09-21 16:34 c_schmitz Status feedback => closed
2016-09-21 16:34 c_schmitz Resolution reopened => no change required
2016-09-21 16:34 c_schmitz Note Added: 40897