View Issue Details

This bug affects 3 person(s).
 42
IDProjectCategoryView StatusLast Update
19164Bug reportsErgonomypublic2024-03-04 15:10
ReporterDenisChenu Assigned ToDenisChenu  
PriorityhighSeverityblock 
Status resolvedResolutionfixed 
Product Version6.2.x 
Summary19164: Extra action button for Question are really badly placed
Description

I n6.X : the question tool button show Survey tools, to finds Question tools : you must go on an hidden menu
And more this menu can be at far far bottom of the page

Steps To Reproduce

Steps to reproduce

Sdearch for Set condition

Expected result

Find it on quetsion edit menu, maybe tool and/or in Question summary

Actual result

Hard to find it ?

TagsNo tags attached.
Attached Files
5X.png (46,190 bytes)   
5X.png (46,190 bytes)   
6X.png (149,497 bytes)
Bug heat42
Complete LimeSurvey version number (& build)6.2.11
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database type & versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

has duplicate 19267 closedDenisChenu I can't find the set of conditions 
has duplicate 19430 closedc_schmitz Loss of ergonomics compared to previous versions 
related to 19179 assignedtibor.pacalat Absence of the Conditions designer in Options (Concepteur de conditions) 
related to 19350 new Question - Overflow Menu hidden by question tool tip 
related to 19448 new Questioon menu needed too on Question edit 

Users monitoring this issue

marina_zbae, mfavetti

Activities

mfavetti

mfavetti

2023-10-11 00:41

developer   ~77614

I agree.

If the idea is to give some quick actions in the sidebar when you are scrolling down and want to do something to a specific question, fine. But all of those options should still exist on the question menu for the question that is currently being displayed. Instead of adding a small amount of convenience with the sidebar question menu, a large amount of inconvenience has been added when trying to accomplish those actions on the current question.

DenisChenu

DenisChenu

2023-11-27 12:26

developer   ~78729

https://forums.limesurvey.org/forum/design-issues/143236-where-is-the-set-conditions-button#252665

DenisChenu

DenisChenu

2023-11-30 09:03

developer   ~78815

@tibor.pacalat i really think there are an error on the Tool menu at top : it must be the question tool , but when dev do it : he confused it with the survey tool menu

tibor.pacalat

tibor.pacalat

2024-02-23 11:03

administrator   ~79603

@DenisChenu sorry for late reply, this got lost somehow :/

This should definitely be fixed.

Current situation is as seen in the screenshots. You can see the difference between the 5.x and 6.x clearly.

What needs to be done:

The question action menu in 6.x (three dots) can stay, but the same menu should be under Tools when the question is selected.

@DenisChenu @gabrieljenik who can work on this?

DenisChenu

DenisChenu

2024-02-23 11:18

developer   ~79604

I take it :)
(PS : i really need to check the @olle solution to extend Menu)

gabrieljenik

gabrieljenik

2024-02-26 13:11

manager   ~79630

From the very little I have reviewed, I believe the issue is that the wrong toolbar is being used on the question views.

riqcles

riqcles

2024-02-27 17:07

reporter   ~79667

In previous versions, I used the questionnaire logic file to see all of my questions, rather than using the structure menu.

When you have more than 80 questions and 20 groups (like the example in the video), the text search (CRT + F) allows you to find information on the question to be edited more quickly.

For example, I need to modify or create a condition:
Before :

logic file
Identifying the question
click on the question ID
opening the question in a new tab
Press the condition manager button
NOW :
Steps 1 to 4 the same, but no more step 5
So I am obliged to return to the structure and “find” my question (example: question 70) by unfolding the absence of the group (example: 17)

While it would be so simple that the tool menu which is present in the banner at the top of the question, has this functionality.

Because this tool menu takes over the functionality of the main menu of the questionnaire.

I have close to 3,000 active questionnaires (more than 200 have been created by my users since January until today), so it's not easy when I'm asked to carry out operations over some very long periods.

////////////////////////////////////////////////////////////////////////////////////////////////////
Steps to reproduce
(Create or import a questionnaire with many questions and groups (example of the Limesurvey demo in several languages)

Use the quiz logic file to add conditions to a question mid-quiz

link to explanatory video. : https://drive.google.com/file/d/11OPSfn695SkXCGrygzI6IlHKmnZCUXIC/view?usp=sharing

Expected result
Condition management is in the tool menu

Actual result
You have to return to the structure, open the group and press the 3 small dots to get the menu and choose this option
////////////////////////////////////////////////////////////////////////////////////////////////////

DenisChenu

DenisChenu

2024-02-27 18:12

developer   ~79669

@riqcles : it's assigned : Question Tool menu get back at top

DenisChenu

DenisChenu

2024-02-28 17:59

developer   ~79686

https://github.com/LimeSurvey/LimeSurvey/pull/3766

DenisChenu

DenisChenu

2024-03-04 15:09

developer   ~79709

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=36159

DenisChenu

DenisChenu

2024-03-04 15:09

developer   ~79710

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=36158

Related Changesets

LimeSurvey: master 1aad101b

2024-03-04 15:09:37

DenisChenu


Committer: GitHub Details Diff
Fixed issue 19164: Extra action button for Question are really badly placed (03766) Affected Issues
19164
mod - application/views/questionAdministration/partial/topbarBtns/questionToolsDropdownItems.php Diff File
add - application/views/questionAdministration/partial/topbarBtns/questionToolsDropdownMenu.php Diff File
mod - application/views/questionAdministration/partial/topbarBtns/questionTopbarLeft_view.php Diff File

LimeSurvey: master 1aad101b

2024-03-04 15:09:37

DenisChenu


Committer: GitHub Details Diff
Fixed issue 19164: Extra action button for Question are really badly placed (03766) Affected Issues
19164
mod - application/views/questionAdministration/partial/topbarBtns/questionToolsDropdownItems.php Diff File
add - application/views/questionAdministration/partial/topbarBtns/questionToolsDropdownMenu.php Diff File
mod - application/views/questionAdministration/partial/topbarBtns/questionTopbarLeft_view.php Diff File

Issue History

Date Modified Username Field Change
2023-10-10 17:10 DenisChenu New Issue
2023-10-10 17:10 DenisChenu File Added: 5X.png
2023-10-10 17:10 DenisChenu File Added: 6X.png
2023-10-11 00:41 mfavetti Note Added: 77614
2023-10-11 00:41 mfavetti Bug heat 0 => 2
2023-10-11 00:42 mfavetti Issue Monitored: mfavetti
2023-10-11 00:42 mfavetti Bug heat 2 => 4
2023-10-16 17:29 DenisChenu Summary Extra action button for Quetsion are really badly placed => Extra action button for Question are really badly placed
2023-10-18 10:28 marina_zbae Issue Monitored: marina_zbae
2023-10-18 10:28 marina_zbae Bug heat 4 => 6
2023-10-20 16:20 DenisChenu Relationship added related to 19179
2023-11-23 08:10 mfavetti Relationship added related to 19267
2023-11-27 12:26 DenisChenu Note Added: 78729
2023-11-27 12:26 DenisChenu Bug heat 6 => 8
2023-11-30 09:03 DenisChenu Note Added: 78815
2023-11-30 10:34 guest Bug heat 8 => 14
2024-01-16 16:23 DenisChenu Relationship added related to 19350
2024-02-23 09:52 mfavetti Relationship added has duplicate 19430
2024-02-23 09:52 mfavetti Bug heat 14 => 20
2024-02-23 10:28 c_schmitz Priority none => high
2024-02-23 10:28 c_schmitz Severity minor => block
2024-02-23 10:28 c_schmitz Bug heat 20 => 26
2024-02-23 10:31 riqcles Bug heat 26 => 28
2024-02-23 11:03 tibor.pacalat Note Added: 79603
2024-02-23 11:03 tibor.pacalat File Added: Screenshot 2024-02-23 at 10.47.21.png
2024-02-23 11:03 tibor.pacalat File Added: Screenshot 2024-02-23 at 10.47.29.png
2024-02-23 11:03 tibor.pacalat File Added: Screenshot 2024-02-23 at 10.58.12.png
2024-02-23 11:03 tibor.pacalat Bug heat 28 => 30
2024-02-23 11:18 DenisChenu Assigned To => DenisChenu
2024-02-23 11:18 DenisChenu Status new => assigned
2024-02-23 11:18 DenisChenu Note Added: 79604
2024-02-26 13:11 gabrieljenik Note Added: 79630
2024-02-26 13:11 gabrieljenik Bug heat 30 => 32
2024-02-27 17:07 riqcles Note Added: 79667
2024-02-27 17:07 riqcles Bug heat 32 => 34
2024-02-27 18:12 DenisChenu Note Added: 79669
2024-02-28 10:54 DenisChenu Relationship added related to 19448
2024-02-28 11:11 DenisChenu Assigned To DenisChenu => gabrieljenik
2024-02-28 11:11 DenisChenu Status assigned => ready for code review
2024-02-28 11:12 DenisChenu Relationship replaced has duplicate 19267
2024-02-28 11:12 DenisChenu Bug heat 34 => 42
2024-02-28 17:59 DenisChenu Note Added: 79686
2024-03-01 20:07 gabrieljenik Assigned To gabrieljenik => tibor.pacalat
2024-03-01 20:07 gabrieljenik Status ready for code review => ready for testing
2024-03-04 15:09 DenisChenu Changeset attached => LimeSurvey master 1aad101b
2024-03-04 15:09 DenisChenu Changeset attached => LimeSurvey master 1aad101b
2024-03-04 15:09 DenisChenu Note Added: 79709
2024-03-04 15:09 DenisChenu Note Added: 79710
2024-03-04 15:09 DenisChenu Assigned To tibor.pacalat => DenisChenu
2024-03-04 15:09 DenisChenu Resolution open => fixed
2024-03-04 15:09 DenisChenu Assigned To tibor.pacalat => DenisChenu
2024-03-04 15:09 DenisChenu Resolution open => fixed
2024-03-04 15:10 tibor.pacalat Status ready for testing => resolved