View Issue Details

This bug affects 4 person(s).
 28
IDProjectCategoryView StatusLast Update
18895Bug reportsTheme editorpublic2024-01-31 15:25
ReporterDenisChenu Assigned Totibor.pacalat  
PrioritynoneSeveritypartial_block 
Status resolvedResolutionfixed 
Product Version5.6.x 
Summary18895: No way to add textarea with core config.xml
Description

There are no textarea available for core config.xml

Steps To Reproduce

Steps to reproduce

Try to add a textarea via options.xml

Expected result

Have a way : type='text' rows='4' OR type='textarea'

Actual result

No way

TagsNo tags attached.
Bug heat28
Complete LimeSurvey version number (& build)6.1.4
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database type & versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 18880 resolvedgabrieljenik Unable to add imagefile except brandlogofile and backgroundimagefile in option 
related to 19049 closedtibor.pacalat Cannot export LSS from survey where theme is set to one extended from 'bootswatch' 
related to 18894 resolvedtibor.pacalat Not able to add theme option text input 

Users monitoring this issue

There are no users monitoring this issue.

Activities

Mazi

Mazi

2023-09-12 09:35

updater   ~76954

@DenisChenu, we are using a textarea for defining the template footer details at our themes via a theme option. That works fine using this code:

OPTIONS.TWIG:
<div class='row'>
<div class='col-sm-12'>
<div class='panel panel-default'>
<div class='panel-heading'>{{ gT("Footer") }}</div>
<div class='panel-body'>
<div class='form-group row'>
<label for='simple_edit_options_footer' class='control-label'>{{ gT("Footer text/copyright (HTML links supported)") }}</label>
<div class="input-group">
<textarea rows="5" cols="200" data-inheritvalue="{{oParentOptions.footer | escape}}" name="footer" class="selector_option_value_field selector__color-picker form-control simple_edit_options_footer" data-id="footer"></textarea>
</div>
</div>
</div>
</div>
</div>
</div>

CONFIG.XML:
<footer>© Company name</footer>

DenisChenu

DenisChenu

2023-09-12 10:32

developer   ~76955

Last edited: 2023-09-12 10:33

In option.twig : yes, but not by config.xml only.

I mean : i already have a options.twig : https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla/-/tree/master/options?ref_type=heads
But if i want to remove it : need toi update core.

Update the description : options.xml

Mazi

Mazi

2023-09-12 10:53

updater   ~76956

You are right, at config.xml this is missing. I have adjusted the ticket title since it was mentioning options.xml.

Mazi

Mazi

2023-09-12 10:54

updater   ~76957

@gabrieljenik, I hope you don't mind if we assign this one to you as well since this is also affecting setting theme options at config.xml so this is similar to your tickets
https://bugs.limesurvey.org/view.php?id=18880
https://bugs.limesurvey.org/view.php?id=18894

Mazi

Mazi

2023-09-13 15:26

updater   ~76990

@DenisChenu, we already have a solution for text inputs at https://bugs.limesurvey.org/view.php?id=18894. Would you be able to extend this for textareas as well? I think we really need this feature for LS 6.x templates.

Mazi

Mazi

2023-09-18 13:40

updater   ~77110

@ollehar: This issue is confirmed, but what are the next steps for fixing it? We already have a solution for text inputs at https://bugs.limesurvey.org/view.php?id=18894. Can we add support for textareas in a similar way?

ollehar

ollehar

2023-09-18 13:59

administrator   ~77115

Hm I'm not in the application team anymore, maybe ping @p_teichmann?

Mazi

Mazi

2023-10-11 14:46

updater   ~77628

@p_teichmann, @tibor.pacalat, what can we do to get this bug fixed similar to the fix for text inputs at 18894?

Mazi

Mazi

2023-11-02 12:00

updater   ~78212

@c_schmitz: At options.twig it was a piece of cake to use a textarea as theme option. When defining theme options at the config.xml, this is not doable which is a big disadvantage.
Nearly all our custom themes use a textarea for a "footer" theme option which allows them to enter simple text or HTML with links to their imprint or data privacy statements.
What can we do to support this at 6.x as well?

DenisChenu

DenisChenu

2023-11-02 12:18

developer   ~78213

Nearly all our custom themes use a textarea for a "footer" theme option which allows them to enter simple text or HTML with links to their imprint or data privacy statements.

I didn't mind for this place, interesting too.

If you use textearea : https://github.com/LimeSurvey/LimeSurvey/pull/3521 must be tested.

ollehar

ollehar

2023-11-28 09:26

administrator   ~78759

@gabrieljenik You unassigned yourself from this? At 2023-09-13.

Mazi

Mazi

2024-01-16 17:36

updater   ~79189

@tibor.pacalat, I was told to only annoy you as product owner with my questions, so here we go: What is the current status? When can we assume to get this fixed?

@c_schmitz, I'd appreciate to get some feedback to my question above (https://bugs.limesurvey.org/view.php?id=18895#c78212). Thanks!

tibor.pacalat

tibor.pacalat

2024-01-16 17:49

administrator   ~79190

@DenisChenu can you work on this?

@Mazi when Denis fixes it and I test it, it will be deployed on the next Monday as usual.

DenisChenu

DenisChenu

2024-01-18 16:09

developer   ~79218

https://github.com/LimeSurvey/LimeSurvey/pull/3703

Theme for test vanilla_style : include inline style in vanilla.

vanilla_style.zip (147,179 bytes)
DenisChenu

DenisChenu

2024-01-18 16:11

developer   ~79219

I think it's OK for 6 only since theme for 3 are compatible until 5.
Only 6 theme broke compatibility currently.

But can be done for 5

Mazi

Mazi

2024-01-24 11:16

updater   ~79307

Thanks for working on this, DeniChenu.
I agree that a fix for 5.x is not needed since only for 6.x one needs to re-create custom themes.

tibor.pacalat

tibor.pacalat

2024-01-29 16:24

administrator   ~79325

Last edited: 2024-01-29 16:25

@DenisChenu I tried adding a second textarea but it just shows one.
Am I doing something wrong or there is a bug?

tibor.pacalat

tibor.pacalat

2024-01-29 16:25

administrator   ~79326

DenisChenu

DenisChenu

2024-01-29 16:34

developer   ~79328

@DenisChenu I tried adding a second textarea but it just shows one.

Need 2 diffrent name style and style2 : attribute name give the final name.

Test with : https://bin.shnoulle.net/?014940627087a583#2XNEG2KTz4Ce9xXDL97PddwGSBhrra15pF75oBGzUn3e

       &lt;style type=&quot;textarea&quot; rows=&quot;8&quot; title=&quot;Inline style&quot; category=&quot;Style and css&quot; width=&quot;12&quot; parent=&quot;style&quot;>
/* This part is loaded as an inline style after all the included css files. */
/* The final result is partially escaped. You can use child combinator surrounded by space. */
       &lt;/style>
       &lt;style2 type=&quot;textarea&quot; rows=&quot;8&quot; title=&quot;Inline style&quot; category=&quot;Style and css&quot; width=&quot;12&quot; parent=&quot;style&quot;>
/* test a second textarea */
       &lt;/style2>
tibor.pacalat

tibor.pacalat

2024-01-29 16:50

administrator   ~79330

Ok, it works now! Is this documented in the Manual as well?

DenisChenu

DenisChenu

2024-01-29 16:51

developer   ~79331

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=36003

DenisChenu

DenisChenu

2024-01-29 16:51

developer   ~79332

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&amp;id=36002

DenisChenu

DenisChenu

2024-01-29 17:32

developer   ~79338

Ok, it works now! Is this documented in the Manual as well?

It's the same for ALL other options. I don't choose xml for options in config.xml.

I only found this for documentation : https://manual.limesurvey.org/Template_config.xml

Nothing at https://manual.limesurvey.org/Theme_editor

LimeBot

LimeBot

2024-01-30 10:18

administrator   ~79345

Fixed in Release 6.4.4+240130

Related Changesets

LimeSurvey: master bace49aa

2024-01-29 16:51:19

DenisChenu


Committer: GitHub Details Diff
Fixed issue 18895: No way to add textarea with core config.xml (#3703) Affected Issues
18895
mod - application/models/TemplateManifest.php Diff File
mod - application/views/themeOptions/options_core.php Diff File

LimeSurvey: master bace49aa

2024-01-29 16:51:19

DenisChenu


Committer: GitHub Details Diff
Fixed issue 18895: No way to add textarea with core config.xml (#3703) Affected Issues
18895
mod - application/models/TemplateManifest.php Diff File
mod - application/views/themeOptions/options_core.php Diff File

Issue History

Date Modified Username Field Change
2023-06-19 08:24 DenisChenu New Issue
2023-06-19 08:24 DenisChenu Relationship added related to 18894
2023-06-19 08:24 DenisChenu Relationship added related to 18880
2023-06-19 10:37 tibor.pacalat Bug heat 0 => 6
2023-08-25 00:51 guest Bug heat 6 => 12
2023-09-12 09:35 Mazi Note Added: 76954
2023-09-12 09:35 Mazi Bug heat 12 => 14
2023-09-12 10:32 DenisChenu Note Added: 76955
2023-09-12 10:32 DenisChenu Bug heat 14 => 16
2023-09-12 10:33 DenisChenu Summary No way to add textarea with core options.twig => No way to add textarea with core options.xml
2023-09-12 10:33 DenisChenu Description Updated
2023-09-12 10:33 DenisChenu Steps to Reproduce Updated
2023-09-12 10:33 DenisChenu Note Edited: 76955
2023-09-12 10:52 Mazi Summary No way to add textarea with core options.xml => No way to add textarea with core config.xml
2023-09-12 10:52 Mazi Description Updated
2023-09-12 10:53 Mazi Note Added: 76956
2023-09-12 10:53 Mazi Assigned To => gabrieljenik
2023-09-12 10:53 Mazi Status new => assigned
2023-09-12 10:54 Mazi Note Added: 76957
2023-09-13 14:36 gabrieljenik Assigned To gabrieljenik =>
2023-09-13 14:36 gabrieljenik Status assigned => confirmed
2023-09-13 15:26 Mazi Note Added: 76990
2023-09-18 13:40 Mazi Note Added: 77110
2023-09-18 13:59 ollehar Note Added: 77115
2023-09-18 13:59 ollehar Bug heat 16 => 18
2023-10-11 14:46 Mazi Note Added: 77628
2023-11-02 12:00 Mazi Note Added: 78212
2023-11-02 12:18 DenisChenu Note Added: 78213
2023-11-02 12:19 DenisChenu Relationship added related to 19049
2023-11-28 09:26 ollehar Note Added: 78759
2024-01-16 10:23 guest Bug heat 18 => 24
2024-01-16 17:36 Mazi Note Added: 79189
2024-01-16 17:49 tibor.pacalat Note Added: 79190
2024-01-16 17:49 tibor.pacalat Bug heat 24 => 26
2024-01-16 17:49 DenisChenu Assigned To => DenisChenu
2024-01-16 17:49 DenisChenu Status confirmed => assigned
2024-01-18 16:09 DenisChenu Note Added: 79218
2024-01-18 16:09 DenisChenu File Added: Capture d’écran du 2024-01-18 16-09-00.png
2024-01-18 16:09 DenisChenu File Added: vanilla_style.zip
2024-01-18 16:11 DenisChenu Assigned To DenisChenu => gabrieljenik
2024-01-18 16:11 DenisChenu Status assigned => ready for code review
2024-01-18 16:11 DenisChenu Complete LimeSurvey version number (& build) 5.6.25 and 6.1.3 => 6.1.4
2024-01-18 16:11 DenisChenu Note Added: 79219
2024-01-24 00:08 gabrieljenik Assigned To gabrieljenik => tibor.pacalat
2024-01-24 00:08 gabrieljenik Status ready for code review => ready for testing
2024-01-24 11:16 Mazi Note Added: 79307
2024-01-29 16:24 tibor.pacalat Note Added: 79325
2024-01-29 16:24 tibor.pacalat File Added: Screenshot 2024-01-29 at 16.23.57.png
2024-01-29 16:25 tibor.pacalat Note Added: 79326
2024-01-29 16:25 tibor.pacalat File Added: Screenshot 2024-01-29 at 16.25.20.png
2024-01-29 16:25 tibor.pacalat Note Edited: 79325
2024-01-29 16:34 DenisChenu Note Added: 79328
2024-01-29 16:50 tibor.pacalat Note Added: 79330
2024-01-29 16:51 DenisChenu Changeset attached => LimeSurvey master bace49aa
2024-01-29 16:51 DenisChenu Changeset attached => LimeSurvey master bace49aa
2024-01-29 16:51 DenisChenu Note Added: 79331
2024-01-29 16:51 DenisChenu Note Added: 79332
2024-01-29 17:32 DenisChenu Note Added: 79338
2024-01-30 10:18 LimeBot Note Added: 79345
2024-01-30 10:19 Mazi Bug heat 26 => 28
2024-01-31 15:25 tibor.pacalat Status ready for testing => resolved
2024-01-31 15:25 tibor.pacalat Resolution open => fixed