View Issue Details

This bug affects 3 person(s).
 28
IDProjectCategoryView StatusLast Update
18894Bug reportsTheme editorpublic2023-12-19 13:39
ReporterOMdev Assigned Totibor.pacalat  
PrioritynormalSeverityblock 
Status resolvedResolutionfixed 
Product Version6.1.x 
Summary18894: Not able to add theme option text input
Description

Hello - We also not able to add text fields in theme options :

https://github.com/LimeSurvey/LimeSurvey/blob/a48ae2dc3a47077fefdd88d60afc5bbf69f10347/application/views/themeOptions/options_core.php#L202

Earlier we had options.twig and we were able to add whatever needed.

Steps To Reproduce

Steps to reproduce

add text box input in config.xml

Expected result

Get text field theme option

Actual result

We dont get it

(Write here what happened instead)

TagsNo tags attached.
Bug heat28
Complete LimeSurvey version number (& build)LimeSurvey Community Edition Version 6.1.3+230612
I will donate to the project if issue is resolvedNo
Browser
Database type & versionna
Server OS (if known)
Webserver software & version (if known)
PHP Versionna

Relationships

related to 18895 resolvedtibor.pacalat No way to add textarea with core config.xml 
related to 18880 resolvedgabrieljenik Unable to add imagefile except brandlogofile and backgroundimagefile in option 

Users monitoring this issue

There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2023-06-19 08:20

developer   ~75693

Earlier we had options.twig and we were able to add whatever needed.

You can still use options.twig : https://github.com/LimeSurvey/LimeSurvey/blob/a48ae2dc3a47077fefdd88d60afc5bbf69f10347/themes/survey/vanilla/config.xml#L94

Here the type must be text, not input …

Mazi

Mazi

2023-06-19 09:57

updater   ~75698

Since using the far better structured config.xml has various advantages, I'd like to see this fixed at LS 6.x. Using the options.twig is very error prone and far more difficult to use for new users.

Mazi

Mazi

2023-06-28 11:03

updater   ~75882

@ollehar, can we please assign these theme related tickets to a developer? We are currently working on making our templates compatible with version 6.x but this holds us back.

Mazi

Mazi

2023-07-11 12:15

updater   ~76030

@ollehar, @c_schmitz: We are currently stuck adjusting/developing themes for LS 6.x due to the various issues reported to defining theme options at config.xml.
Can someone look into this?

ollehar

ollehar

2023-08-08 11:21

administrator   ~76480

@gabrieljenik Want to pick this up?

Mazi

Mazi

2023-08-08 11:49

updater   ~76485

Thanks for picking this up @ollehar.

gabrieljenik

gabrieljenik

2023-08-11 21:15

manager   ~76543

https://github.com/LimeSurvey/LimeSurvey/pull/3354
(Dev, as this is the implementation of a missing feature: text inputs on theme options)

gabrieljenik

gabrieljenik

2023-08-15 16:33

manager   ~76603

Sample theme with sample option to set subtitle on welcome screen

fruity_18894.zip (109,751 bytes)
Mazi

Mazi

2023-09-18 13:38

updater   ~77109

@gabrieljenik, this fix has the "Code review" tags for more than a month now and nothing has happened. But we need this fix for new projects.
What are the next steps?

gabrieljenik

gabrieljenik

2023-09-18 13:50

manager   ~77112

It i s up to the DEV team to review it. Sorry, not much I can do.

Mazi

Mazi

2023-09-18 14:00

updater   ~77116

@ollehar, assuming you are the boss of the DEV team: What are the next steps to finally bring this fix into the next release?

ollehar

ollehar

2023-09-18 14:01

administrator   ~77117

ping @p_teichmann have fun ;)

ollehar

ollehar

2023-09-18 14:08

administrator   ~77119

Or perhaps rather communicate with @f_funke, @Mazi.

Mazi

Mazi

2023-09-18 14:23

updater   ~77123

@ollerhar, why should I talk to @f_funke about this? To my knowledge he is not a developer? Or is he also testing bug fixes?

ollehar

ollehar

2023-09-18 15:07

administrator   ~77136

Well this was kinda a grey zone between bug fix and new feature, but fine, reminding devs about stalled bug fixes is probably OK.

Mazi

Mazi

2023-09-21 15:26

updater   ~77222

@p_teichmann, can you review so we can finally have this essential fix available at one of the next releases?

Mazi

Mazi

2023-11-02 11:57

updater   ~78211

Guys, it looks like playing ping-pong with this ticket checking the history. What are the final steps to finally get this into the next release?

@c_schmitz, many hosting customers on your end seem to be forced to switch from old 3.x to newer 6.x version soon. Without having the basic theme issues fixed, we can not help our customers using your hosting to re-build their custom 3.x themes for the new 6.x version.

p_teichmann

p_teichmann

2023-11-07 14:45

administrator   ~78313

Seems good to me, not sure if 1 line as textbox size is enough

tibor.pacalat

tibor.pacalat

2023-11-07 15:15

administrator   ~78314

Last edited: 2023-11-07 15:18

@gabrieljenik can you please resolve merge conflicts and maybe also merge develop into this branch https://github.com/LimeSurvey/LimeSurvey/pull/3354 ?

When I switch to this PR currently, and I press on Upload theme button, I get grey overlay and no modal :/

gabrieljenik

gabrieljenik

2023-11-08 12:52

manager   ~78333

All green now.

tibor.pacalat

tibor.pacalat

2023-11-09 17:48

administrator   ~78355

Last edited: 2023-11-10 14:36

@gabrieljenik with debug=2 after selecting the zip file to upload and clicking on install I am getting this error.

In case it matters, I have php 8.1

Mazi

Mazi

2023-11-13 10:01

updater   ~78404

@tibor.pacalat: Sorry for being a little annoying. But can we finally have this integrated at the upcoming release?
All these template issues really hold us back from creating LS 6.x templates for customers.

gabrieljenik

gabrieljenik

2023-11-13 14:06

manager   ~78410

@gabrieljenik with debug=2 after selecting the zip file to upload and clicking on install I am getting this error.

I will review and be back

tibor.pacalat

tibor.pacalat

2023-11-14 11:43

administrator   ~78450

@tibor.pacalat: Sorry for being a little annoying. But can we finally have this integrated at the upcoming release?
All these template issues really hold us back from creating LS 6.x templates for customers.

@Mazi sorry for holding you back, but I can't push things faster than they are going.

gabrieljenik

gabrieljenik

2023-11-16 21:09

manager   ~78504

@tibor.pacalat Ready for re-reviewal

The problem was this PR: https://github.com/LimeSurvey/LimeSurvey/pull/3376/files
It added trim without taking into account that it could be null, which is not allowed on PHP 8.1.

guest

guest

2023-12-18 12:49

viewer   ~79024

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=35879

Mazi

Mazi

2023-12-18 13:17

updater   ~79028

@gabrieljenik, is this the same fix for a different branch/LS version or another fix to get this to work fine?

gabrieljenik

gabrieljenik

2023-12-18 16:26

manager   ~79031

@gabrieljenik, is this the same fix for a different branch/LS version or another fix to get this to work fine?

Initial thought, it should work for v5 as well with not much of a hassle.

Mazi

Mazi

2023-12-18 20:17

updater   ~79037

@gabrieljenik, we just tested the previously attached demo theme yesterday. That didn't display the text field. Is it still a bug or was that because the fix was not available at the latest release yet?

gabrieljenik

gabrieljenik

2023-12-18 23:50

manager   ~79038

That didn't display the text field. Is it still a bug or was that because the fix was not available at the latest release yet?

I think this was released today

OMdev

OMdev

2023-12-19 06:46

reporter   ~79039

I have checked using : LimeSurvey Community Edition Version 6.3.9 using the template shared above [fruity_18894.zip ] by gabrieljenik 2023-08-15 16:33 and it seems to be not working. See screenshot please.

image.png (37,184 bytes)   
image.png (37,184 bytes)   
tibor.pacalat

tibor.pacalat

2023-12-19 12:23

administrator   ~79044

Last edited: 2023-12-19 12:24

@Mazi @OMdev for me it works as expected (see screenshots).

Mazi

Mazi

2023-12-19 12:58

updater   ~79045

@tibor.pacalat, which version/build did you test?

tibor.pacalat

tibor.pacalat

2023-12-19 13:38

administrator   ~79047

Last edited: 2023-12-19 13:39

6.4.0+231218 using the provided theme. But, 6.3.9 should behave the same, since this was merged in a while ago.

Related Changesets

LimeSurvey: master 03594f83

2023-11-20 14:53:08

Gabriel Jenik


Committer: GitHub Details Diff
Fixed issue 18894: Not able to add theme option text input (#3354)

Co-authored-by: lapiudevgit <devgit@lapiu.biz>
Affected Issues
18894
mod - application/controllers/admin/Themes.php Diff File
mod - application/views/themeOptions/options_core.php Diff File
mod - assets/packages/themeoptions-core/themeoptions-core.js Diff File

Issue History

Date Modified Username Field Change
2023-06-19 08:13 OMdev New Issue
2023-06-19 08:20 DenisChenu Note Added: 75693
2023-06-19 08:20 DenisChenu Bug heat 0 => 2
2023-06-19 08:24 DenisChenu Relationship added related to 18895
2023-06-19 08:31 DenisChenu Relationship added related to 18880
2023-06-19 09:57 Mazi Note Added: 75698
2023-06-19 09:57 Mazi Bug heat 2 => 4
2023-06-19 10:23 DenisChenu Bug heat 4 => 10
2023-06-19 10:37 tibor.pacalat Bug heat 10 => 16
2023-06-28 11:03 Mazi Note Added: 75882
2023-06-28 12:38 DenisChenu Summary not able to add theme option type input => not able to add theme option text input
2023-07-11 12:15 Mazi Note Added: 76030
2023-08-08 11:21 ollehar Assigned To => gabrieljenik
2023-08-08 11:21 ollehar Status new => assigned
2023-08-08 11:21 ollehar Note Added: 76480
2023-08-08 11:21 ollehar Bug heat 16 => 18
2023-08-08 11:21 ollehar Priority none => normal
2023-08-08 11:21 ollehar Summary not able to add theme option text input => Not able to add theme option text input
2023-08-08 11:49 Mazi Note Added: 76485
2023-08-11 21:15 gabrieljenik Assigned To gabrieljenik => ollehar
2023-08-11 21:15 gabrieljenik Status assigned => ready for code review
2023-08-11 21:15 gabrieljenik Note Added: 76543
2023-08-11 21:15 gabrieljenik Bug heat 18 => 20
2023-08-15 16:33 gabrieljenik Note Added: 76603
2023-08-15 16:33 gabrieljenik File Added: fruity_18894.zip
2023-09-18 13:38 Mazi Note Added: 77109
2023-09-18 13:50 gabrieljenik Note Added: 77112
2023-09-18 14:00 Mazi Note Added: 77116
2023-09-18 14:01 ollehar Note Added: 77117
2023-09-18 14:08 ollehar Note Added: 77119
2023-09-18 14:23 Mazi Note Added: 77123
2023-09-18 15:07 ollehar Note Added: 77136
2023-09-21 15:26 Mazi Note Added: 77222
2023-11-01 17:31 p_teichmann Status ready for code review => in code review
2023-11-02 10:36 p_teichmann Assigned To ollehar => p_teichmann
2023-11-02 11:57 Mazi Note Added: 78211
2023-11-07 14:45 p_teichmann Note Added: 78313
2023-11-07 14:45 p_teichmann Bug heat 20 => 22
2023-11-07 14:46 p_teichmann Assigned To p_teichmann => tibor.pacalat
2023-11-07 14:46 p_teichmann Status in code review => ready for testing
2023-11-07 15:15 tibor.pacalat Note Added: 78314
2023-11-07 15:15 tibor.pacalat Bug heat 22 => 24
2023-11-07 15:18 tibor.pacalat Note Edited: 78314
2023-11-08 12:52 gabrieljenik Note Added: 78333
2023-11-09 17:48 tibor.pacalat Note Added: 78355
2023-11-09 17:48 tibor.pacalat File Added: Screenshot 2023-11-09 at 17.31.30.png
2023-11-10 14:36 tibor.pacalat Note Edited: 78355
2023-11-13 10:01 Mazi Note Added: 78404
2023-11-13 14:06 gabrieljenik Note Added: 78410
2023-11-14 11:43 tibor.pacalat Note Added: 78450
2023-11-16 21:09 gabrieljenik Note Added: 78504
2023-11-20 14:53 tibor.pacalat Status ready for testing => resolved
2023-11-20 14:53 tibor.pacalat Resolution open => fixed
2023-12-18 12:49 Changeset attached => LimeSurvey master 03594f83
2023-12-18 12:49 guest Note Added: 79024
2023-12-18 12:49 guest Bug heat 24 => 26
2023-12-18 13:17 Mazi Note Added: 79028
2023-12-18 16:26 gabrieljenik Note Added: 79031
2023-12-18 20:17 Mazi Note Added: 79037
2023-12-18 23:50 gabrieljenik Note Added: 79038
2023-12-19 06:46 OMdev Note Added: 79039
2023-12-19 06:46 OMdev File Added: image.png
2023-12-19 06:46 OMdev Bug heat 26 => 28
2023-12-19 12:23 tibor.pacalat Note Added: 79044
2023-12-19 12:23 tibor.pacalat File Added: Screenshot 2023-12-19 at 12.13.52.png
2023-12-19 12:23 tibor.pacalat File Added: Screenshot 2023-12-19 at 12.22.36.png
2023-12-19 12:23 tibor.pacalat File Added: Screenshot 2023-12-19 at 12.22.43.png
2023-12-19 12:24 tibor.pacalat Note Edited: 79044
2023-12-19 12:58 Mazi Note Added: 79045
2023-12-19 13:38 tibor.pacalat Note Added: 79047
2023-12-19 13:39 tibor.pacalat Note Edited: 79047