View Issue Details

This bug affects 1 person(s).
 18
IDProjectCategoryView StatusLast Update
18288Bug reportsUser / Groups / Rolespublic2022-08-08 09:16
Reporterchristianl Assigned ToDenisChenu  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version5.3.x 
Fixed in Version5.3.x 
Summary18288: Can't assign groups to surveys
Description

Suddenly the option to add groups to a permission for a survey stopped working.
The groups are still there and I can assign new members to a group, but when I want to add a group to a survey, no groups are shown in the dropdown box.
For single users the behaviour is normal and I can add a user.

Steps To Reproduce

Steps to reproduce

Create gropu, add user, assign group to survey via permissions

Expected result

dropdown box shows group list

Actual result

dropdown box shows no groups

TagsNo tags attached.
Bug heat18
Complete LimeSurvey version number (& build)LimeSurvey Community Edition, Version 5.3.28+220727
I will donate to the project if issue is resolvedNo
BrowserFirefox
Database type & versionmysql
Server OS (if known)Debian Linux
Webserver software & version (if known)Apach 2.4.54
PHP Version7.4

Relationships

has duplicate 18302 closedgabrieljenik The "User Groups" are no longer displayed under "Survey Permissions". 

Users monitoring this issue

User List adelphisurveys

Activities

DenisChenu

DenisChenu

2022-07-27 17:20

developer   ~71189

The groups are still there and I can assign new members to a group, but when I want to add a group to a survey, no groups are shown in the dropdown box.

You need to be member of group (or superadmin) to see group

I can not reproduce currently.

Can you give more information :

  1. usercontrolSameGroupPolicy ?
  2. User rights on User and Group
  3. Super admin test
christianl

christianl

2022-07-27 17:25

reporter   ~71190

  1. usercontrolSameGroupPolicy is on (afaik this option is in german: Gruppenmitglieder können nur die eigene Gruppe sehen)
  2. I am the admin of the Limesurvey installation (User ID 1)

It has worked some time ago, not sure how many updates I did since the last time I used this.

DenisChenu

DenisChenu

2022-07-27 17:32

developer   ~71191

Can you activate debug mode ?

I check with or without User group control, but with superadmin : it must always show all usergroup

test on 5.3.28 git version

The last update is here : https://github.com/LimeSurvey/LimeSurvey/commit/49e2d2fcbcf0c85469243e6c2d9cf6237950e298

But the test seems clearly OK …

DenisChenu

DenisChenu

2022-07-27 17:32

developer   ~71192

@gabrieljenik : you try to confirm ? Can or can not ?

DenisChenu

DenisChenu

2022-07-27 17:34

developer   ~71193

Got it :)

gabrieljenik

gabrieljenik

2022-07-27 17:35

manager   ~71194

I will try to confirm

DenisChenu

DenisChenu

2022-07-27 17:36

developer   ~71195

Sorry Gabriel : i check on SurveyGroups not oin Surveys :)

It work on surveygroups

My merge : i fix it

DenisChenu

DenisChenu

2022-07-27 18:07

developer   ~71198

Maybe you can test : https://github.com/LimeSurvey/LimeSurvey/pull/2549

christianl

christianl

2022-07-27 18:17

reporter   ~71200

The changes fixed the problem. I can now see the user groups in the permissions section of the survey. Thanks

DenisChenu

DenisChenu

2022-07-27 19:02

developer   ~71202

I check with a limited user too : it's OK.

DenisChenu

DenisChenu

2022-08-01 18:20

developer   ~71275

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33695

LimeBot

LimeBot

2022-08-08 09:16

administrator   ~71359

Fixed in Release 5.3.30+220808

Related Changesets

LimeSurvey: master ddf11701

2022-08-01 18:20:39

DenisChenu


Committer: GitHub Details Diff
Fixed issue 18288: Can't assign groups to surveys (#2549)

Fixed issue 18297: Survey permissions menu does not work
Dev: always use getUserGroupList
Dev: this function do the filter, return all usergroup for superadmin
Affected Issues
18288, 18297
mod - application/controllers/admin/SurveyPermission.php Diff File
mod - application/helpers/common_helper.php Diff File

Issue History

Date Modified Username Field Change
2022-07-27 16:43 christianl New Issue
2022-07-27 16:59 gabrieljenik Status new => confirmed
2022-07-27 17:00 gabrieljenik Status confirmed => new
2022-07-27 17:20 DenisChenu Note Added: 71189
2022-07-27 17:20 DenisChenu Bug heat 0 => 2
2022-07-27 17:25 christianl Note Added: 71190
2022-07-27 17:25 christianl Bug heat 2 => 4
2022-07-27 17:32 DenisChenu Note Added: 71191
2022-07-27 17:32 DenisChenu Status new => feedback
2022-07-27 17:32 DenisChenu Note Added: 71192
2022-07-27 17:34 DenisChenu Assigned To => DenisChenu
2022-07-27 17:34 DenisChenu Status feedback => assigned
2022-07-27 17:34 DenisChenu Note Added: 71193
2022-07-27 17:35 gabrieljenik Note Added: 71194
2022-07-27 17:35 gabrieljenik Bug heat 4 => 6
2022-07-27 17:35 gabrieljenik Assigned To DenisChenu => gabrieljenik
2022-07-27 17:35 gabrieljenik Status assigned => acknowledged
2022-07-27 17:36 DenisChenu Assigned To gabrieljenik => DenisChenu
2022-07-27 17:36 DenisChenu Status acknowledged => assigned
2022-07-27 17:36 DenisChenu Note Added: 71195
2022-07-27 18:07 DenisChenu Assigned To DenisChenu =>
2022-07-27 18:07 DenisChenu Status assigned => ready for code review
2022-07-27 18:07 DenisChenu Note Added: 71198
2022-07-27 18:17 christianl Note Added: 71200
2022-07-27 19:02 DenisChenu Note Added: 71202
2022-08-01 18:20 DenisChenu Changeset attached => LimeSurvey master ddf11701
2022-08-01 18:20 DenisChenu Note Added: 71275
2022-08-01 18:20 DenisChenu Assigned To => DenisChenu
2022-08-01 18:20 DenisChenu Resolution open => fixed
2022-08-01 18:24 DenisChenu Status ready for code review => resolved
2022-08-01 18:24 DenisChenu Fixed in Version => 5.3.x
2022-08-04 20:49 gabrieljenik Relationship added related to 18302
2022-08-04 20:55 gabrieljenik Relationship replaced has duplicate 18302
2022-08-04 20:55 gabrieljenik Bug heat 6 => 14
2022-08-04 20:55 gabrieljenik Issue Monitored: adelphisurveys
2022-08-04 20:55 gabrieljenik Bug heat 14 => 16
2022-08-08 09:16 LimeBot Note Added: 71359
2022-08-08 09:16 LimeBot Status resolved => closed
2022-08-08 09:16 LimeBot Bug heat 16 => 18