View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
18302Bug reportsSurvey participants (Tokens)public2022-08-04 20:55
Reporteradelphisurveys Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version5.3.x 
Summary18302: The "User Groups" are no longer displayed under "Survey Permissions".
Description

I have created several "User Groups", they are also displayed normally under "Configuration" -> "User Groups". If I want to assign a group to a survey as under "Survey Permissions", the "select box" under "User Group" is empty.
Therefore I can't do "Add groups users".

I had done a manual update from 5.3.26+220720 to 5.3.29+220801.

Also, I have one more question. I had created the usergroup with 6 users and assigned 3 surveys under "Survey Permissions". This also works so far. If I now subsequently assign another user to the group, the group does not automatically update itself with the assigned surveys? Is this correct or have I just overlooked something?
So I have to go through all the surveys again and set the group permissions again myself?

Wouldn't it be nice if this would happen automatically?

Many thanks and greetings

Steps To Reproduce

I have created several "User Groups", they are also displayed normally under "Configuration" -> "User Groups". If I want to assign a group to a survey as under "Survey Permissions", the "select box" under "User Group" is empty.
Therefore I can't do "Add groups users".

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)5.3.29+220801
I will donate to the project if issue is resolvedNo
BrowserChrome Firefox
Database type & versionmysql Ver 15.1 Distrib 10.5.15-MariaDB
Server OS (if known)Debian GNU/Linux 11
Webserver software & version (if known)Server version: Apache/2.4.54 (Debian)
PHP VersionPHP 7.4.30

Relationships

duplicate of 18288 closedDenisChenu Can't assign groups to surveys 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

ollehar

ollehar

2022-08-04 17:08

administrator   ~71328

Are the user groups empty? That is, do they have any belonging users?

DenisChenu

DenisChenu

2022-08-04 17:13

developer   ~71329

https://github.com/LimeSurvey/LimeSurvey/commit/ddf117019aba385806b300392662ad7a004c36e5
no ?

gabrieljenik

gabrieljenik

2022-08-04 20:55

manager   ~71331

Last edited: 2022-08-04 20:55

18288 wasn't include in latest release.
Please, let's wait to that to release to check if that solves the issue.
If it doesn't, please, let's let us know, so we can re open this ticket.

As per...

I had created the usergroup with 6 users and assigned 3 surveys under "Survey Permissions". This also works so far.
If I now subsequently assign another user to the group, the group does not automatically update itself with the assigned surveys?
Is this correct or have I just overlooked something?
So I have to go through all the surveys again and set the group permissions again myself?
Wouldn't it be nice if this would happen automatically?

Please, can I aks you to file another ticket for that?
Not sure if a BUg or a feature request.
But anyway, please, open a new ticket.

Issue History

Date Modified Username Field Change
2022-08-04 16:14 adelphisurveys New Issue
2022-08-04 17:08 ollehar Note Added: 71328
2022-08-04 17:08 ollehar Bug heat 0 => 2
2022-08-04 17:13 DenisChenu Note Added: 71329
2022-08-04 17:13 DenisChenu Bug heat 2 => 4
2022-08-04 20:49 gabrieljenik Relationship added related to 18288
2022-08-04 20:55 gabrieljenik Assigned To => gabrieljenik
2022-08-04 20:55 gabrieljenik Status new => closed
2022-08-04 20:55 gabrieljenik Resolution open => duplicate
2022-08-04 20:55 gabrieljenik Note Added: 71331
2022-08-04 20:55 gabrieljenik Bug heat 4 => 6
2022-08-04 20:55 gabrieljenik Relationship replaced duplicate of 18288
2022-08-04 20:55 gabrieljenik Note Edited: 71331