View Issue Details

IDProjectCategoryView StatusLast Update
15327Bug reportsImport/Exportpublic2019-09-29 10:59
Reporterorvil Assigned ToDenisChenu  
PrioritynoneSeveritypartial_block 
Status closedResolutionnot fixable 
Product Version3.17.x 
Summary15327: Data export stops after exactly 980 columns
Description

When taking a survey with more than 980 fields of resulting data (that's not so much by using some larger matrix number questions) csv and xlsx output goes only till col nr 980.
Anyhow all columns (>980) are stored correctly in the database

Steps To Reproduce

some large matrix number questions will do

Additional Information

Is working fine in LS Version 2.xx (even if this is an old one)

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.18.0
I will donate to the project if issue is resolvedYes
Browserany
Database & DB-VersionmariaDB libmysql - mysqlnd 5.0.12
Server OS (if known)5.7.26-3 - (Debian)
Webserver software & version (if known)Debian
PHP Version7.2

Relationships

parent of 15340 new Feature requests Show a warning in export if max_input_vars OR allow «export ALL» 
related to 15339 new Bug reports Installer must check max_input_vars value and send a warning 
Not all the children of this issue are yet resolved or closed.

Activities

orvil

orvil

2019-09-25 05:08

reporter   ~53704

Here is a *.lss for testing. It has 8 12x11 matrix number questions for data input as example.

btw: LS shows all data collumns correctly in the "show answers" section.

orvil

orvil

2019-09-25 13:30

reporter   ~53710

Found that VV export ist working fine for all columns!

DenisChenu

DenisChenu

2019-09-26 17:00

developer   ~53721

Confirm : stop at Q8_SQ005_SQ007

image.png (2,852 bytes)   
image.png (2,852 bytes)   
DenisChenu

DenisChenu

2019-09-26 17:17

developer   ~53723

OK, linked with max_input_vars : https://manual.limesurvey.org/Troubleshooting#After_submitting_a_page.2C_you_end_up_on_the_general_index_page.2Fon_a_404_page_or_you_get_the_message_.27The_CSRF_token_could_not_be_verified.27

DenisChenu

DenisChenu

2019-09-26 17:18

developer   ~53724

When exporting a big number of response fields, not all of them are being exported

:)

DenisChenu

DenisChenu

2019-09-26 17:19

developer   ~53725

I set not fixable because ini_set didn't work on majority of system for max_input_vars

:)

Issue History

Date Modified Username Field Change
2019-09-25 04:40 orvil New Issue
2019-09-25 05:08 orvil File Added: limesurvey_survey_333256.lss
2019-09-25 05:08 orvil Note Added: 53704
2019-09-25 13:30 orvil Note Added: 53710
2019-09-26 17:00 DenisChenu File Added: image.png
2019-09-26 17:00 DenisChenu Note Added: 53721
2019-09-26 17:17 DenisChenu Note Added: 53723
2019-09-26 17:18 DenisChenu Assigned To => DenisChenu
2019-09-26 17:18 DenisChenu Status new => closed
2019-09-26 17:18 DenisChenu Resolution open => not fixable
2019-09-26 17:18 DenisChenu Note Added: 53724
2019-09-26 17:19 DenisChenu Note Added: 53725
2019-09-29 10:54 DenisChenu Relationship added related to 15339
2019-09-29 10:59 DenisChenu Relationship added parent of 15340