View Issue Details

This bug affects 1 person(s).
 40
IDProjectCategoryView StatusLast Update
15063Bug reportsSurvey editingpublic2020-06-16 08:12
ReporterDenisChenu Assigned Toc_schmitz  
PriorityimmediateSeveritycrash 
Status closedResolutionfixed 
Product Version4.0.0-RC3 
Summary15063: No surveys menu : Local Storage QuotaExceededError: The quota has been exceeded.
DescriptionSurveys menu aren't shown
Steps To ReproduceDebug > 1
Create a survey with one group/question
Go to Survey check console
Additional InformationNeed to clean Local Storage transparently
Tagssprint
Bug heat40
Complete LimeSurvey version number (& build)4.1.1 github
I will donate to the project if issue is resolvedNo
Browserff
Database type & versionnot relevant?
Server OS (if known)not relevant ?
Webserver software & version (if known)not relevant ?
PHP Versionnot relevant ?

Relationships

has duplicate 15064 closed Unable to edit aray question 
has duplicate 15356 closedmarkusfluer Side-menu breaks after importing ~8000 questions 
has duplicate 16048 closedJHoeck Only parts of the UI is rendered, buttons etc. are missing 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2019-07-20 18:03

developer  

DenisChenu

DenisChenu

2019-07-20 18:04

developer   ~52943

Last edited: 2019-07-20 18:05

View 2 revisions

````
[Vue warn]: Error in created hook: "QuotaExceededError: The quota has been exceeded."

found in

---> <Sidebar> at src/components/sidebar.vue
       <Root> vue.esm.js:628
DOMException: "The quota has been exceeded." vue.esm.js:1897
    VueJS 23
    createSideMenu adminsidepanelmain.js:68
    createPanelAppliance adminsidepanelmain.js:155
    <anonyme> adminsidepanelmain.js:186
    jQuery 2
[Vue warn]: Error in mounted hook: "QuotaExceededError: The quota has been exceeded."

found in

---> <Submenu> at src/components/subcomponents/_submenu.vue
       <Sidemenu> at src/components/subcomponents/_sidemenu.vue
         <Sidebar> at src/components/sidebar.vue
           <Root> vue.esm.js:628
DOMException: "The quota has been exceeded." vue.esm.js:1897
[Vue warn]: Error in mounted hook: "QuotaExceededError: The quota has been exceeded."

found in

---> <Submenu> at src/components/subcomponents/_submenu.vue
       <Sidemenu> at src/components/subcomponents/_sidemenu.vue
         <Sidebar> at src/components/sidebar.vue
           <Root> vue.esm.js:628
DOMException: "The quota has been exceeded." vue.esm.js:1897
[Vue warn]: Error in mounted hook: "QuotaExceededError: The quota has been exceeded."

found in

---> <Sidemenu> at src/components/subcomponents/_sidemenu.vue
       <Sidebar> at src/components/sidebar.vue
         <Root> vue.esm.js:628
DOMException: "The quota has been exceeded." vue.esm.js:1897
[Vue warn]: Error in mounted hook: "QuotaExceededError: The quota has been exceeded."

found in

---> <Questionexplorer> at src/components/subcomponents/_questionsgroups.vue
       <Sidebar> at src/components/sidebar.vue
         <Root> vue.esm.js:628
DOMException: "The quota has been exceeded." vue.esm.js:1897
[Vue warn]: Error in mounted hook: "QuotaExceededError: The quota has been exceeded."

found in

---> <Sidebar> at src/components/sidebar.vue
       <Root> vue.esm.js:628
DOMException: "The quota has been exceeded." vue.esm.js:1897
[Vue warn]: Error in mounted hook: "QuotaExceededError: The quota has been exceeded."

(found in <Root>) vue.esm.js:628
DOMException: "The quota has been exceeded." vue.esm.js:1897
Unhandled promise rejection DOMException: "The quota has been exceeded." es6.promise.js:110
Unhandled promise rejection DOMException: "The quota has been exceeded." es6.promise.js:110
Erreur dans les liens source : request failed with status 404
URL de la ressource : http://limesurvey.local/develop/assets/packages/bootstrap/bootstrap.css
URL du lien source : bootstrap.css.map
Erreur dans les liens source : request failed with status 404
URL de la ressource : http://limesurvey.local/develop/themes/admin/Sea_Green/css/lime-admin-colors.css
URL du lien source : lime-admin-colors.css.map
Erreur dans les liens source : TypeError: NetworkError when attempting to fetch resource.
URL de la ressource : moz-extension://6887d171-2694-4f4e-a73e-2a09581aa7cd/browser-polyfill.js
URL du lien source : browser-polyfill.js.map
Erreur dans les liens source : request failed with status 404
URL de la ressource : http://limesurvey.local/develop/assets/packages/lstutorial/build/lstutorial.js
URL du lien source : lstutorial.js.map
````

etc …

DenisChenu

DenisChenu

2019-07-20 18:09

developer   ~52944

Same with debug = 0 after reset assets
DenisChenu

DenisChenu

2019-07-20 18:10

developer  

DenisChenu

DenisChenu

2019-07-23 13:10

developer   ~52959

Delete whole localStorage fix the issue.

But it must be done transparently for all user/browser
cdorin

cdorin

2019-08-20 17:09

manager   ~53207

Hmm, do not have this issue (tried it with debug mode 1). COuld you confirm whether you still have it in the latest dev? Or did I test it wrongly... hmm
DenisChenu

DenisChenu

2019-08-21 01:42

developer   ~53208

@cdorin : need localStorage filled by a lot of survey , after a lot of test.
Look at console/localStorage , delete a survey : local storage still there: never deleted.
We must delete local storage : it's caching : we must not take all memory available …
fradeff

fradeff

2019-09-18 15:08

reporter   ~53627

thanks @DenisChenu:

"bug" confirmed: got exactly the same error this morning, perhaps because I'm active on many limesurvey instances on the same debian server (all are Version 3.17.16+190906)

using the same method described by Denis (clearing the local storage from ff inspector / storage) worked for me

it was not so obvious to find the fix (tried many things and finally found it by myself... Unfortunately before reaching that post!)
DenisChenu

DenisChenu

2019-09-18 15:21

developer   ~53628

Last edited: 2019-09-18 15:25

View 2 revisions

Yep,

We really need to
1. Clean up our localStorage more than currently
2. Maybe find a way to have working LimeSurvey admin without any localStorage …

https://stackoverflow.com/questions/2989284/what-is-the-max-size-of-localstorage-values and https://www.html5rocks.com/en/tutorials/offline/quota-research/
an,d https://demo.agektmr.com/storage/

Maybe move to sessionStorage : https://developer.mozilla.org/en-US/docs/Web/API/Window/sessionStorage

fradeff

fradeff

2019-09-18 17:27

reporter   ~53641

Thanks Denis for the interesting links; I must confess, 'till this morning I didnt knew anything about localStorage... so now I know a bit more - and still haven't understood the utility of this feature, and I particularly don't understand why LS need that stuff.

Wouldn't it be possible to store that in a session table on the server? A table which could be automatically emptied after a couple of days or a given period, defined in some LS config - you know, kind of a "good old time", when sessions where stored on the server, with just a simple cookie linking the client to the datas in the table? Ok, someone may argue that this means a little more usage of bandwidth, but it is really there that we need to try to minimize bandwith usage?
 
My dinosaur-old-way-of.thinking doesn't really like that new wave of excessive usage of client-side datas - and this is getting harder with working with many different devices on different places, which is (unfortunately or not) a trend that will likely increase in the future
DenisChenu

DenisChenu

2019-09-18 17:32

developer   ~53642

Hi Frederic, it's not for you, more for dev team :)

And about your issue «Maybe find a way to have working LimeSurvey admin without any localStorage …»
JHoeck

JHoeck

2019-09-30 13:48

developer   ~53745

I cant reproduce it.
DenisChenu

DenisChenu

2019-09-30 17:46

developer   ~53789

@JHoeck
> I cant reproduce it.

You need a lot lot lot of survey testing for this issue … [html5rocks](https://www.html5rocks.com/en/tutorials/offline/quota-research/) show it broke when get to 10MB with firefox and chrome.
DenisChenu

DenisChenu

2019-10-04 09:03

developer   ~53872

A solution to get it quickly
DenisChenu

DenisChenu

2019-10-04 09:05

developer   ~53873

And with `dom.storage.enabled` to false : no alert are shown, something like “Sorry, you need to activate localStorage” ?
(In my opinion : must work without local storage … (and without JS too …))
DenisChenu

DenisChenu

2019-10-04 09:13

developer   ~53874

`dom.storage.enabled` to `false` : issue in 3.8 too
DenisChenu

DenisChenu

2020-02-03 16:22

developer   ~55675

Again now, just after create a new survey with "sample question"
DenisChenu

DenisChenu

2020-02-03 16:23

developer   ~55676

Console error are more clear :)
DenisChenu

DenisChenu

2020-02-03 16:24

developer  

ollehar

ollehar

2020-02-03 16:32

administrator   ~55677

We have this in LS3 too. I set to urgent.
DenisChenu

DenisChenu

2020-04-04 11:13

developer   ~56945

My opinion : we must not use localmStorage for such data, we set in local storage something
- update a lot (if we look at question, in general we edit questin)
- not seen a lot (we look at question one or 2 times not 20 times without update)

And more : localstorage stay in browser ... ; not cleaned when not logued in ...
fjusufi

fjusufi

2020-04-09 11:58

reporter   ~57041

I have the same problem and can't seem to figure out how to use session storage, this has to be in the server side, right.
DenisChenu

DenisChenu

2020-04-09 12:15

developer   ~57043

No : browser side
DenisChenu

DenisChenu

2020-04-09 12:15

developer   ~57044

According to @ollehar comment
https://bugs.limesurvey.org/view.php?id=15063#c55677

This must be set to 3.X too, no ?
fjusufi

fjusufi

2020-04-09 12:20

reporter   ~57045

This will be hard to explain to potential clients!!!
ollehar

ollehar

2020-04-09 12:30

administrator   ~57046

The code should automatically purge the storage. A previous coder said it was fixed, but maybe it was not.
fjusufi

fjusufi

2020-04-09 12:35

reporter   ~57047

I'm using the latest Version 4.1.15+200402 and it is not fixed!
ollehar

ollehar

2020-04-09 12:36

administrator   ~57048

@fjusufi If you're a paying customer, please report it in our support channel.
Jelle_S

Jelle_S

2020-05-19 09:42

reporter   ~57896

Not a paying customer, but also experiencing this bug (4.2.2+200504, self-hosted).
ollehar

ollehar

2020-05-19 10:30

administrator   ~57897

@jelle_S Did clearing browser local storage fix it?
DenisChenu

DenisChenu

2020-05-19 10:40

developer   ~57901

Maybe we can automatically clear dom.storage just after login ?
Jelle_S

Jelle_S

2020-05-19 10:51

reporter   ~57902

Yes, clearing the storage fixed it, but not an easy process to explain to an end-user :)
ollehar

ollehar

2020-05-19 11:06

administrator   ~57903

> Maybe we can automatically clear dom.storage just after login ?

We can also configure VueX to *not* use local storage!
DenisChenu

DenisChenu

2020-05-19 11:08

developer   ~57904

> We can also configure VueX to not use local storage!

Yes , sure .

Since it's updated a lot : each time a question was updated : the storage can be outdated …
I don't understand why we use localstorage ?
c_schmitz

c_schmitz

2020-06-11 17:17

administrator   ~58251

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30121
c_schmitz

c_schmitz

2020-06-11 17:23

administrator   ~58252

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30122
c_schmitz

c_schmitz

2020-06-11 17:30

administrator   ~58253

It's not a perfect solution but it is a fast solution.
DenisChenu

DenisChenu

2020-06-11 17:35

developer   ~58254

I think it's great : movging to session seems OK for me, since when a lot of admin user work on surveys : no need top keep it …
lime_release_bot

lime_release_bot

2020-06-16 08:12

administrator   ~58297

Fixed in Release 4.3.0+200616

Related Changesets

LimeSurvey: 3.x-LTS c4ff8b6a

2020-06-11 17:17:35

c_schmitz

Details Diff
Fixed issue 15063: Left sidebar is not shown with console error Local Storage QuotaExceededError: The quota has been exceeded.
Dev Switched to session storage which is automatically cleared when session is destroyed
Affected Issues
15063
mod - assets/packages/adminsidepanel/build.min/js/adminsidepanel.js Diff File
mod - assets/packages/adminsidepanel/build/js/adminsidepanel.js Diff File
mod - assets/packages/adminsidepanel/src/store/vuex-store.js Diff File

LimeSurvey: master 99bf4e66

2020-06-11 17:22:57

c_schmitz

Details Diff
Fixed issue 15063: Left sidebar is not shown with console error Local Storage QuotaExceededError: The quota has been exceeded.
Dev Switched to session storage which is automatically cleared when session is destroyed
Affected Issues
15063
mod - assets/packages/adminbottommenu/src/store/vuex-store.js Diff File
mod - assets/packages/adminsidepanel/build.min/js/adminsidepanel.js Diff File
mod - assets/packages/adminsidepanel/build/js/adminsidepanel.js Diff File
mod - assets/packages/adminsidepanel/src/store/vuex-store.js Diff File

Issue History

Date Modified Username Field Change
2019-07-20 18:03 DenisChenu New Issue
2019-07-20 18:03 DenisChenu File Added: Capture d’écran du 2019-07-20 18-02-19.png
2019-07-20 18:04 DenisChenu Note Added: 52943
2019-07-20 18:05 DenisChenu Note Edited: 52943 View Revisions
2019-07-20 18:09 DenisChenu Note Added: 52944
2019-07-20 18:10 DenisChenu File Added: Capture d’écran du 2019-07-20 18-09-59.png
2019-07-23 13:10 DenisChenu Note Added: 52959
2019-07-23 13:10 DenisChenu Relationship added has duplicate 15064
2019-07-23 13:11 DenisChenu Summary No surveys menu => No surveys menu : Local Storage QuotaExceededError: The quota has been exceeded.
2019-07-23 13:11 DenisChenu Additional Information Updated View Revisions
2019-08-20 17:09 cdorin Assigned To => cdorin
2019-08-20 17:09 cdorin Status new => feedback
2019-08-20 17:09 cdorin Note Added: 53207
2019-08-21 01:42 DenisChenu File Added: Capture d’écran du 2019-08-21 01-39-51.png
2019-08-21 01:42 DenisChenu Note Added: 53208
2019-08-21 01:42 DenisChenu Status feedback => assigned
2019-09-18 15:08 fradeff Note Added: 53627
2019-09-18 15:21 DenisChenu Note Added: 53628
2019-09-18 15:25 DenisChenu Note Edited: 53628 View Revisions
2019-09-18 17:27 fradeff Note Added: 53641
2019-09-18 17:32 DenisChenu Note Added: 53642
2019-09-30 13:37 JHoeck Assigned To cdorin => JHoeck
2019-09-30 13:38 JHoeck Tag Attached: sprint
2019-09-30 13:48 JHoeck Note Added: 53745
2019-09-30 13:48 JHoeck Status assigned => feedback
2019-09-30 17:46 DenisChenu Note Added: 53789
2019-09-30 17:46 DenisChenu Status feedback => assigned
2019-10-04 08:58 DenisChenu Relationship added has duplicate 15356
2019-10-04 09:03 DenisChenu File Added: Capture d’écran du 2019-10-04 09-02-49.png
2019-10-04 09:03 DenisChenu Note Added: 53872
2019-10-04 09:05 DenisChenu File Added: Capture d’écran du 2019-10-04 09-04-01.png
2019-10-04 09:05 DenisChenu File Added: Capture d’écran du 2019-10-04 09-04-11.png
2019-10-04 09:05 DenisChenu Note Added: 53873
2019-10-04 09:13 DenisChenu Note Added: 53874
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing
2019-12-16 12:06 markusfluer Status assigned => resolved
2019-12-16 12:06 markusfluer Resolution open => fixed
2020-02-03 16:22 DenisChenu Status resolved => feedback
2020-02-03 16:22 DenisChenu Resolution fixed => reopened
2020-02-03 16:22 DenisChenu Complete LimeSurvey version number (& build) 4.0.0 github e5d117578b => 4.1.1 github
2020-02-03 16:22 DenisChenu Note Added: 55675
2020-02-03 16:23 DenisChenu Note Added: 55676
2020-02-03 16:23 DenisChenu Status feedback => assigned
2020-02-03 16:24 DenisChenu File Added: Capture d’écran du 2020-02-03 16-18-42.png
2020-02-03 16:32 ollehar Note Added: 55677
2020-02-03 16:32 ollehar Priority none => urgent
2020-02-03 16:32 ollehar Severity minor => crash
2020-03-27 09:19 DenisChenu Relationship added has duplicate 16048
2020-04-04 11:13 DenisChenu File Added: Capture d’écran du 2020-04-04 11-12-06.png
2020-04-04 11:13 DenisChenu Note Added: 56945
2020-04-09 11:58 fjusufi Note Added: 57041
2020-04-09 12:15 DenisChenu Note Added: 57043
2020-04-09 12:15 DenisChenu Note Added: 57044
2020-04-09 12:20 fjusufi Note Added: 57045
2020-04-09 12:30 ollehar Note Added: 57046
2020-04-09 12:35 fjusufi Note Added: 57047
2020-04-09 12:36 ollehar Note Added: 57048
2020-05-19 09:42 Jelle_S Note Added: 57896
2020-05-19 10:30 ollehar Note Added: 57897
2020-05-19 10:30 ollehar Priority urgent => immediate
2020-05-19 10:40 DenisChenu Note Added: 57901
2020-05-19 10:51 Jelle_S Note Added: 57902
2020-05-19 11:06 ollehar Note Added: 57903
2020-05-19 11:08 DenisChenu Note Added: 57904
2020-06-11 17:17 c_schmitz Changeset attached => LimeSurvey 3.x-LTS c4ff8b6a
2020-06-11 17:17 c_schmitz Note Added: 58251
2020-06-11 17:17 c_schmitz Assigned To JHoeck => c_schmitz
2020-06-11 17:17 c_schmitz Resolution reopened => fixed
2020-06-11 17:23 c_schmitz Changeset attached => LimeSurvey master 99bf4e66
2020-06-11 17:23 c_schmitz Note Added: 58252
2020-06-11 17:30 c_schmitz Status assigned => resolved
2020-06-11 17:30 c_schmitz Note Added: 58253
2020-06-11 17:35 DenisChenu Note Added: 58254
2020-06-16 08:12 lime_release_bot Note Added: 58297
2020-06-16 08:12 lime_release_bot Status resolved => closed