View Issue Details

IDProjectCategoryView StatusLast Update
09106Bug reports[All Projects] Accessibilitypublic2018-05-23 12:30
ReporterDenisChenuAssigned ToLouisGac 
PrioritynormalSeverityminor 
Status closedResolutionwon't fix 
Product Version2.06+ 
Target VersionFixed in Version 
Summary09106: Add some 'error' in tite and list error before showing question
Description

For accessibility and usuability : some Accessiblity guide ask

  • When a form is submited and have error : Add an element in title tage with 'This page have error'
  • When a form is submitted : show the list of errors before the form (and usuability : add anchor in this list to go quickly to this error.
Steps To Reproduce

No step ...

Additional Information

Settings 'showpopups' to false show only a 'This page have error'. We don't have a way to replace it in plugin.
Think Add the 'This page have error' can be very difficult in plugin.

And think all accessibility and usuability issue must be in core (maybe in optionnal plugin but put in LS default distribution).

For the accessibility system i search in my email from different list but sure i have it ;)

TagsNo tags attached.
Complete LimeSurvey version number (& build)
I will donate to the project if issue is resolved
Browser
Database & DB-Version
Server OS (if known)
Webserver software & version (if known)
PHP Version

Relationships

related to 10389 closedLouisGac Validation Messages in public survey are not really informative 

Activities

cortxdp

cortxdp

2015-10-23 15:41

reporter   ~33434

Last edited: 2015-10-23 15:45

View 6 revisions

I second this proposition.
I suggest adding a template and a keyword to generate a list of error message with link to the specific question.
See file attached
.

cortxdp

cortxdp

2015-10-23 15:45

reporter  

error list limesurvey.txt (755 bytes)
Adding the following template (ex : Validation error)

<!-- To be used when returning from validation. The focus should be put here. Another request should be made for this feature. -->
<a id="error-list" ></a> 
<!--Change heading to fit your template. I use h2 since h1 is the main content of my page, i.e. my survey name. You can use h3 if you uss question group and it's your h2. etc.-->
<h2>Error list, please correct these an resubmit the form</h2> 
{ERRORLIST}


The keyword should generate this 


<ul class="error-list">
<li><a href="[questionid]">[specific validation message] </a></li>
<li><a href="[questionid]">[specific validation message] </a></li>
<li><a href="[questionid]">[specific validation message] </a></li>
</ul>

DenisChenu

DenisChenu

2016-02-05 08:36

developer   ~34611

Using keyword seems a good idea. But actually : EM return easily error : 0/1 for a whole page, but less easily :
qid=>error type,
qid=>error type

etc ...

LouisGac

LouisGac

2018-05-23 12:30

manager   ~47782

not relevant anymore

Issue History

Date Modified Username Field Change
2014-06-20 10:27 DenisChenu New Issue
2015-10-23 15:41 cortxdp Note Added: 33434
2015-10-23 15:42 cortxdp Note Edited: 33434 View Revisions
2015-10-23 15:42 cortxdp Note Edited: 33434 View Revisions
2015-10-23 15:43 cortxdp Note Edited: 33434 View Revisions
2015-10-23 15:44 cortxdp Note Edited: 33434 View Revisions
2015-10-23 15:45 cortxdp File Added: error list limesurvey.txt
2015-10-23 15:45 cortxdp Note Edited: 33434 View Revisions
2016-02-05 08:36 DenisChenu Note Added: 34611
2016-02-05 08:38 DenisChenu Project Development => Bug reports
2016-02-05 08:39 DenisChenu Product Version 2.05 => 2.06+
2016-02-11 13:32 DenisChenu Relationship added related to 10389
2018-05-23 12:30 LouisGac Assigned To => LouisGac
2018-05-23 12:30 LouisGac Status new => closed
2018-05-23 12:30 LouisGac Resolution open => won't fix
2018-05-23 12:30 LouisGac Note Added: 47782