View Issue Details

IDProjectCategoryView StatusLast Update
08859Bug reports[All Projects] Expression Managerpublic2014-04-04 10:26
ReporterMazi Assigned Toc_schmitz  
PrioritynormalSeverityminor 
Status closedResolutionno change required 
Product Version2.05+ 
Target Version2.05+Fixed in Version 
Summary08859: Using .question syntax auto-adds additional text
Description

When trying to display the subquestion text of a question using questioncode_subquestioncode.question this doesn't work for Array Texts/Numbers/Dual scale.

For Array Texts/Numbers one has to use:
questioncode_subquestioncode_answercode.question

For Array Dual Scale one has to use:
questioncode_subquestioncode_scaleID.question (with scaleID being 0 or 1).

When using the above syntax, Limesurvey automatically adds the answer code or scale number, examples:
Research[Manager]
VW Passat[Scale 1]

Steps To Reproduce

Import the attached survey, run it and check the array text/numbers/dual scale placeholders at the overview on page 2.

TagsNo tags attached.
Complete LimeSurvey version number (& build)140226
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome
Database & DB-VersionMySQL 5
Server OS (if known)Linux
Webserver software & version (if known)Apache
PHP Version5.3

Relationships

related to 08858 resolvedDenisChenu Feature requests Extend EM so we can get the question text of multiple choice and array questions via questioncode.question 

Activities

Mazi

Mazi

2014-03-14 14:48

partner  

limesurvey_survey_631298.lss (32,318 bytes)
Mazi

Mazi

2014-03-14 14:49

partner  

placeholders.png (1,924 bytes)
placeholders.png (1,924 bytes)
c_schmitz

c_schmitz

2014-03-19 11:20

administrator   ~29391

After some consideration I think this is not a bug but a missing feature as detailed by mfaber.

Mazi

Mazi

2014-03-24 16:51

partner   ~29523

Carsten, at this report I am not complaining about the weird syntax to be used to reference the texts (that is reported at issue 08858) but about the auto-added texts.
Using that syntax is absolutely fine with me but the auto-added texts are annoying and make a working solution unusable.

c_schmitz

c_schmitz

2014-03-24 17:40

administrator   ~29524

The texts are there for a reason. If removed other people will complain that they were removed as they mark a certain column/row combination

Mazi

Mazi

2014-03-24 18:27

partner   ~29526

Well, that argument always counts but I can see no reasons for auto-adding these texts when using placeholders as described above:
"For Array Texts/Numbers one has to use:
questioncode_subquestioncode_answercode.question

For Array Dual Scale one has to use:
questioncode_subquestioncode_scaleID.question (with scaleID being 0 or 1)."

-> At the first example the result reads "Research[Manager]" though the text being displayed is independent from the column ("Manager").

-> At the second example it adds the scale number: "VW Passat[Scale 1]" and again this makes no sense since the text is the same for both scales.

From my point of view this is a wrong results of placeholder usage and hopefully someone can at least have a look at the code details to determine whether this can be fixed more or less easily.

c_schmitz

c_schmitz

2014-03-25 07:29

administrator   ~29528

Last edited: 2014-03-25 07:29

View 2 revisions

What you are looking for is

questioncode_subquestioncode.question

which is currently not available for EM.

c_schmitz

c_schmitz

2014-04-04 10:26

administrator   ~29662

2.05+ Build 140404 released.

Issue History

Date Modified Username Field Change
2014-03-14 14:46 Mazi New Issue
2014-03-14 14:48 Mazi File Added: limesurvey_survey_631298.lss
2014-03-14 14:48 Mazi Relationship added related to 08858
2014-03-14 14:49 Mazi File Added: placeholders.png
2014-03-19 10:24 c_schmitz Assigned To => c_schmitz
2014-03-19 10:24 c_schmitz Status new => assigned
2014-03-19 11:20 c_schmitz Note Added: 29391
2014-03-19 11:20 c_schmitz Status assigned => closed
2014-03-19 11:20 c_schmitz Resolution open => no change required
2014-03-24 16:51 Mazi Note Added: 29523
2014-03-24 16:51 Mazi Status closed => feedback
2014-03-24 16:51 Mazi Resolution no change required => reopened
2014-03-24 16:51 Mazi Status feedback => assigned
2014-03-24 17:40 c_schmitz Note Added: 29524
2014-03-24 18:27 Mazi Note Added: 29526
2014-03-25 07:29 c_schmitz Note Added: 29528
2014-03-25 07:29 c_schmitz Note Edited: 29528 View Revisions
2014-03-28 14:40 c_schmitz Status assigned => resolved
2014-03-28 14:40 c_schmitz Resolution reopened => no change required
2014-04-04 10:26 c_schmitz Note Added: 29662
2014-04-04 10:26 c_schmitz Status resolved => closed