Anonymous Login
2016-10-22 23:26 CEST

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
08038Bug reports[All Projects] Theme editorpublic2013-11-04 12:11
Assigned ToDenisChenu 
Product Version2.00+ 
Target Version2.00+Fixed in Version2.00+ 
Summary08038: Can't upload image files to a custom template
DescriptionOn a certain server I am having problems uploading files to a custom template. The LS system is hosted at godaddy and I also had problems with the famous "No input file specified" problem there, see

When trying to upload a simple png file, I get redirected from my custom template to the default template and no file is uploaded.
Even with debug set to "2", bo errors are shown.
After redirect, the URL also looks weird:

I tried the same on another server using the same Limesurvey build and it all works fine there, so I assume it has to do with godaddy and maybe problems with the URL (see link above).

I also tried setting the urlFormat to "path", but then I ran into the "No input file specified" problem, so that setting currently is set to "get".
Steps To Reproduce1. Create a copy of a shipped template (this works fine).

2. Try to upload a file.

3. You get redirected to
Additional InformationI checked file permissions and both folders /tmp and /upload/* and all files within have rights 777.

Server access can be granted on request.

I also noticed problems with the "show phpinfo" function at global settings. It just opens the global settings screen in a new tab using URL
while on my other server the URL is

If I enter that last part of the URL (index.php/admin/globalsettings/showphpinfo) at the buggy server, I run into the "no input file specified" problem again.

phpinfo details attached
TagsNo tags attached.
Complete LimeSurvey version number (& build)130708
I will donate to the project if issue is resolvedNo
Database & DB-VersionMySQL 5
Operating System (Server)Linux
Webserver software & versionApache
PHP Version5.3.24
Attached Files

parent of 08332closedc_schmitz JS files are not imported during template import 



DenisChenu (developer)

Fix committed to master branch:


DenisChenu (developer)

Fix committed to 2.05 branch:


DenisChenu (developer)

Just sa/ problem. Fix to for phpinfo.

And think you're happy to be allowed to upload js file ;)


c_schmitz (administrator)

2.00+ Build 130802 released

+Related Changesets

-Issue History
Date Modified Username Field Change
2013-07-23 13:01 Mazi New Issue
2013-07-23 13:01 Mazi Status new => assigned
2013-07-23 13:01 Mazi Assigned To => DenisChenu
2013-07-23 13:01 Mazi File Added: phpinfo.pdf
2013-07-30 23:51 DenisChenu Changeset attached => LimeSurvey master a69a383c
2013-07-30 23:51 DenisChenu Note Added: 25896
2013-07-30 23:51 DenisChenu Resolution open => fixed
2013-07-31 00:15 DenisChenu Changeset attached => LimeSurvey 2.05 2f6b4ae3
2013-07-31 00:15 DenisChenu Note Added: 25897
2013-07-31 00:16 DenisChenu Note Added: 25898
2013-07-31 00:16 DenisChenu Status assigned => resolved
2013-07-31 00:16 DenisChenu Fixed in Version => 2.00+
2013-08-04 21:54 c_schmitz Note Added: 25915
2013-08-04 21:54 c_schmitz Status resolved => closed
2013-11-04 12:11 c_schmitz Relationship added parent of 08332
2015-12-11 14:40 c_schmitz Category Templates => Theme editor
+Issue History