View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
18027Bug reportsLabel setspublic2022-05-16 11:19
ReportersdsAdm1n Assigned Togabrieljenik  
PrioritynoneSeveritycrash 
Status closedResolutionfixed 
Product Version5.2.x 
Summary18027: Unable to create a label set
Description

after installing latest version of LS, i tried to create a new label set. however, below are the issues i am facing:

  1. For two languages label set creation:
    I tried to add only one item using the quick add feature, and then click on Save button, but Limesurvey redirects me to KCfinder resources file uploader as per below screen shot.
  2. For single language label set creation:
    first item added normally, but whenever to I click add button to insert one new item, the new item shows to the side instead of underneath and the item get save immediately before i can specify the label text as per the second screen shot.
Steps To Reproduce

Steps to reproduce

Go to Label Sets, click to create a new label set with multiple languages
Use quick add to define label items.
click save button

Expected result

label items get saved

Actual result

KCfinder open in a new page with a message saying "You don't have permissions to browse server" and items are not stored

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)Version 5.3.8+220404
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome
Database type & versionMS SQL Server 2016
Server OS (if known)Win Server 2019
Webserver software & version (if known)IIS 10
PHP Version7.4

Relationships

related to 18040 testinggabrieljenik Add buttons submit the whole labelset instead of only adding a row 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

sdsAdm1n

sdsAdm1n

2022-04-11 07:03

reporter  

Multilanguage label set.png (21,880 bytes)   
Multilanguage label set.png (21,880 bytes)   
One Language label list.png (52,637 bytes)   
One Language label list.png (52,637 bytes)   
gabrieljenik

gabrieljenik

2022-04-13 14:03

manager   ~69051

PR: https://github.com/LimeSurvey/LimeSurvey/pull/2347

sdsAdm1n

sdsAdm1n

2022-04-14 10:44

reporter   ~69067

Thank you Gabriel, I have applied the suggested fix. seems like quick add is working fine, but for one by one insertion, the issue is still showing as per the photo

One Language label list-2.png (52,637 bytes)   
One Language label list-2.png (52,637 bytes)   
gabrieljenik

gabrieljenik

2022-04-18 22:37

manager   ~69111

Thanks @sdsAdm1n.
I have updated the PR.

gabrieljenik

gabrieljenik

2022-05-10 12:07

manager   ~69538

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33474

LimeBot

LimeBot

2022-05-16 11:19

administrator   ~69658

Fixed in Release 5.3.14+220516

Related Changesets

LimeSurvey: master a8ef77c6

2022-05-10 12:07:22

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 18027: Unable to create a label set (#2347)

Co-authored-by: encuestabizdevgit <devgit@encuesta.biz>
Affected Issues
18027
mod - application/views/admin/labels/_labelviewtabcontent_view.php Diff File
mod - assets/scripts/admin/labels.js Diff File

Issue History

Date Modified Username Field Change
2022-04-11 07:03 sdsAdm1n New Issue
2022-04-11 07:03 sdsAdm1n File Added: Multilanguage label set.png
2022-04-11 07:03 sdsAdm1n File Added: One Language label list.png
2022-04-11 12:46 galads Assigned To => gabrieljenik
2022-04-11 12:46 galads Status new => assigned
2022-04-13 14:03 gabrieljenik Note Added: 69051
2022-04-13 14:03 gabrieljenik Bug heat 0 => 2
2022-04-13 14:03 gabrieljenik Status assigned => testing
2022-04-14 10:44 sdsAdm1n Note Added: 69067
2022-04-14 10:44 sdsAdm1n File Added: One Language label list-2.png
2022-04-14 10:44 sdsAdm1n Bug heat 2 => 4
2022-04-14 15:00 gabrieljenik Status testing => assigned
2022-04-18 22:37 gabrieljenik Note Added: 69111
2022-04-18 22:37 gabrieljenik Status assigned => testing
2022-04-18 22:41 gabrieljenik Issue cloned: 18040
2022-04-18 22:41 gabrieljenik Relationship added related to 18040
2022-05-10 12:07 gabrieljenik Changeset attached => LimeSurvey master a8ef77c6
2022-05-10 12:07 gabrieljenik Note Added: 69538
2022-05-10 12:07 gabrieljenik Resolution open => fixed
2022-05-16 11:19 LimeBot Note Added: 69658
2022-05-16 11:19 LimeBot Status testing => closed
2022-05-16 11:19 LimeBot Bug heat 4 => 6