View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
16741Bug reportsStatisticspublic2020-12-28 10:42
Reportercdorin Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.3.24 
Summary16741: Filtering on responses for questions of type Array Dual Scale was not working in Statistics
DescriptionIn Statistics, Filtering on responses for questions of type Array Dual Scale was not working at all: Results were not respecting those filters, and the selections in those selectors were lost on the results page.
Steps To ReproduceTo reproduce: Just create a one-question survey with a dual array dual scale question and their sub-questions. Or use an example from the man page https://manual.limesurvey.org/Question_type_-_Array_dual_scale . Then fill-in one survey, and go to admin results statistics. In Response Filters select one of the dual-scale answers that was NOT selected in that test survey.

Expected result: 0 out of 1 shown and selection in Response Filter still selected.
Actual result: 1 out of 1 shown and Response Filter selection lost.
After applying PR: Result becomes as expected.
Additional InformationAnalysis and fixes:
Those filters' multi-selects were ignored in the filtering because their select names were wrong: E.g.:
Actual wrong: select name="956915X67X519SQ001#{0}[]" and select name="956915X67X519SQ001#{1}[]"
Expected correct: select name="956915X67X519SQ001#0[]" and select name="956915X67X519SQ001#1[]"

Additionally, once fixed, an html comment above was generating a warning because they supposed strings and got arrays of strings. This PR fixes both of them.
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)LimeSurvey master
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionirrelevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionirrelevant

Activities

cdorin

cdorin

2020-10-15 16:16

manager   ~60216

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1062
gabrieljenik

gabrieljenik

2020-11-03 15:46

manager   ~60508

This ticket applies to master. While 16746 applies for LTS
gabrieljenik

gabrieljenik

2020-11-12 15:27

manager   ~60626

New PR: https://github.com/LimeSurvey/LimeSurvey/pull/1653
gabrieljenik

gabrieljenik

2020-12-15 23:10

manager   ~60973

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30807
lime_release_bot

lime_release_bot

2020-12-28 10:42

administrator   ~61177

Fixed in Release 4.3.32+201221

Related Changesets

LimeSurvey: master 4eb9724e

2020-12-15 23:08:28

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16741: Filtering on responses for questions of type Array Dual Scale was not working in Statistics (#1653)

* Fixed issue 16741: Filtering on responses for questions of type Array Dual Scale was not working in Statistics

* Fixed issue 16741: Filtering on responses for questions of type Array Dual Scale was not working in Statistics

Dummy change to trigger travis
Affected Issues
16741
mod - application/views/admin/export/statistics_subviews/_question.php Diff File

Issue History

Date Modified Username Field Change
2020-10-15 16:16 cdorin New Issue
2020-10-15 16:16 cdorin Note Added: 60216
2020-10-15 16:16 cdorin Status new => confirmed
2020-11-03 15:46 gabrieljenik Note Added: 60508
2020-11-03 15:48 gabrieljenik Assigned To => gabrieljenik
2020-11-03 15:48 gabrieljenik Status confirmed => assigned
2020-11-03 15:48 gabrieljenik Product Version => 4.3.24
2020-11-12 15:27 gabrieljenik Note Added: 60626
2020-12-15 23:10 gabrieljenik Changeset attached => LimeSurvey master 4eb9724e
2020-12-15 23:10 gabrieljenik Note Added: 60973
2020-12-15 23:10 gabrieljenik Resolution open => fixed
2020-12-28 10:42 lime_release_bot Note Added: 61177
2020-12-28 10:42 lime_release_bot Status assigned => closed