View Issue Details

IDProjectCategoryView StatusLast Update
16746Bug reportsStatisticspublic2020-11-16 09:31
Reportervharris Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.24.1 
Summary16746: Filtering on responses for questions of type Array Dual Scale was not working in Statistics
Description

In Statistics, Filtering on responses for questions of type Array Dual Scale was not working at all: Results were not respecting those filters, and the selections in those selectors were lost on the results page.

Steps To Reproduce

To reproduce: Just create a one-question survey with a dual array dual scale question and their sub-questions. Or use an example from the man page https://manual.limesurvey.org/Question_type_-_Array_dual_scale . Then fill-in one survey, and go to admin results statistics. In Response Filters select one of the dual-scale answers that was NOT selected in that test survey.

Expected result: 0 out of 1 shown and selection in Response Filter still selected.
Actual result: 1 out of 1 shown and Response Filter selection lost.
After applying PR: Result becomes as expected.

Additional Information

Analysis and fixes:
Those filters' multi-selects were ignored in the filtering because their select names were wrong: E.g.:
Actual wrong: select name="956915X67X519SQ001#{0}[]" and select name="956915X67X519SQ001#{1}[]"
Expected correct: select name="956915X67X519SQ001#0[]" and select name="956915X67X519SQ001#1[]"

Additionally, once fixed, an html comment above was generating a warning because they supposed strings and got arrays of strings. This PR fixes both of them.

TagsNo tags attached.
Complete LimeSurvey version number (& build)LimeSurvey LTS
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browser
Database & DB-VersionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionN/A

Activities

gabrieljenik

gabrieljenik

2020-11-03 15:51

developer   ~60509

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1641

gabrieljenik

gabrieljenik

2020-11-10 12:40

developer   ~60604

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30715

lime_release_bot

lime_release_bot

2020-11-16 09:31

administrator   ~60647

Fixed in Release 3.25.0+201117

Related Changesets

LimeSurvey: 3.x-LTS 3d11b46d

2020-11-10 12:39:54

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16746: Filtering on responses for questions of type Array Dual Scale was not working in Statistics (#1641)

Applied changes from https://github.com/LimeSurvey/LimeSurvey/pull/1062 to LTS
Affected Issues
16746
mod - application/views/admin/export/statistics_subviews/_question.php Diff File

Issue History

Date Modified Username Field Change
2020-10-16 15:05 vharris New Issue
2020-11-03 15:51 gabrieljenik Note Added: 60509
2020-11-10 12:40 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS 3d11b46d
2020-11-10 12:40 gabrieljenik Note Added: 60604
2020-11-10 12:40 gabrieljenik Assigned To => gabrieljenik
2020-11-10 12:40 gabrieljenik Resolution open => fixed
2020-11-16 09:31 lime_release_bot Note Added: 60647
2020-11-16 09:31 lime_release_bot Status new => closed