View Issue Details

IDProjectCategoryView StatusLast Update
16339Bug reportsPluginspublic2021-04-30 16:19
Reporterbismark Assigned Togabrieljenik  
PrioritynoneSeverityblock 
Status resolvedResolutionfixed 
Product Version3.22.17 
Summary16339: pluginhelper fullpagewrapper doesnt show content
Description`index.php/admin/pluginhelper?sa=fullpagewrapper&plugin=...&method=...`

- sidebody will be shown, which is wrong
- plugin content doesnt appear
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.xLTS
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version10.1.26-MariaDB
Server OS (if known)
Webserver software & version (if known)
PHP Version7.3.15

Activities

Mazi

Mazi

2020-05-28 12:58

partner   ~58069

@bismark: Please also mention at which version this was still working fine.

@cdorin: We use this at a plugin which worked fine a few months ago but is now broken. Please fix ASAP.
bismark

bismark

2020-05-28 15:00

reporter   ~58073

Last edited: 2021-04-27 16:15

version 3.17.15 was ok, 3.17.16+ not
bismark

bismark

2020-06-02 15:01

reporter   ~58139

Last edited: 2021-04-27 16:15

@cdorin any progress on that issue?
cdorin

cdorin

2020-06-02 15:47

manager   ~58141

Last edited: 2021-04-27 16:15

No progress so far, unfortunately - other tasks have been assigned to the devs this sprint.
Mazi

Mazi

2020-06-02 16:11

partner   ~58142

Last edited: 2021-04-27 16:15

So we have to wait at least another 2 weeks until this gets added to the next sprint and probably 2 more weeks so a fix gets provided?

That is bad for a project that should start in 1-2 weeks. Especially, since the same plugin worked fine at 3.17.x.

c_schmitz, when do we get back the old times at which I could report an urgent issue related to a customer project and then a fix was provided within a few days without planning sprints?
bismark

bismark

2020-06-02 16:48

reporter   ~58143

Last edited: 2021-04-27 16:15

All I can say is, that the plugin returns the content correctly.
the content is available in the source code of the page, but html is probably broken.

any js stuff? vue? adminbasics?
cdorin

cdorin

2020-06-02 17:11

manager   ~58144

Last edited: 2021-04-27 16:15

While I do understand your concerns, we just simply do not have the resources at the moment for that. But I would be more than happy to check a PR from you or somebody else and merge it asap.
Mazi

Mazi

2020-06-02 17:14

partner   ~58145

Last edited: 2021-04-27 16:15

Sorry, we are not familiar with that vueJS stuff (if that causes the issue). I can only state that it worked fine ago and I still think it is not the partners task to fix new bugs. We already paid someone to fix https://bugs.limesurvey.org/view.php?id=16214.
bismark

bismark

2020-06-03 01:04

reporter   ~58149

Last edited: 2021-04-27 16:15

maybe this commit causes trouble: https://github.com/LimeSurvey/LimeSurvey/commit/575576221f89b4dbfdead4ae02b3fe249923359d
DenisChenu

DenisChenu

2020-06-03 09:00

developer   ~58150

Last edited: 2021-04-27 16:15

> We already paid someone to fix ?

I don't ask money ?
DenisChenu

DenisChenu

2020-06-03 09:11

developer   ~58152

Last edited: 2021-04-27 16:15

Else : this one work in 3.X : /index.php?r=admin/pluginhelper&sa=sidebody&plugin=TEST&method=actionSettings

````
    public function actionSettings($surveyId = null)
    {
        if(empty($surveyId)) {
            return "TEST";
        }
        // Do something , my real plugin
````
bismark

bismark

2020-06-03 11:18

reporter   ~58154

Last edited: 2021-04-27 16:15

@DenisChenu we talk about sa=fullpagewrapper, sidebody works as expected
DenisChenu

DenisChenu

2020-06-03 11:18

developer   ~58155

Last edited: 2021-04-27 16:15

Yes, i know :) it's for an alternative way to do (i never use fullpagewrapper)
ollehar

ollehar

2021-03-03 15:29

administrator   ~62671

Last edited: 2021-04-27 16:15

Please check if this bug still exists in the latest patch release. Thank you.
bismark

bismark

2021-04-21 21:18

reporter   ~64096

Last edited: 2021-04-27 16:15

no, fullpagewrapper is not working correctly
ollehar

ollehar

2021-04-22 09:37

administrator   ~64102

Last edited: 2021-04-27 16:15

Alright. Hm, we have a plugin we can test with?
Mazi

Mazi

2021-04-22 14:47

partner   ~64112

Last edited: 2021-04-27 16:15

@bismark, can you upload a simple plugin which shows the problem?

@ollehar, after Marko has uploaded a sample plugin, please temporarily turn this into a private ticket.
ollehar

ollehar

2021-04-22 14:50

administrator   ~64113

Last edited: 2021-04-27 16:15

Sure. Just ping me.
gabrieljenik

gabrieljenik

2021-04-27 16:14

manager   ~64168

Last edited: 2021-04-27 16:15

To clarify the problem: the fullpagewrapper works fine, unless one of the parameters in the URL is the survey id.

In that case the side menu appears because the layout_insurvey.php is used.

The _renderWrappedTemplate function of Survey_Common_Action.php decides that this layout should be used when the data in the view ($ aData) includes the "surveyid".

Until version 3.17.15, when you used the fullpagewrapper it worked fine even if you put a survey id in the URL. The problem is that from the commit de7707d700d1304110eca1e12fd22b3aa1d011b7 some parameters such as the survey id are included in the $ aData (it is not included by the helper plugin, but by Survey_Common_Action itself).

The solution then is for the helper plugin to explicitly specify that the layout_main.php must be used.

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1858
bismark

bismark

2021-04-27 16:18

reporter   ~64169

@gabrieljenik I didnt test, but it sounds good
thumbs up, thank you
gabrieljenik

gabrieljenik

2021-04-27 17:09

manager   ~64170

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31643
gabrieljenik

gabrieljenik

2021-04-29 14:42

manager   ~64187

PR for v4: https://github.com/LimeSurvey/LimeSurvey/pull/1860
gabrieljenik

gabrieljenik

2021-04-30 16:19

manager   ~64205

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31652

Related Changesets

LimeSurvey: 3.x-LTS 6187bf4a

2021-04-27 17:09:09

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16339: Plugin helper fullpagewrapper doesnt show content (#1858)

Co-authored-by: encuestabizdevgit <devgit@encuesta.biz>
Affected Issues
16339
mod - application/controllers/admin/PluginHelper.php Diff File

LimeSurvey: master 8338259a

2021-04-30 16:19:40

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16339: pluginhelper fullpagewrapper doesnt show content (#1860)

Co-authored-by: encuestabizdevgit <devgit@encuesta.biz>
Affected Issues
16339
mod - application/controllers/admin/PluginHelper.php Diff File

Issue History

Date Modified Username Field Change
2020-05-28 12:17 bismark New Issue
2020-05-28 12:58 Mazi Note Added: 58069
2020-05-28 15:00 bismark Note Added: 58073
2020-06-02 15:01 bismark Note Added: 58139
2020-06-02 15:47 cdorin Note Added: 58141
2020-06-02 16:11 Mazi Note Added: 58142
2020-06-02 16:48 bismark Note Added: 58143
2020-06-02 17:11 cdorin Note Added: 58144
2020-06-02 17:14 Mazi Note Added: 58145
2020-06-03 01:04 bismark Note Added: 58149
2020-06-03 09:00 DenisChenu Note Added: 58150
2020-06-03 09:11 DenisChenu Note Added: 58152
2020-06-03 09:11 DenisChenu File Added: Capture d’écran du 2020-06-03 09-11-28.png
2020-06-03 11:18 bismark Note Added: 58154
2020-06-03 11:18 DenisChenu Note Added: 58155
2021-03-03 15:29 ollehar Assigned To => ollehar
2021-03-03 15:29 ollehar Status new => feedback
2021-03-03 15:29 ollehar Note Added: 62671
2021-04-21 21:18 bismark Note Added: 64096
2021-04-21 21:18 bismark Status feedback => assigned
2021-04-22 09:37 ollehar Note Added: 64102
2021-04-22 14:47 Mazi Note Added: 64112
2021-04-22 14:50 ollehar Note Added: 64113
2021-04-27 16:14 gabrieljenik Note Added: 64168
2021-04-27 16:15 gabrieljenik Status assigned => review
2021-04-27 16:18 bismark Note Added: 64169
2021-04-27 17:09 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS 6187bf4a
2021-04-27 17:09 gabrieljenik Note Added: 64170
2021-04-27 17:09 gabrieljenik Assigned To ollehar => gabrieljenik
2021-04-27 17:09 gabrieljenik Resolution open => fixed
2021-04-27 17:09 ollehar Status review => resolved
2021-04-29 14:42 gabrieljenik Note Added: 64187
2021-04-30 16:19 gabrieljenik Changeset attached => LimeSurvey master 8338259a
2021-04-30 16:19 gabrieljenik Note Added: 64205