View Issue Details

IDProjectCategoryView StatusLast Update
16204Bug reportsOtherpublic2020-07-13 12:35
Reportercdorin Assigned Tocdorin  
PriorityhighSeveritycrash 
Status closedResolutionfixed 
Product Version4.2.1 
Summary16204: Arrays (all types) not displayed correctly during survey-taking (mobile phone) - LE: it applies only to certain Array types
Description

Arrays (all types) not displayed correctly during survey-taking.

Arrays are not being split up if device screen is small (e.g., see phone)

TagsNo tags attached.
Complete LimeSurvey version number (& build)irrelevant
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionirrelevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionirrelevant

Relationships

parent of 16267 closed Array question type: Array by Scale not displayed correctly during survey taking (mobile phone) 
parent of 16268 closedcdorin Array question type: Array by Column not displayed correctly during survey taking (mobile phone) 

Activities

DenisChenu

DenisChenu

2020-04-29 09:20

developer   ~57444

Still working on SkelVanilla for information (please don't broke it ;) )

JHoeck

JHoeck

2020-05-05 13:22

developer   ~57535

Last edited: 2020-05-15 11:27

What do u mean with SkelVanilla? What is it?

cdorin

cdorin

2020-05-05 13:58

manager   ~57538

Last edited: 2020-05-15 11:27

@JHoeck: https://www.limesurvey.org/limestore?view=extensiondetails&id=15

DenisChenu

DenisChenu

2020-05-05 13:58

developer   ~57539

Last edited: 2020-05-15 11:27

Own theme system
https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla

DenisChenu

DenisChenu

2020-05-05 14:00

developer   ~57540

Last edited: 2020-05-15 11:27

When put information about SkelVanilla : i mean : it didn't came from core directly, more theme related issue «only» (i remove template-core from dependance).

JHoeck

JHoeck

2020-05-12 17:03

developer   ~57705

Last edited: 2020-05-15 11:27

This is not a theme issue. Its an issue, unrelated to the theme. U can test the changes in bug/16204-arrays-all-types-not-displayed-correctly-during-survey-taking-mobile-phone.

DenisChenu

DenisChenu

2020-05-12 17:29

developer   ~57707

Last edited: 2020-05-15 11:27

«Arrays (all types) not displayed correctly during survey-taking (mobile phone)»

It's not All type here, i check 5 point and 10 point with SkelVanilla : can confirm it's not a template issue …

cdorin

cdorin

2020-05-12 17:37

manager   ~57709

Last edited: 2020-05-15 11:27

Yes, my report was faulty. I talked already to Jessica about it - guess I got too panicked when I was able to reproduce the issue with several Arrays. Anyway, will keep an eye close on this since such issues should not appear during survey-taking. Thank you for your comments as well, Denis!

DenisChenu

DenisChenu

2020-05-12 18:11

developer   ~57713

Last edited: 2020-05-15 11:27

No problem @cdorin, but i think i annoy @JHoeck a lot … but : it's your fault, you can offer a drink ;)

cdorin

cdorin

2020-05-12 18:14

manager   ~57714

Last edited: 2020-05-15 11:27

Hahhaa, not at all, Denis ^^
@JHoekck, fritz on me when you come next time to office ^^
I changed the name of the mantis ticket as well.

Mazi

Mazi

2020-05-19 17:22

partner   ~57942

@cdorin, why was this set to be resolved (and why by swendrich?)?

I just tested with latest Version 4.2.4+200520 and the issue still shows up, see screenshot.

array_mobile.png (36,504 bytes)   
array_mobile.png (36,504 bytes)   
DenisChenu

DenisChenu

2020-05-19 17:27

developer   ~57943

Seems there are multiple issue here …

  1. label are not set in twig view for some question
  2. Some array are not shown line by line in phone (

Maybe best is to report a clean issue with a sample LSS + sample screenshot showing specific issue

Mazi

Mazi

2020-05-19 17:56

partner   ~57945

Re-opened

Mazi

Mazi

2020-05-20 21:57

partner   ~57979

Default template test survey attached. Array questions can be found at first question group.

DenisChenu

DenisChenu

2020-05-21 12:24

developer   ~57981

Last edited: 2020-05-21 12:25

View 3 revisions

I can not test with vanilla (it's broken)

But : it work for me with 4.2.4 github

Maybe reset asset ?

EDIT : preview group
EDIT : Fruity

DenisChenu

DenisChenu

2020-05-21 12:36

developer   ~57982

Arg … but broke with SkelVanilla now !

And it force me to reset : broke SkelVanilla API … https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla/-/commit/3a4356f1655e1fa203c4a38affae3968345a936c

This really awfull this config system that can be easily updated … need to resest whole survey theme.

@Mazi : surely this issue for you … theme need to be resetted

DenisChenu

DenisChenu

2020-05-21 12:37

developer   ~57983

Mazi

Mazi

2020-06-24 17:31

partner   ~58427

@cdorin, this really serious problem was reported several weeks ago. I just updated to the latest release and did some testing. Looks like this is still an issue?

How can it be that such issues with status "crash" and priority "high" do not get fixed short term?
This show stopper makes using LS4 on mobile devices nearly impossible when using array questions.

medhat

medhat

2020-07-01 07:56

reporter   ~58602

+1 to get this issue fixed soon!

DenisChenu

DenisChenu

2020-07-01 08:32

developer   ~58603

@medhat : can you look at source code you have noTablesOnMobile.css loaded ?

Mazi

Mazi

2020-07-07 13:19

partner   ~58735

Last edited: 2020-07-07 13:19

View 2 revisions

To make this work when using a custom theme it seems that you have to:

  1. Update to the latest version.
  2. Reset the vanilla theme (if your custom theme is based on that).
  3. Also reset your custm theme.
  4. It may not hurt to also clear the assets cache at the global settings.

If all went well, the missing "noTablesOnMobile" should now be loaded when calling a survey.

JHoeck

JHoeck

2020-07-07 14:01

developer   ~58738

Which array type is affected? Name it please.

DenisChenu

DenisChenu

2020-07-07 14:08

developer   ~58741

@JHoeck : if you don't reset vanilla and childs after udating : alll table .

Array : https://manual.limesurvey.org/Question_type_-_Array
Array dual scale : https://manual.limesurvey.org/Question_type_-_Array_dual_scale
Array 5 point : https://manual.limesurvey.org/Question_type_-_Array_(5_point_choice)
etc …

@Mazi upload a sample lss file (and a screenshot)

cdorin

cdorin

2020-07-07 17:47

manager   ~58759

Sample .lss . Can reproduce the issue with bootswatch and vanilla (latest release via CU)

gabrieljenik

gabrieljenik

2020-07-07 22:04

developer   ~58766

Last edited: 2020-07-07 22:05

View 2 revisions

Somehow the noMoreTables.cs files is not on the DB but it is on the XML.
That could be because the DB is not loaded from the XML at the ver begining but loaded through db startup scripts.
So in those scripts, the noMoreTables.css lib is missing.

When the theme is reset, the DB is refreshed from the XML.
As the noMoreTables.css is there, the issue seems to go away.

We will send a PR with the DB update.

It is to highlight that the problem is turned upside down with ajaxify.js.
It is on the DB scripts but not on the config XML.
Not sure if that's still used, but I guess that if you setup ajaxmode after reseting the theme, you will find an error.

DenisChenu

DenisChenu

2020-07-08 08:43

developer   ~58767

We need a better solution : update DB (partially) can be done only for core theme.
We need a way to reset theme partially only too.

gabrieljenik

gabrieljenik

2020-07-08 15:14

developer   ~58786

Last edited: 2020-07-08 15:14

View 2 revisions

We need a way to reset theme partially only too.

What do you mean? The DB change should fix vanilla and bootswatch, which are the ones with issues.
But seems I am missing something.

DenisChenu

DenisChenu

2020-07-08 15:45

developer   ~58792

Currently if Theme developper add a js file or a css file in his own template.
The only way to fix previous version of same theme is reset ALL theme option to default (on all survey)

Here the issue is for core theme, but need a solution for external theme.
A way to add a JS file in option.xml without the need to reset whole theme options.

gabrieljenik

gabrieljenik

2020-07-08 18:07

developer   ~58803

You mean like reloading only the "files" sections?

DenisChenu

DenisChenu

2020-07-08 18:37

developer   ~58805

I don't know

Currently :
Add a theme
Set it to a survey
Set an logo to this survey
Update theme config.xml to add a css
Go to survey css was not loaded
Only way : reset whole theme : you loose logo configuration (and if you have 150 surveys with 150 different logos : it's the same)

It's the reason i'm on 9.X.Y version on SkelVanilla. Major relase : best to add a new theme not update …

gabrieljenik

gabrieljenik

2020-07-08 19:03

developer   ~58807

Last edited: 2020-07-08 19:08

View 2 revisions

I understand.
But shouldn't that be on another ticket? (sorry, not the best comment)

gabrieljenik

gabrieljenik

2020-07-08 19:08

developer   ~58808

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1473

Created a new DB migration for adding missing noTablesOnMobile.css to vanilla and bootswatch configs
Beware: DBversion was updated.

sushmanadendla

sushmanadendla

2020-07-10 15:07

manager   ~58895

Tested the issue by pulling the PR. Working as expected. Please refer the attachment for more details

16204_Vanilla.png (52,720 bytes)   
16204_Vanilla.png (52,720 bytes)   
16204_Bootswatch.png (45,426 bytes)   
16204_Bootswatch.png (45,426 bytes)   
guest

guest

2020-07-11 09:43

viewer   ~58909

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30276

lime_release_bot

lime_release_bot

2020-07-13 12:35

administrator   ~58920

Fixed in Release 4.3.4+200713

Related Changesets

LimeSurvey: master 21803675

2020-07-11 09:43:15

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16204: Arrays (all types) not displayed correctly during survey-taking (mobile phone) (#1473)

* Fixed issue 16204: Arrays (all types) not displayed correctly during survey-taking (mobile phone)

Created a new DB migration for adding missing noTablesOnMobile.css to vanilla and bootswatch configs

* Fixed issue 16204: Arrays (all types) not displayed correctly during survey-taking (mobile phone)

Fixed files being associated. Now in sync with config.xml
Affected Issues
16204
mod - application/config/version.php Diff File
mod - application/helpers/update/updatedb_helper.php Diff File

Issue History

Date Modified Username Field Change
2020-04-29 02:25 cdorin New Issue
2020-04-29 02:33 cdorin Description Updated View Revisions
2020-04-29 09:20 DenisChenu Note Added: 57444
2020-05-05 13:21 JHoeck Assigned To => JHoeck
2020-05-05 13:21 JHoeck Status new => assigned
2020-05-05 13:22 JHoeck Note Added: 57535
2020-05-05 13:58 cdorin Note Added: 57538
2020-05-05 13:58 DenisChenu Note Added: 57539
2020-05-05 14:00 DenisChenu Note Added: 57540
2020-05-05 14:42 JHoeck Status assigned => acknowledged
2020-05-12 17:03 JHoeck Note Added: 57705
2020-05-12 17:29 DenisChenu Note Added: 57707
2020-05-12 17:37 cdorin Note Added: 57709
2020-05-12 18:11 DenisChenu Note Added: 57713
2020-05-12 18:14 cdorin Note Added: 57714
2020-05-12 18:14 cdorin Summary Arrays (all types) not displayed correctly during survey-taking (mobile phone) => Arrays (all types) not displayed correctly during survey-taking (mobile phone) - LE: it applies only to certain Array types
2020-05-13 13:44 JHoeck Relationship added parent of 16267
2020-05-13 13:47 JHoeck Relationship added parent of 16268
2020-05-14 16:46 ollehar Priority none => high
2020-05-15 11:27 swendrich Status acknowledged => resolved
2020-05-19 17:22 Mazi Note Added: 57942
2020-05-19 17:22 Mazi File Added: array_mobile.png
2020-05-19 17:27 DenisChenu Note Added: 57943
2020-05-19 17:56 Mazi Status resolved => new
2020-05-19 17:56 Mazi Resolution open => reopened
2020-05-19 17:56 Mazi Note Added: 57945
2020-05-20 21:57 Mazi Note Added: 57979
2020-05-20 21:57 Mazi File Added: limesurvey_survey_395849.lss
2020-05-21 12:24 DenisChenu Note Added: 57981
2020-05-21 12:24 DenisChenu File Added: Capture d’écran 2020-05-21 à 12.24.09-fullpage.png
2020-05-21 12:24 DenisChenu Note Edited: 57981 View Revisions
2020-05-21 12:25 DenisChenu Note Edited: 57981 View Revisions
2020-05-21 12:36 DenisChenu Note Added: 57982
2020-05-21 12:37 DenisChenu Note Added: 57983
2020-05-21 12:37 DenisChenu File Added: Capture d’écran du 2020-05-21 12-26-55.png
2020-06-24 17:31 Mazi Note Added: 58427
2020-07-01 07:56 medhat Note Added: 58602
2020-07-01 08:32 DenisChenu Note Added: 58603
2020-07-07 13:19 Mazi Note Added: 58735
2020-07-07 13:19 Mazi Note Edited: 58735 View Revisions
2020-07-07 14:01 JHoeck Note Added: 58738
2020-07-07 14:08 DenisChenu Note Added: 58741
2020-07-07 17:47 cdorin Note Added: 58759
2020-07-07 17:47 cdorin File Added: array_questions_survey.lss
2020-07-07 18:31 cdorin Assigned To JHoeck => cdorin
2020-07-07 18:31 cdorin Status new => confirmed
2020-07-07 22:04 gabrieljenik Note Added: 58766
2020-07-07 22:05 gabrieljenik Note Edited: 58766 View Revisions
2020-07-08 08:43 DenisChenu Note Added: 58767
2020-07-08 15:14 gabrieljenik Note Added: 58786
2020-07-08 15:14 gabrieljenik Note Edited: 58786 View Revisions
2020-07-08 15:45 DenisChenu Note Added: 58792
2020-07-08 18:07 gabrieljenik Note Added: 58803
2020-07-08 18:37 DenisChenu Note Added: 58805
2020-07-08 19:03 gabrieljenik Note Added: 58807
2020-07-08 19:08 gabrieljenik Note Edited: 58807 View Revisions
2020-07-08 19:08 gabrieljenik Note Added: 58808
2020-07-10 15:07 sushmanadendla Note Added: 58895
2020-07-10 15:07 sushmanadendla File Added: 16204_Vanilla.png
2020-07-10 15:07 sushmanadendla File Added: 16204_Bootswatch.png
2020-07-11 09:43 gabrieljenik Changeset attached => LimeSurvey master 21803675
2020-07-11 09:43 guest Note Added: 58909
2020-07-13 12:35 lime_release_bot Note Added: 58920
2020-07-13 12:35 lime_release_bot Status confirmed => closed
2020-07-13 12:35 lime_release_bot Resolution reopened => fixed