View Issue Details

IDProjectCategoryView StatusLast Update
16204Bug reportsOtherpublic2020-07-01 08:32
Reportercdorin Assigned ToJHoeck  
PriorityhighSeveritycrash 
Status newResolutionreopened 
Product Version4.2.1 
Summary16204: Arrays (all types) not displayed correctly during survey-taking (mobile phone) - LE: it applies only to certain Array types
Description

Arrays (all types) not displayed correctly during survey-taking.

Arrays are not being split up if device screen is small (e.g., see phone)

TagsNo tags attached.
Complete LimeSurvey version number (& build)irrelevant
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionirrelevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionirrelevant

Relationships

parent of 16267 closed Array question type: Array by Scale not displayed correctly during survey taking (mobile phone) 
parent of 16268 closedcdorin Array question type: Array by Column not displayed correctly during survey taking (mobile phone) 

Activities

DenisChenu

DenisChenu

2020-04-29 09:20

developer   ~57444

Still working on SkelVanilla for information (please don't broke it ;) )

JHoeck

JHoeck

2020-05-05 13:22

developer   ~57535

Last edited: 2020-05-15 11:27

What do u mean with SkelVanilla? What is it?

cdorin

cdorin

2020-05-05 13:58

manager   ~57538

Last edited: 2020-05-15 11:27

@JHoeck: https://www.limesurvey.org/limestore?view=extensiondetails&id=15

DenisChenu

DenisChenu

2020-05-05 13:58

developer   ~57539

Last edited: 2020-05-15 11:27

Own theme system
https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla

DenisChenu

DenisChenu

2020-05-05 14:00

developer   ~57540

Last edited: 2020-05-15 11:27

When put information about SkelVanilla : i mean : it didn't came from core directly, more theme related issue «only» (i remove template-core from dependance).

JHoeck

JHoeck

2020-05-12 17:03

developer   ~57705

Last edited: 2020-05-15 11:27

This is not a theme issue. Its an issue, unrelated to the theme. U can test the changes in bug/16204-arrays-all-types-not-displayed-correctly-during-survey-taking-mobile-phone.

DenisChenu

DenisChenu

2020-05-12 17:29

developer   ~57707

Last edited: 2020-05-15 11:27

«Arrays (all types) not displayed correctly during survey-taking (mobile phone)»

It's not All type here, i check 5 point and 10 point with SkelVanilla : can confirm it's not a template issue …

cdorin

cdorin

2020-05-12 17:37

manager   ~57709

Last edited: 2020-05-15 11:27

Yes, my report was faulty. I talked already to Jessica about it - guess I got too panicked when I was able to reproduce the issue with several Arrays. Anyway, will keep an eye close on this since such issues should not appear during survey-taking. Thank you for your comments as well, Denis!

DenisChenu

DenisChenu

2020-05-12 18:11

developer   ~57713

Last edited: 2020-05-15 11:27

No problem @cdorin, but i think i annoy @JHoeck a lot … but : it's your fault, you can offer a drink ;)

cdorin

cdorin

2020-05-12 18:14

manager   ~57714

Last edited: 2020-05-15 11:27

Hahhaa, not at all, Denis ^^
@JHoekck, fritz on me when you come next time to office ^^
I changed the name of the mantis ticket as well.

Mazi

Mazi

2020-05-19 17:22

partner   ~57942

@cdorin, why was this set to be resolved (and why by swendrich?)?

I just tested with latest Version 4.2.4+200520 and the issue still shows up, see screenshot.

array_mobile.png (36,504 bytes)   
array_mobile.png (36,504 bytes)   
DenisChenu

DenisChenu

2020-05-19 17:27

developer   ~57943

Seems there are multiple issue here …

  1. label are not set in twig view for some question
  2. Some array are not shown line by line in phone (

Maybe best is to report a clean issue with a sample LSS + sample screenshot showing specific issue

Mazi

Mazi

2020-05-19 17:56

partner   ~57945

Re-opened

Mazi

Mazi

2020-05-20 21:57

partner   ~57979

Default template test survey attached. Array questions can be found at first question group.

DenisChenu

DenisChenu

2020-05-21 12:24

developer   ~57981

Last edited: 2020-05-21 12:25

View 3 revisions

I can not test with vanilla (it's broken)

But : it work for me with 4.2.4 github

Maybe reset asset ?

EDIT : preview group
EDIT : Fruity

DenisChenu

DenisChenu

2020-05-21 12:36

developer   ~57982

Arg … but broke with SkelVanilla now !

And it force me to reset : broke SkelVanilla API … https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla/-/commit/3a4356f1655e1fa203c4a38affae3968345a936c

This really awfull this config system that can be easily updated … need to resest whole survey theme.

@Mazi : surely this issue for you … theme need to be resetted

DenisChenu

DenisChenu

2020-05-21 12:37

developer   ~57983

Mazi

Mazi

2020-06-24 17:31

partner   ~58427

@cdorin, this really serious problem was reported several weeks ago. I just updated to the latest release and did some testing. Looks like this is still an issue?

How can it be that such issues with status "crash" and priority "high" do not get fixed short term?
This show stopper makes using LS4 on mobile devices nearly impossible when using array questions.

medhat

medhat

2020-07-01 07:56

reporter   ~58602

+1 to get this issue fixed soon!

DenisChenu

DenisChenu

2020-07-01 08:32

developer   ~58603

@medhat : can you look at source code you have noTablesOnMobile.css loaded ?

Issue History

Date Modified Username Field Change
2020-04-29 02:25 cdorin New Issue
2020-04-29 02:33 cdorin Description Updated View Revisions
2020-04-29 09:20 DenisChenu Note Added: 57444
2020-05-05 13:21 JHoeck Assigned To => JHoeck
2020-05-05 13:21 JHoeck Status new => assigned
2020-05-05 13:22 JHoeck Note Added: 57535
2020-05-05 13:58 cdorin Note Added: 57538
2020-05-05 13:58 DenisChenu Note Added: 57539
2020-05-05 14:00 DenisChenu Note Added: 57540
2020-05-05 14:42 JHoeck Status assigned => acknowledged
2020-05-12 17:03 JHoeck Note Added: 57705
2020-05-12 17:29 DenisChenu Note Added: 57707
2020-05-12 17:37 cdorin Note Added: 57709
2020-05-12 18:11 DenisChenu Note Added: 57713
2020-05-12 18:14 cdorin Note Added: 57714
2020-05-12 18:14 cdorin Summary Arrays (all types) not displayed correctly during survey-taking (mobile phone) => Arrays (all types) not displayed correctly during survey-taking (mobile phone) - LE: it applies only to certain Array types
2020-05-13 13:44 JHoeck Relationship added parent of 16267
2020-05-13 13:47 JHoeck Relationship added parent of 16268
2020-05-14 16:46 ollehar Priority none => high
2020-05-15 11:27 swendrich Status acknowledged => resolved
2020-05-19 17:22 Mazi Note Added: 57942
2020-05-19 17:22 Mazi File Added: array_mobile.png
2020-05-19 17:27 DenisChenu Note Added: 57943
2020-05-19 17:56 Mazi Status resolved => new
2020-05-19 17:56 Mazi Resolution open => reopened
2020-05-19 17:56 Mazi Note Added: 57945
2020-05-20 21:57 Mazi Note Added: 57979
2020-05-20 21:57 Mazi File Added: limesurvey_survey_395849.lss
2020-05-21 12:24 DenisChenu Note Added: 57981
2020-05-21 12:24 DenisChenu File Added: Capture d’écran 2020-05-21 à 12.24.09-fullpage.png
2020-05-21 12:24 DenisChenu Note Edited: 57981 View Revisions
2020-05-21 12:25 DenisChenu Note Edited: 57981 View Revisions
2020-05-21 12:36 DenisChenu Note Added: 57982
2020-05-21 12:37 DenisChenu Note Added: 57983
2020-05-21 12:37 DenisChenu File Added: Capture d’écran du 2020-05-21 12-26-55.png
2020-06-24 17:31 Mazi Note Added: 58427
2020-07-01 07:56 medhat Note Added: 58602
2020-07-01 08:32 DenisChenu Note Added: 58603