View Issue Details

IDProjectCategoryView StatusLast Update
16076Bug reportsSurvey editingpublic2020-05-19 16:10
Reporterong Assigned To 
PriorityhighSeveritycrash 
Status closedResolutionno change required 
Product Version4.1.11 
Summary16076: can not edit a saved question
DescriptionHi
I have this problem in version 4.1.12

An array question (type F, I think other as well) can not be edited, once it was saved. See attached image.
Steps To Reproducecreate array (type F) question
add subquestions
add answers
save
switch to another question
go back to first question
go to EDIT
- you do not even need to change anything -
click SAVE
an error message appears
Additional InformationI reported a similar problem at https://bugs.limesurvey.org/view.php?id=16075
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.12+200324
I will donate to the project if issue is resolvedNo
Browservivaldi /chromium
Database & DB-Versionmysql 8.0.18
Server OS (if known)debian
Webserver software & version (if known)apache2
PHP Version7.something

Activities

ong

ong

2020-04-02 13:08

reporter  

no_save_after_edit.gif (290,696 bytes)
cdorin

cdorin

2020-04-02 17:37

manager   ~56891

Is it a copied question?
ong

ong

2020-04-02 18:22

reporter   ~56896

Hi,
well, no I would answer.
I did create SRQLa. Then I saved it. I did some other work on the survey. Then I returned to SRQLa and wanted to edit something (shown in the animated gif attached to my original report).
It's impossible for me to save the question back from editmode.
Is that understandable?
cdorin

cdorin

2020-04-02 18:45

manager   ~56897

I followed the procedure - unfortunately I am still not able to reproduce it. Please wait till Monday when we will do another minor release and try again if the issue still exists with another survey.
ong

ong

2020-04-02 18:47

reporter   ~56898

Yes, I will wait and test again. I will report back.
ong

ong

2020-04-08 09:25

reporter   ~57020

Hi,
just installed version 4.1.16+200407 in a new web root, with new mysql database and imported the lss - the problem still occurs, I am unable to save an edited question (not all of them, but some, as reported)
ong

ong

2020-05-13 09:28

reporter   ~57731

for me this error still exists in 4.2.3+200511
cdorin

cdorin

2020-05-14 14:26

manager   ~57785

Can you please send us the .lss file?
ollehar

ollehar

2020-05-14 16:19

administrator   ~57787

Can you please click F12 in the browser and give us a screenshot of any errors shown in the JavaScript console? Thank you.
ong

ong

2020-05-14 16:27

reporter   ~57789

Hi,
lss attached, try with question oct5017c
When I just tried the I was able to reproduce the error.

Screenshots of errors and warning in console also attached.
errors.png (95,104 bytes)   
errors.png (95,104 bytes)   
warning.png (109,989 bytes)
cdorin

cdorin

2020-05-17 23:42

manager   ~57859

Random order is enabled. Please wait for the next update - the issue was already solved by @ollehar
cdorin

cdorin

2020-05-17 23:51

manager   ~57861

Will move it to "feedback" category. Please check Monday/Tuesday the new version and let us know if the issue still persists
ong

ong

2020-05-19 15:37

reporter   ~57931

The issue seems to be resolved: In my updated version 4.2.4+200520 I was yet unable to reproduce it. I am able to save all edits. Thank you!
ollehar

ollehar

2020-05-19 16:09

administrator   ~57938

Glad to hear it. :) Let us know if you have any further issues. Thank you.

Issue History

Date Modified Username Field Change
2020-04-02 13:08 ong New Issue
2020-04-02 13:08 ong File Added: no_save_after_edit.gif
2020-04-02 17:37 cdorin Note Added: 56891
2020-04-02 17:41 cdorin Assigned To => cdorin
2020-04-02 17:41 cdorin Status new => feedback
2020-04-02 18:22 ong Note Added: 56896
2020-04-02 18:22 ong Status feedback => assigned
2020-04-02 18:45 cdorin Note Added: 56897
2020-04-02 18:45 cdorin Status assigned => feedback
2020-04-02 18:47 ong Note Added: 56898
2020-04-02 18:47 ong Status feedback => assigned
2020-04-08 09:25 ong Note Added: 57020
2020-05-13 09:28 ong Note Added: 57731
2020-05-14 14:26 cdorin Note Added: 57785
2020-05-14 14:26 cdorin Assigned To cdorin =>
2020-05-14 14:26 cdorin Status assigned => new
2020-05-14 14:26 cdorin Description Updated View Revisions
2020-05-14 14:26 cdorin Steps to Reproduce Updated View Revisions
2020-05-14 16:19 ollehar Note Added: 57787
2020-05-14 16:19 ollehar Status new => feedback
2020-05-14 16:27 ong Note Added: 57789
2020-05-14 16:27 ong File Added: oct5017c_limesurvey_survey_159531.lss
2020-05-14 16:27 ong File Added: errors.png
2020-05-14 16:27 ong File Added: warning.png
2020-05-14 16:27 ong Status feedback => new
2020-05-14 16:31 ollehar Priority none => high
2020-05-17 23:42 cdorin Note Added: 57859
2020-05-17 23:51 cdorin Status new => feedback
2020-05-17 23:51 cdorin Note Added: 57861
2020-05-19 15:37 ong Note Added: 57931
2020-05-19 15:37 ong Status feedback => new
2020-05-19 16:09 ollehar Note Added: 57938
2020-05-19 16:10 ollehar Status new => closed
2020-05-19 16:10 ollehar Resolution open => no change required