View Issue Details

IDProjectCategoryView StatusLast Update
16075Bug reportsSurvey editingpublic2020-05-19 16:46
Reporterong Assigned Tocdorin  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.1.11 
Fixed in Version4.2.4 
Summary16075: copy question does not work
Description

When I copy a question (type: array F) I can not save the copy. I get an error message - this is wrong - the code does not yet exists (see attached image)
(I am working with 4.1.12)

Steps To Reproduce

Create question type F (array)
add sub questions
add answer options
save
try to duplicate this question using COPY-button
directly after page is displayed, click SAVE

Tagscopy, duplicate, question, question copy
Complete LimeSurvey version number (& build)4.1.12+200324
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browservivaldi / chromium
Database & DB-Versionmysql v 8.0.18
Server OS (if known)debian something
Webserver software & version (if known)apache2
PHP Version7.something

Activities

ong

ong

2020-04-02 12:59

reporter  

no_save_s.gif (331,903 bytes)
ong

ong

2020-04-02 13:09

reporter   ~56882

I also reported a similar problem https://bugs.limesurvey.org/view.php?id=16076

cdorin

cdorin

2020-04-02 17:41

manager   ~56892

Unfortunately, I cannot replicate the behaviour in 4.14. Could you please update and try once more? (indeed, that was an issue in the past)

ong

ong

2020-04-10 12:32

reporter   ~57071

Hi,
almost forgot. I did update to version 4.1.16+200407 - but the problem still remains (see new attached image).
As in another bug report, I noted, that I actually exported the LSS, created a new MySQL DB and did a fresh installation of version 4.1.16+200407, then imported the lss - but the problems (yes, all), remained.

no_save_2.gif (465,242 bytes)
ong

ong

2020-05-19 15:39

reporter   ~57932

The issue may be resolved: In my updated version 4.2.4+200520 I was yet unable to reproduce it. I am able to copy a matrix question (even with random sub-questions). Thank you!

cdorin

cdorin

2020-05-19 16:46

manager   ~57939

Fixed in 4.2.4.
thx for feedback :)

Issue History

Date Modified Username Field Change
2020-04-02 12:59 ong New Issue
2020-04-02 12:59 ong File Added: no_save_s.gif
2020-04-02 13:00 ong Tag Attached: question copy
2020-04-02 13:00 ong Tag Attached: question
2020-04-02 13:00 ong Tag Attached: copy
2020-04-02 13:00 ong Tag Attached: duplicate
2020-04-02 13:09 ong Note Added: 56882
2020-04-02 17:41 cdorin Assigned To => cdorin
2020-04-02 17:41 cdorin Status new => feedback
2020-04-02 17:41 cdorin Note Added: 56892
2020-04-10 12:32 ong File Added: no_save_2.gif
2020-04-10 12:32 ong Note Added: 57071
2020-04-10 12:32 ong Status feedback => assigned
2020-05-19 15:39 ong Note Added: 57932
2020-05-19 16:46 cdorin Status assigned => resolved
2020-05-19 16:46 cdorin Resolution open => fixed
2020-05-19 16:46 cdorin Note Added: 57939
2020-05-19 16:46 cdorin Status resolved => closed
2020-05-19 16:46 cdorin Fixed in Version => 4.2.4