View Issue Details

This bug affects 1 person(s).
 14
IDProjectCategoryView StatusLast Update
15898Bug reportsSurvey takingpublic2020-12-23 17:33
Reporterrussell37uk Assigned Tocdorin  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.1.6 
Summary15898: Issues uploading files during survey
DescriptionI am having a issue where files cannot be uploaded to a live survey, I have also added this in the forums, as it could just be me having some settings wrong! (https://www.limesurvey.org/forum/installation-a-update-issues/120311-issues-uploading-files-during-survey)
Regardless of what file extension i try to add i always get this error (attached)

In addition to this (not in my opinion related to the issue above), notice the upload limit in the image - I have increased this in the survey question/logic, but it keeps defaulting back to this value after saving the question.
PHP upload limits etc are set to a min 240M so not an issue as far as PHP settings are concerned.

Many thanks for any advice given.
TagsNo tags attached.
Bug heat14
Complete LimeSurvey version number (& build)4.1.6+200220
I will donate to the project if issue is resolvedNo
Browserchrome
Database type & versionMySQL
Server OS (if known)Linux
Webserver software & version (if known)
PHP Version7.2.27

Relationships

related to 15874 resolvedJHoeck Feature requests Bad control of file extension list : space inside list 
has duplicate 16146 closed Bug reports File upload, space in list of allowed file types 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

russell37uk

russell37uk

2020-02-20 22:58

reporter  

Untitled.png (15,374 bytes)   
Untitled.png (15,374 bytes)   
DenisChenu

DenisChenu

2020-02-21 08:19

developer   ~56126

@russell37uk can you confirm replace the value by same values but without space fix the issue .
russell37uk

russell37uk

2020-02-21 13:52

reporter   ~56138

@DenisChenu
Is there a file that should be edited to delete the spaces in the extension list, as when i try to edit within the question editor it always defaults back (with the spaces) when saving (this also means i cannot add other media file options eg mp4, 3gp etc) like i could in a precious version LS 3x.

In addition to this the file upload limit also keeps defaulting to 10240, when it should be 200k on my install (240M + on PHP upload limits)

Never had any issues using a earlier version of LS.
DenisChenu

DenisChenu

2020-02-21 15:39

developer   ~56141

Not a file : directly in Question advanced settings. It's to be sure it's same issue than https://bugs.limesurvey.org/view.php?id=15874

About 10240 : please report it at another issue with you phpinfo and a sample lss file.
russell37uk

russell37uk

2020-02-21 17:42

reporter   ~56142

@DenisChenu

Cannot remove the space in question/edit question, as the space re appears when saving the edited question - so issue not fixed

I also attempted the fix you mentioned in the other issue - again no change.

I am now doing a completely fresh install of LS 4.1.6 and will update this report asap as to wether this resolves the issue or not.

Thank you for your patience
DenisChenu

DenisChenu

2020-02-22 14:51

developer   ~56148

Last edited: 2020-02-22 14:54

View 2 revisions

> Cannot remove the space in question/edit question, as the space re appears when saving the edited question - so issue not fixed

I can on my part ... maybe another issue here.


> I also attempted the fix you mentioned in the other issue - again no change.

Here it's in src, you need to update builkd file. https://github.com/LimeSurvey/LimeSurvey/tree/f65418b1083ff653a9a13e5362e7e06628f5958d/assets/packages/questions/upload/build
I do it manually on assets/packages/questions/upload/build/uploadquestion.js , reset assets and set debug to 2 to confirm it work.

DenisChenu

DenisChenu

2020-05-06 10:48

developer   ~57570

Leave open for

> Cannot remove the space in question/edit question, as the space re appears when saving the edited question - so issue not fixed

Can you confirm with 4.2.2 ? If yes : can you opn a new bug ? Then i can close this onebecause it's duplicate of https://bugs.limesurvey.org/view.php?id=15874
cdorin

cdorin

2020-12-23 17:33

manager   ~61113

No feedback provided - ticket closed .
Cannot reproduce the issue in 4.4.0 RC1

Issue History

Date Modified Username Field Change
2020-02-20 22:58 russell37uk New Issue
2020-02-20 22:58 russell37uk File Added: Untitled.png
2020-02-21 00:56 jelo Relationship added related to 15874
2020-02-21 08:19 DenisChenu Note Added: 56126
2020-02-21 13:52 russell37uk Note Added: 56138
2020-02-21 15:39 DenisChenu Note Added: 56141
2020-02-21 17:42 russell37uk Note Added: 56142
2020-02-22 14:51 DenisChenu File Added: Capture d’écran du 2020-02-22 14-51-12.png
2020-02-22 14:51 DenisChenu Note Added: 56148
2020-02-22 14:54 DenisChenu Note Edited: 56148 View Revisions
2020-05-06 10:44 DenisChenu Relationship added has duplicate 16146
2020-05-06 10:48 DenisChenu Note Added: 57570
2020-05-06 10:48 DenisChenu Status new => feedback
2020-12-23 17:33 cdorin Assigned To => cdorin
2020-12-23 17:33 cdorin Status feedback => closed
2020-12-23 17:33 cdorin Resolution open => fixed
2020-12-23 17:33 cdorin Note Added: 61113