View Issue Details

This bug affects 1 person(s).
 2
IDProjectCategoryView StatusLast Update
16146Bug reportsOtherpublic2020-05-06 10:46
ReporterJmantysalo Assigned To 
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version4.1.16 
Summary16146: File upload, space in list of allowed file types
DescriptionWhen you make a new question of type file upload it will by default have allowed filetypes "png, gif, doc, odt, jpg, pdf, png". But then you can not upload pdf-file. It works without spaces, "png,gif,doc,odt,jpg,pdf,png" is ok.
TagsNo tags attached.
Bug heat2
Complete LimeSurvey version number (& build)Versio 4.1.17+200414
I will donate to the project if issue is resolvedNo
BrowserN/A
Database type & versionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionN/A

Relationships

duplicate of 15898 closedcdorin Bug reports Issues uploading files during survey 
duplicate of 15874 resolvedJHoeck Feature requests Bad control of file extension list : space inside list 
related to 16079 closedc_schmitz Bug reports File Upload question on selection of file returns a error 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

Jmantysalo

Jmantysalo

2020-04-18 10:54

reporter   ~57233

It seems that the PHP-code for this works. Hence the problem is on JS side, which means that the problem might depend on browser. I used newest FF available on Ubuntu 18.04, i.e. version 75.0.

Issue History

Date Modified Username Field Change
2020-04-17 07:57 Jmantysalo New Issue
2020-04-18 10:54 Jmantysalo Note Added: 57233
2020-05-06 10:09 DenisChenu Relationship added related to 16079
2020-05-06 10:44 DenisChenu Relationship added duplicate of 15898
2020-05-06 10:45 DenisChenu Relationship added duplicate of 15874
2020-05-06 10:46 DenisChenu Status new => closed
2020-05-06 10:46 DenisChenu Resolution open => duplicate