View Issue Details

IDProjectCategoryView StatusLast Update
15624Bug reports[All Projects] Data Entry (non public)public2019-11-27 17:11
Reporterdariocosta Assigned To 
PrioritynoneSeverityblock 
Status newResolutionopen 
Product Version3.20.x 
Target VersionFixed in Version 
Summary15624: File Upload not working for iOS 13.2
Description

When you try to upload a picture from the photo library or from camera, the form give you error, it seems like it doesn't recognise the mime type.

Steps To Reproduce

Add upload file question to your survey and access it with iOS device.

Additional Information

Versione di LimeSurvey
3.20.2
Build di LimeSurvey
191119
Sistema operativo
Windows NT SURVEYSERVER 10.0 build 14393 (Windows Server 2016) AMD64
PHP versione
7.2.14
Nome del web server
limesurvey.demobbl.it
Software del web server
Microsoft-IIS/10.0
Informazioni sul web server
HTTP/1.1
Driver del database
mysql
Versione del driver del database
mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
Informazioni sul database server
Uptime: 17888140 Threads: 1 Questions: 4206452 Slow queries: 0 Opens: 2968 Flush tables: 1 Open tables: 1720 Queries per second avg: 0.235
Versione del database server
Uptime: 17888140 Threads: 1 Questions: 4206452 Slow queries: 0 Opens: 2968 Flush tables: 1 Open tables: 1720 Queries per second avg: 0.235

TagsNo tags attached.
Complete LimeSurvey version number (& build)Versione 3.20.2+191119
I will donate to the project if issue is resolvedNo
BrowserSafari iOS
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2.14

Activities

galads

galads

2019-11-27 15:45

reporter   ~54824

I cannot reproduce this error on iOS 12.4.3 safari/Chrome browser

cdorin

cdorin

2019-11-27 15:46

manager   ~54825

@dariocosta, have you also tried the free hosting on limesurvey? Does it work there? If yes, it's a server configuration issue, most probably a permission system problem.

dariocosta

dariocosta

2019-11-27 16:45

reporter   ~54833

Thanks for your reply.
I tried just now to create a test free hosting on your server, but the result is the same: unable to upload image.
You can try it here: https://testdpes.limequery.com/878551?lang=en
There's only one question, with the file upload. If you do it with PC no problem, but if you try with iOS (I've an iPhone XR with latest iOS 13.2 installed), you will be prompted with the message as in the screenshot.



prova.png (93,367 bytes)
prova.png (93,367 bytes)
cdorin

cdorin

2019-11-27 17:07

manager   ~54834

can you select the file? Is the file format correct? does the modal display some kind of preview when you do that? Is the upload stored in the response table or you remain stuck in file upload modal?

cdorin

cdorin

2019-11-27 17:08

manager   ~54835

@markusfluer, perhaps you can also take a look at it when you have time.

dariocosta

dariocosta

2019-11-27 17:11

reporter   ~54836

When you click on select file, you are prompted to select the file. The photo library opens and you can select the image correctly, but when it comes back to the form, you receive this error and you remain stuck in this file upload modal.

Issue History

Date Modified Username Field Change
2019-11-26 18:48 dariocosta New Issue
2019-11-27 15:45 galads Note Added: 54824
2019-11-27 15:46 cdorin Note Added: 54825
2019-11-27 16:45 dariocosta File Added: prova.png
2019-11-27 16:45 dariocosta Note Added: 54833
2019-11-27 17:07 cdorin Note Added: 54834
2019-11-27 17:08 cdorin Note Added: 54835
2019-11-27 17:11 dariocosta Note Added: 54836