View Issue Details

IDProjectCategoryView StatusLast Update
15299Bug reports[All Projects] Survey editingpublic2019-11-28 15:06
Reporterdominikvitt Assigned Tocdorin  
PrioritynoneSeverityminor 
Status closedResolutionsuspended 
Product Version4.0.0-RC3 
Target Version4.0.0-RC4Fixed in Version 
Summary15299: Unable to open links in question organizer in the sidebar
Description

Several links in question organizer are not working.
Only with debug set to 1 or 2.

Steps To Reproduce

Click on links on question organizer in the sidebar.
Debug mode in config should be set to 1 or 2.

Additional Information

Unable to:

  • open existing group
  • add a new group
  • reorder groups
  • reorder questions
  • open Email templates page

Errors:
<h1>PHP Error [500]</h1>
<p>Declaration of questionedit::renderJSON($aData) should be compatible with Survey_Common_Action::renderJSON($aData, $success = true) (/var/www/html/LimeSurvey-develop/application/controllers/admin/questionedit.php:27)</p>

AND

<h1>PHP Error [500]</h1>
<p>Declaration of questiongroups::renderJSON($aData) should be compatible with Survey_Common_Action::renderJSON($aData, $success = true) (/var/www/html/LimeSurvey-develop/application/controllers/admin/questiongroups.php:27)</p>

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0-RC3
I will donate to the project if issue is resolvedNo
BrowserChromium, Firefox
Database & DB-VersionMySQL 5.7.24-0ubuntu0.18.04.1
Server OS (if known)Linux Mint 19.1 Tessa 64-bit
Webserver software & version (if known)Nginx
PHP Version7.3.5-1+ubuntu18.04.1+deb.sury.org+1

Relationships

related to 15103 closedJHoeck No menu link to organize 

Activities

DenisChenu

DenisChenu

2019-09-18 11:47

developer   ~53619

Related to https://bugs.limesurvey.org/view.php?id=15103 ?
Deprecated or not ?

dominikvitt

dominikvitt

2019-09-18 12:44

developer   ~53620

It is not related to that bug report, because sidebar view is already restructured.
This bug report is related to the latest changes because links worked without any problem during this week.

dominikvitt

dominikvitt

2019-09-18 13:43

developer   ~53621

Also very similar error when trying to open Email templates link on the sidebar

DenisChenu

DenisChenu

2019-09-18 14:54

developer   ~53626

/me need to test again develop version ;)

dominikvitt

dominikvitt

2019-09-23 14:11

developer   ~53684

First two items ("open existing group" and "add a new group") seems to work now.
Other items still don't work.

cdorin

cdorin

2019-11-28 15:06

manager   ~54872

Will suspend the discussion. We will need to discuss an alternative next year (sorry Denis)

Issue History

Date Modified Username Field Change
2019-09-18 09:19 dominikvitt New Issue
2019-09-18 10:08 dominikvitt Description Updated View Revisions
2019-09-18 10:08 dominikvitt Steps to Reproduce Updated View Revisions
2019-09-18 11:45 DenisChenu Relationship added related to 13852
2019-09-18 11:45 DenisChenu Relationship deleted related to 13852
2019-09-18 11:47 DenisChenu Relationship added related to 15103
2019-09-18 11:47 DenisChenu Note Added: 53619
2019-09-18 12:44 dominikvitt Note Added: 53620
2019-09-18 13:43 dominikvitt Note Added: 53621
2019-09-18 14:54 DenisChenu Note Added: 53626
2019-09-23 14:11 dominikvitt Note Added: 53684
2019-09-23 14:12 dominikvitt Additional Information Updated View Revisions
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing
2019-11-03 16:22 cdorin Assigned To => cdorin
2019-11-03 16:22 cdorin Status new => assigned
2019-11-28 15:06 cdorin Status assigned => closed
2019-11-28 15:06 cdorin Resolution open => suspended
2019-11-28 15:06 cdorin Note Added: 54872