View Issue Details

IDProjectCategoryView StatusLast Update
15180Bug reportsData Entry (non public)public2020-02-12 22:17
Reporteraabc Assigned To 
PrioritynormalSeverityminor 
Status acknowledgedResolutionopen 
Product Version3.17.x 
Summary15180: Numerical input disappearing after entering in numerical input fields
Description

Reported from one of our users: When entering numbers in the numerical input fields where the numbers appear to the far right (never happens with the fields aligned to the left), the numbers disappear instantaneously. Sometimes the same number must be typed in 4-5 times before it will "stick" for lack of a better word. I've tried multiple browsers and computers. This has been occurring for about 5 months. It's random, but when it happens, it happens a lot. Is this a known issue? Any ideas on how to resolve this issue?

Steps To Reproduce

The issue occurs randomly. I thought about making a video of it, but I can't predict when it will occur. I just created two test survey responses but was unable to recreate the problem.

Additional Information

Database hosted by LimeSurvey.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.17.10
I will donate to the project if issue is resolvedNo
BrowserSafari, Chrome, Firefox
Database & DB-VersionUnknown
Server OS (if known)
Webserver software & version (if known)
PHP VersionUnknown

Relationships

related to 14777 assignededdylackmann Vanishing values on "Numerical input" 

Activities

DenisChenu

DenisChenu

2019-08-23 18:53

developer   ~53231

In theme option : i think you can disable the javascript

Fix automatically numeric value

Test with No and only for expression

aabc

aabc

2019-08-24 17:45

reporter   ~53232

In Theme options, I don't see anything referring to javascript or numeric value.

DenisChenu

DenisChenu

2019-08-24 19:20

developer   ~53233

Then : test with vanilla

aabc

aabc

2019-09-18 19:20

reporter   ~53645

I'm using a customized theme option that removed the "exit and clear survey" button from my surveys because users were mistakenly clicking on it. So I'm unable to change my theme option. The issue occurs for multiple users, including me. We've tried the following which haven't resolved the issue: logging out, logging back in; restarting browser and computer; clearing all browsing data including cookies and cache; using multiple browsers and computers, ensuring browser is up-to-date; using incognito window.

DenisChenu

DenisChenu

2019-09-19 07:36

developer   ~53647

So I'm unable to change my theme option.

? Why ? Extended Theme options are the same than base theme option.

And maybe this was fixed in the new theme. If you «just» need to remove exit and clear survey : it's easy to do it again …

cdorin

cdorin

2019-11-03 17:33

manager   ~54359

Can't really reproduce it. Could you please send us the survey within which you observe this behaviour? i tried with multiple numerical and numerical input.

aabc

aabc

2019-11-11 00:57

reporter   ~54494

Yes, it has been observed in the following two surveys, in the numerical input fields. For example, in the first question group (Part 1 - Initial OB Visit) - Age, Education, Zip Code Weight, Height, and Gravidity fields. (I observed this last Wednesday in the Sample survey below).
Survey ID 812725 Title: 0001 - Sample Birth Center Survey
Survey ID 30530 Title: 305 - AABC PDR 3.0

wolf

wolf

2020-02-12 15:00

reporter   ~55916

I also have had this error several times.
I attached a screen video and a standard multiple numerical input question (tested now on limesurvey v4.0, but also reproducible on limesurvey v3.xx. Standard fruity theme or bootswatch theme, tested on firefox & chromium).
Some hints, but no way to reproduce it certainly:

  • occurs only? on multiple numerical input
  • it happens especially when testing surveys by entering random numbers very quickly.
  • I could only reproduce it when moving by tab key from one input field to another, not by clicking with the mouse to activate it.
  • Only happened if the input field was empty.
  • In the video I was holding the key down so you can see that the input field is cleared repeatedly - when entering number by number, normally the field gets deleted only once or twice, afterwards the input is accepted. It does never happen field after field, but after several fields it might happen again.
  • bug does not occur "Fix automatically numeric value" is set to "No"
    I tried to debug, but I didn't get far with my little knowledge. If I can help, please post.
wolf

wolf

2020-02-12 16:23

reporter   ~55925

Additional info: seems to be the same bug as https://bugs.limesurvey.org/view.php?id=14777

Issue History

Date Modified Username Field Change
2019-08-22 16:54 aabc New Issue
2019-08-23 18:53 DenisChenu Note Added: 53231
2019-08-24 17:45 aabc Note Added: 53232
2019-08-24 19:20 DenisChenu File Added: Capture d’écran du 2019-08-24 19-19-45.png
2019-08-24 19:20 DenisChenu Note Added: 53233
2019-09-18 19:20 aabc Note Added: 53645
2019-09-19 07:36 DenisChenu Note Added: 53647
2019-11-03 17:33 cdorin Note Added: 54359
2019-11-03 17:33 cdorin Assigned To => cdorin
2019-11-03 17:33 cdorin Status new => feedback
2019-11-11 00:57 aabc Note Added: 54494
2019-11-11 00:57 aabc Status feedback => assigned
2020-02-12 15:00 wolf File Added: simplescreenrecorder-2020-02-12_14.21.49-8-14.mp4
2020-02-12 15:00 wolf File Added: limesurvey_question_875.lsq
2020-02-12 15:00 wolf Note Added: 55916
2020-02-12 16:23 wolf Note Added: 55925
2020-02-12 16:57 cdorin Assigned To cdorin =>
2020-02-12 16:57 cdorin Priority none => normal
2020-02-12 16:57 cdorin Status assigned => acknowledged
2020-02-12 22:17 jelo Relationship added related to 14777