View Issue Details

IDProjectCategoryView StatusLast Update
15051Bug reportsConditionspublic2021-04-22 16:23
Reporterpokeydale Assigned Togabrieljenik  
PrioritynormalSeveritypartial_block 
Status resolvedResolutionfixed 
Product Version4.4.14 
Summary15051: When setting condition on Survey Participant Attributes the expression stored in DB is invalid
DescriptionI am not able to add conditions to questions that use attributes.
Steps To Reproduce1. Add a new condition to a question, select "Survey participant attributes"
2. select "equals in comparison operator
3. select "Survey participant attributes" in question section
4. select any attribute
5. select "Constant" in answer section
6. Key a constant value
7. select "equals in comparison operator
8. select "Survey participant attributes" in question section
9. select any attribute
10. select "Constant" in answer section
11. Key a constant value
12. select "Add condition" button

The new condition does not appear in the conditions list.
The database has an invalid "relevance" column value ie "((56523X3300X19756.NAOK == "afdsafd") and (56523X3300X19756.NAOK == "dale"))"
It is using a random list selection question as opposed to attribute.
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.4.14
I will donate to the project if issue is resolvedYes
BrowserChrome
Database & DB-VersionPostgreSQL 9.6
Server OS (if known)Linux dev-web 4.15.0-1043-aws #45-Ubuntu SMP Mon Jun 24 14:07:03 UTC 2019 x86_64
Webserver software & version (if known)Apache 2.0 Handler
PHP VersionPHP Version 7.2.19-0ubuntu0.18.04.1

Activities

scyrma

scyrma

2020-06-04 09:41

reporter   ~58167

I'm having the same issue on version 4.1.18+200416. Happy to provide more information and feedback if needed.
cdorin

cdorin

2021-02-03 10:21

manager   ~61874

@gabrieljenik, could you please take a look at the issue in both LTS and master? Thanks!
gabrieljenik

gabrieljenik

2021-02-03 14:18

manager   ~61884

I think we have done some work about that on 16519 and 15945 ( or 16520 and 16518 for LTS).
The versions where the bug was reported are older than that.

Can Ia sk to retest on a newer version?
c_schmitz

c_schmitz

2021-03-10 15:48

administrator   ~63001

@pokeydale and @scyrma: Can you please re-test and let us know? Thank you!
scyrma

scyrma

2021-03-15 06:21

reporter   ~63349

Our installation has not been updated since then, but as soon as it is, I'll give it a try and see.
c_schmitz

c_schmitz

2021-03-26 15:10

administrator   ~63654

I can confirm this on 4.4.14
gabrieljenik

gabrieljenik

2021-03-30 20:22

manager   ~63726

Applyig same patch as on bug 16518 (3.22.29). This is an interface issue, solved now

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1832
gabrieljenik

gabrieljenik

2021-03-30 20:24

manager   ~63727

Although ticket was entered for LTS, it has already been solved.
The new fix is for master. So changing that here.
gabrieljenik

gabrieljenik

2021-04-01 16:24

manager   ~63781

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31464

Related Changesets

LimeSurvey: master 9c2305c9

2021-04-01 16:24:35

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 15051: When setting condition on Survey Participant Attributes the expression stored in DB is invalid (#1832)

Applyig same patch as on bug 16518 (3.22.29). This is an interface issue, solved now
Affected Issues
15051, 16518
mod - application/controllers/admin/conditionsaction.php Diff File

Issue History

Date Modified Username Field Change
2019-07-16 22:48 pokeydale New Issue
2020-06-04 09:41 scyrma Note Added: 58167
2020-12-29 18:16 cdorin Priority none => normal
2020-12-29 18:16 cdorin Status new => confirmed
2021-02-03 10:21 cdorin Note Added: 61874
2021-02-03 14:18 gabrieljenik Note Added: 61884
2021-03-10 15:48 c_schmitz Note Added: 63001
2021-03-10 15:48 c_schmitz Assigned To => c_schmitz
2021-03-10 15:48 c_schmitz Status confirmed => feedback
2021-03-15 06:21 scyrma Note Added: 63349
2021-03-26 15:09 c_schmitz Assigned To c_schmitz =>
2021-03-26 15:09 c_schmitz Status feedback => confirmed
2021-03-26 15:10 c_schmitz Note Added: 63654
2021-03-30 20:22 gabrieljenik Note Added: 63726
2021-03-30 20:24 gabrieljenik Note Added: 63727
2021-03-30 20:25 gabrieljenik Product Version 3.15.x => 4.4.14
2021-03-30 20:25 gabrieljenik Complete LimeSurvey version number (& build) Version 3.15.9+190214 => 4.4.14
2021-04-01 16:24 gabrieljenik Changeset attached => LimeSurvey master 9c2305c9
2021-04-01 16:24 gabrieljenik Note Added: 63781
2021-04-01 16:24 gabrieljenik Assigned To => gabrieljenik
2021-04-01 16:24 gabrieljenik Resolution open => fixed
2021-04-22 16:23 gabrieljenik Status confirmed => resolved