View Issue Details

IDProjectCategoryView StatusLast Update
16520Bug reportsConditionspublic2020-08-03 11:55
Reportergabrieljenik Assigned To 
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version3.22.27 
Summary16520: For specific screen navigation, condition is not saved properly
DescriptionFor specific screen navigation, condition is not saved properly
That could lead to a situation where:
- After updating an answer option,
- The related condition doesn't get updated
- The condition uses an answer option code which doesn't exists
Steps To Reproduce1 - Create a survey with 2 questions
   + Q1: List. Options Y, N, Maybe
   + Q2: Short Free Text

2 - Add the following condition on Q2
     Q1 = Y

3 - Update Q1. Set answer option code for Y to be different.

4 - Condition on Q2 hasn't been updated and it is using the wrong answer option code.
Additional InformationDetected while reviewing 15945
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.22.27
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMysql
Server OS (if known)
Webserver software & version (if known)
PHP Versionphp

Relationships

related to 16519 closed For specific screen navigation, condition is not saved properly 

Activities

gabrieljenik

gabrieljenik

2020-07-28 02:10

manager   ~59111

Resetting cqid when using token fields

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1498

user225042

2020-07-30 11:22

  ~59202

Tested the issue before pulling the PR, Issue does not exist. I see the Answer option code being updated properly after making the changes but I see the commit done.
Please refer the attachment for more details

user225042

2020-07-30 16:03

  ~59216

The above issue was shown because I was committed to only one branch and checking. Checked the issue with Dorin with all the branches committed for Condition designer and working as expected.
gabrieljenik

gabrieljenik

2020-07-30 16:12

manager   ~59217

`Tested the issue before pulling the PR, Issue does not exist.`
Were you able to finally reproduce the issue?

user225042

2020-07-30 16:18

  ~59219

Issue does not exist in Lime Survey-3.22.27, same with Dorin as well but issue exist in Limesurvey-4

user231563

2020-07-30 17:26

  ~59225

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30330
gabrieljenik

gabrieljenik

2020-07-30 20:32

manager   ~59228

Last edited: 2020-07-30 20:33

View 2 revisions

Reproducing the issue
https://ibb.co/FKfRskV
lime_release_bot

lime_release_bot

2020-08-03 11:55

administrator   ~59260

Fixed in Release 3.22.210+200804

Related Changesets

LimeSurvey: 3.x-LTS 892314b7

2020-07-28 02:08:02

gabrieljenik


Committer: user231563 Details Diff
Fixed issue 16520: For specific screen navigation, condition is not saved properly

Resetting cqid when using token fields
Affected Issues
16520
mod - application/controllers/admin/conditionsaction.php Diff File
mod - assets/scripts/admin/conditions.js Diff File

Issue History

Date Modified Username Field Change
2020-07-22 17:15 gabrieljenik New Issue
2020-07-22 17:15 gabrieljenik Issue generated from: 16519
2020-07-22 17:15 gabrieljenik Relationship added related to 16519
2020-07-22 17:24 user225042 Status new => confirmed
2020-07-22 17:24 user225042 Zoho Sprints => |Yes|
2020-07-22 17:24 swendrich Zoho Sprints ID => 14469000000188013
2020-07-28 02:10 gabrieljenik Note Added: 59111
2020-07-29 16:22 swendrich Zoho Sprints Yes => |Yes|
2020-07-29 16:22 swendrich Status confirmed => resolved
2020-07-29 16:22 user225042 Status resolved => confirmed
2020-07-29 16:22 user225042 Zoho Sprints Yes => |Yes|
2020-07-30 11:22 user225042 Note Added: 59202
2020-07-30 11:22 user225042 File Added: 16520_Beforepulling_PR.png
2020-07-30 16:03 user225042 Note Added: 59216
2020-07-30 16:12 gabrieljenik Note Added: 59217
2020-07-30 16:18 user225042 Note Added: 59219
2020-07-30 17:26 user231563 Changeset attached => LimeSurvey 3.x-LTS 892314b7
2020-07-30 17:26 user231563 Note Added: 59225
2020-07-30 20:32 gabrieljenik Note Added: 59228
2020-07-30 20:33 gabrieljenik Note Edited: 59228 View Revisions
2020-08-03 11:55 lime_release_bot Zoho Sprints Yes => |Yes|
2020-08-03 11:55 lime_release_bot Note Added: 59260
2020-08-03 11:55 lime_release_bot Status confirmed => closed
2020-08-03 11:55 lime_release_bot Resolution open => fixed