View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
14977Bug reportsErgonomypublic2023-03-17 09:05
ReporterDenisChenu Assigned To 
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Summary14977: Hard to navigate in big survey
Description

It's really hard to navigate in big survey,
2.6lts have a dropdown with current Question inside this group + a next/previous button : it's far as great … but still really better …

Strangely : open group are not stable : sometimes current group is open some other are closed and some other open : maybe start by open onlycurrent group ?

Steps To Reproduce

Have a big survey, with docs survey : ls3_sample_survey_multilingual_fr_de_en_it

  1. Import
  2. Open the 3 1st group
  3. Search «Single choice question [dual]»
  4. Click : current question are 2 screen after (screen : 1920x1080)
Additional Information

Sometime : hide manually other group seems to work, but not always …

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)3.17.5 github
I will donate to the project if issue is resolvedNo
Browserff
Database type & versionnot relevant?
Server OS (if known)not relevant ?
Webserver software & version (if known)not relevant ?
PHP Versionnot relevant ?

Relationships

duplicate of 18567 new Big survey (lot of group and qquestion) really hard to edit 
related to 15103 closed No menu link to organize 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2019-06-15 11:12

developer  

ollehar

ollehar

2020-02-14 11:11

administrator   ~56006

More like feature request than bug?

DenisChenu

DenisChenu

2020-02-14 11:13

developer   ~56007

Unsure here : when you have a big survey with lot of question : you think LimeSurvey is unuable . Unusable => bug, no ?

ollehar

ollehar

2020-02-14 11:52

administrator   ~56013

Idk. Saying a feature doesn't cover all use-cases is not the same as the feature has bugs.

cdorin

cdorin

2020-02-21 20:02

reporter   ~56146

Once more UX resources will be put into the software, we will reanalyze this issue (i agree with you).

DenisChenu

DenisChenu

2020-02-22 14:47

developer   ~56147

Idk. Saying a feature doesn't cover all use-cases is not the same as the feature has bugs.

Have more than 15 question in survey seem majority , no ?

Current browse work good with 5/6 questions, not more. Previous one are not great too. But when using 2.6lts system even after year: i confirm : previous navigation in big survey are really best.

Maybe add a "searchable" dropdown with only current group ? And a next/previous can be a good idea.

DenisChenu

DenisChenu

2023-03-17 09:05

developer   ~74132

The other have more idea : i close this one

Issue History

Date Modified Username Field Change
2019-06-15 11:12 DenisChenu New Issue
2019-06-15 11:12 DenisChenu File Added: I-didnt-see-current-question-in-navigation.png
2019-06-15 11:12 DenisChenu File Added: See-where-he-his-4-sreens-after.png
2020-02-13 15:48 DenisChenu Relationship added related to 15103
2020-02-14 11:11 ollehar Note Added: 56006
2020-02-14 11:13 DenisChenu Note Added: 56007
2020-02-14 11:52 ollehar Note Added: 56013
2020-02-21 20:02 cdorin Assigned To => cdorin
2020-02-21 20:02 cdorin Status new => confirmed
2020-02-21 20:02 cdorin Note Added: 56146
2020-02-22 14:47 DenisChenu Note Added: 56147
2020-12-28 18:42 cdorin Assigned To cdorin =>
2020-12-28 18:42 cdorin Status confirmed => acknowledged
2022-06-01 01:06 gabrieljenik Project Bug reports => Feature requests
2022-06-01 14:21 gabrieljenik Project Feature requests => Bug reports
2023-03-17 09:05 DenisChenu Relationship added duplicate of 18567
2023-03-17 09:05 DenisChenu Note Added: 74132
2023-03-17 09:05 DenisChenu Status acknowledged => closed
2023-03-17 09:05 DenisChenu Resolution open => duplicate