View Issue Details

IDProjectCategoryView StatusLast Update
14652Bug reports[All Projects] Otherpublic2019-05-06 10:57
ReportercdorinAssigned Todominikvitt 
PriorityhighSeveritymajor 
Status closedResolutionfixed 
Product Version3.16.x 
Target VersionFixed in Version3.17.x 
Summary14652: Quota system is buggy if you allow users to edit
Description

Create a quota.
Quota action: allow user to modify his last answers before terminate survey.

Import the attached survey. Click yes or no. You are "quota-outed". But, you have the possibility to "Submit". Once you click on it, you are redirected to an empty page, and from there, to the end page.

In the past, there was no submit button.

Please note that if you click on submit and then on next, your answer will appear in the response table as being "complete", the user landing successfully of the end page (this is not supposed to happen).

For normal behaviour, export my second .lsa into your LS2 installation.

Additional Information

Please note that all the themes from LS3 behave in the same manner.

TagsNo tags attached.
Complete LimeSurvey version number (& build)irrelevant
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionirrelevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionirrelevant

Relationships

has duplicate 14845 closedcdorin Quota not working properly 

Activities

cdorin

cdorin

2019-03-15 11:29

manager  

Quotas-ls3.lsa (5,597 bytes)
Quotas-ls2.lsa (3,228 bytes)
Selection_076.png (8,918 bytes)
Selection_076.png (8,918 bytes)
Selection_077.png (5,546 bytes)
Selection_077.png (5,546 bytes)
Selection_078.png (7,581 bytes)
Selection_078.png (7,581 bytes)
cdorin

cdorin

2019-03-15 18:35

manager   ~51013

@DenisChenu, any thoughts on this? I think that the behaviour from LimeSurvey 2.73 is the default one (maybe you know better how it was in the past)

DenisChenu

DenisChenu

2019-03-15 19:14

developer   ~51019

In 2.6lts : you can only go to previous and not submit.

I think allowing «Previous» and «Confirm» (maybe default button must be renamed in quota) is a good solution but : it must work

  1. Previous must go to previous keeping answers (think the issue is more here).
  2. Confirm must show the same page but without previous and set completed to «something other than completed» (like quota out).
cdorin

cdorin

2019-03-21 12:17

manager   ~51085

@DenisChenu, I talked to @dominikvitt about it.

We propose to go back to the behaviour of 2.6lts (no submit button).

While we do agree with your proposed solution, we got some users reporting this oddly behaviour and we need smth at the moment that does not require too much tweaking. But your idea should be taken into account when ((if!)) the quota system will be rewritten in the features.

DenisChenu

DenisChenu

2019-03-21 12:28

developer   ~51086

In 4.0 then ? New feature for 4.0 or up ?
It can be great :)

cdorin

cdorin

2019-03-21 13:29

manager   ~51087

I can't provide any ETA. Will do my best to push it given the fact that it is a nice idea + it's a nice survey behaviour proposal.

DenisChenu

DenisChenu

2019-03-21 14:34

developer   ~51088

No ETA : move this to Feature request without target :). Mean 4.0 and up ;)

I have some since 2.6lts that come for 4.0

cdorin

cdorin

2019-04-18 10:57

manager   ~51513

Hey @dominikvitt, would it be possible to recreate the behaviour from LimeSurvey 2? Basically, the "Submit" Button needs to disappear when "quota-out-ed".

I will create a feature request with the proposal from @DenisChenu.

dominikvitt

dominikvitt

2019-04-23 18:21

developer   ~51555

https://github.com/LimeSurvey/LimeSurvey/commit/9e678fb1cf66e13402acca1bdb18f416477657c0

c_schmitz

c_schmitz

2019-04-24 17:21

administrator   ~51577

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28864

c_schmitz

c_schmitz

2019-04-30 09:12

administrator   ~51666

Fixed in Version 3.1.7.3

Related Changesets

LimeSurvey: master 9e678fb1

2019-04-23 18:18:38

Dominik Vitt

Details Diff
Fixed issue 14652: Quota system is showing submit button when quota exceeded Affected Issues
14652
mod - themes/survey/vanilla/views/subviews/content/quotas.twig Diff File

Issue History

Date Modified Username Field Change
2019-03-15 11:29 cdorin New Issue
2019-03-15 11:29 cdorin Status new => assigned
2019-03-15 11:29 cdorin Assigned To => dominikvitt
2019-03-15 11:29 cdorin File Added: Quotas-ls3.lsa
2019-03-15 11:29 cdorin File Added: Quotas-ls2.lsa
2019-03-15 11:29 cdorin File Added: Selection_076.png
2019-03-15 11:29 cdorin File Added: Selection_077.png
2019-03-15 11:29 cdorin File Added: Selection_078.png
2019-03-15 11:29 cdorin Priority none => high
2019-03-15 18:35 cdorin Note Added: 51013
2019-03-15 19:14 DenisChenu Note Added: 51019
2019-03-21 12:17 cdorin Note Added: 51085
2019-03-21 12:28 DenisChenu Note Added: 51086
2019-03-21 13:29 cdorin Note Added: 51087
2019-03-21 14:34 DenisChenu Note Added: 51088
2019-04-18 10:57 cdorin Note Added: 51513
2019-04-23 18:21 dominikvitt Status assigned => resolved
2019-04-23 18:21 dominikvitt Resolution open => fixed
2019-04-23 18:21 dominikvitt Fixed in Version => 3.17.x
2019-04-23 18:21 dominikvitt Note Added: 51555
2019-04-24 17:21 Changeset attached => LimeSurvey master 9e678fb1
2019-04-24 17:21 c_schmitz Note Added: 51577
2019-04-30 09:12 c_schmitz Note Added: 51666
2019-04-30 09:12 c_schmitz Status resolved => closed
2019-05-06 10:57 cdorin Relationship added has duplicate 14845