View Issue Details

IDProjectCategoryView StatusLast Update
14560Bug reports[All Projects] Survey editingpublic2019-09-30 16:41
ReporterDenisChenu Assigned Todominikvitt  
PrioritylowSeveritymajor 
Status closedResolutionfixed 
Product Version4.0.0dev 
Target VersionFixed in Version4.0.0-RC3 
Summary14560: Mandatory soft must be related to Question not Page
Description

Currently : seems mandatory soft is related to page then :

  • Group with mandatory hard + mandatory soft can be submitted without mandatory hard validation (3rd group in lss)
  • Group with mandatory soft + validation : popup shown but can not submit.
Steps To Reproduce

Import include lss and test it (in develop)

Additional Information

If mandatory soft is related to question :

  1. We can really fix this 2 issues
  2. We can show the system inside question answer for mandatory soft
  3. core theme can still shown a popup, button can validate all soft mandatory in the page
  4. another theme can show it differently

The fix must be set in expression_manager for starting
https://github.com/LimeSurvey/LimeSurvey/commit/a4ec47355e05ce198b32fa307e71a34cebb6b413#diff-796aba4d06254b9caea9d461e4ea80c9R6542

Not test a global var, but test (for exemple) if the SGQA is in an array of posted var.

Else
Another way to show a mansoft system : checkBoxForText test survey (real used system since more then 2 years).

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.0 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 12088 resolveddominikvitt Feature requests Semi-mandatory question (requesting answer instead of enforcing it) 

Activities

DenisChenu

DenisChenu

2019-02-21 09:51

developer  

survey_archive_manSoftTest.lsa (3,979 bytes)
DenisChenu

DenisChenu

2019-02-21 09:54

developer  

simplescreenrecorder-2019-02-21_09.53.18.webm (1,132,332 bytes)
DenisChenu

DenisChenu

2019-02-21 10:03

developer   ~50658

I think

  1. Fix Expression manager to test (for exemple) :
    1. global mansoft (for whole survey)
    2. 1 array of mansoft for Question (then can have way to disable for question
    3. 1 array of mansoft for SGQ (for subquestion, multiple text, but array of radio too)
    4. 1array of mansoft for Group
  2. Move the function to test POSTED value in public static function ProcessCurrentResponses() https://github.com/LimeSurvey/LimeSurvey/blob/a4ec47355e05ce198b32fa307e71a34cebb6b413/application/helpers/expressions/em_manager_helper.php#L8855 (because it's checked ONLY when need to process post)
  3. Fill information in a twig variable : (i don't remind if we have moveResult in aSurveyInfo)
DenisChenu

DenisChenu

2019-02-21 12:58

developer   ~50659

Last edited: 2019-02-21 13:00

View 2 revisions

Idea of updating #1

  1. In EM/ ProcessCurrentResponses : set EM->manSoft[qid][] with all array of qid checked
  2. In EM/validateQuestion : set mandatiory validation OK if EM->manSoft[qid][$qid] is set
  3. Add in qanda_helper, if question have mansoft a checkbox hidden with name mansoft['qid'][] width value current qid. Hide it for javascript
  4. The current button check all mansoft['qid'][] checkbox
cdorin

cdorin

2019-07-31 13:48

manager   ~53054

@dominikvitt, changed the priority. Since you created the question attribute, I guess assigning it to you is the most efficient way ^^

dominikvitt

dominikvitt

2019-09-17 14:30

developer   ~53605

This issue is fixed.
The patch is available now on GitHub and would be available on next LimeSurvey release.

https://github.com/LimeSurvey/LimeSurvey/commit/f6a9b3082bd0cf8306129d73382ee23e0740dc64

lime_release_bot

lime_release_bot

2019-09-30 16:41

administrator   ~53783

Fixed in Release 4.0.0-RC4+190930

Issue History

Date Modified Username Field Change
2019-02-21 09:51 DenisChenu New Issue
2019-02-21 09:51 DenisChenu Status new => assigned
2019-02-21 09:51 DenisChenu Assigned To => dominikvitt
2019-02-21 09:51 DenisChenu File Added: Capture d’écran du 2019-02-21 09-43-24.png
2019-02-21 09:51 DenisChenu File Added: Capture d’écran du 2019-02-21 09-49-41.png
2019-02-21 09:51 DenisChenu File Added: survey_archive_manSoftTest.lsa
2019-02-21 09:51 DenisChenu Additional Information Updated View Revisions
2019-02-21 09:52 DenisChenu Severity minor => major
2019-02-21 09:54 DenisChenu File Added: simplescreenrecorder-2019-02-21_09.53.18.webm
2019-02-21 10:03 DenisChenu Note Added: 50658
2019-02-21 12:58 DenisChenu Note Added: 50659
2019-02-21 13:00 DenisChenu Note Edited: 50659 View Revisions
2019-07-15 11:41 dominikvitt Assigned To dominikvitt => cdorin
2019-07-31 13:48 cdorin Assigned To cdorin => dominikvitt
2019-07-31 13:48 cdorin Priority none => low
2019-07-31 13:48 cdorin Note Added: 53054
2019-08-06 08:29 DenisChenu Relationship added related to 12088
2019-09-17 14:30 dominikvitt Status assigned => resolved
2019-09-17 14:30 dominikvitt Resolution open => fixed
2019-09-17 14:30 dominikvitt Fixed in Version => 4.0.0-RC3
2019-09-17 14:30 dominikvitt Note Added: 53605
2019-09-30 16:41 lime_release_bot Note Added: 53783
2019-09-30 16:41 lime_release_bot Status resolved => closed
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing