View Issue Details

IDProjectCategoryView StatusLast Update
14514Bug reports[All Projects] Central participant databasepublic2019-05-29 16:39
ReportercdorinAssigned Top_teichmann 
PrioritynormalSeveritymajor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.17.x 
Summary14514: Purpose of permission "update" - CPDB
Description

I cannot update shared participants since I have to specifically say when I share the participants that I give the right to the respective user to "update/edit" my users. Not sure exactly what is then the purpose of "update"

Also, it does not affect my right to edit/update the users added by me into the CPDB.

Steps To Reproduce
  1. Give create, view/read import and export permissions to a user
  2. Share participants with the respective user - do not give the right to the user to edit your participants
  3. The update permissions is useless in this regard
TagsNo tags attached.
Complete LimeSurvey version number (& build)irrelevant
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionirrelevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionirrelevant

Relationships

related to 14017 closedp_teichmann CPDB - view permission - user 
related to 14513 closedp_teichmann Permissions on shared participants (CPDB) 

Activities

DenisChenu

DenisChenu

2019-02-11 11:46

developer   ~50490

Then : must do exactly like Survey : checking "update" on global allow updating ALL participants : really seem better :)

markusfluer

markusfluer

2019-02-11 18:38

administrator   ~50506

I side with Denis here, I think the global permission should keep the general logic.
Maybe put this up for discussion tomorrow.

DenisChenu

DenisChenu

2019-02-11 19:29

developer   ~50507

The issue withnthis is like when we fix the issue with Survey global Permission : previously global permission are never used : you check "View" : no more right for this user .

When we fix the issue : some user's say all of theiur user see (and update) all survey , because they checked this Permission :)

p_teichmann

p_teichmann

2019-05-15 14:35

developer   ~51950

https://github.com/LimeSurvey/LimeSurvey/commit/5c9aa865cb19113325d8100bb7a7718a30334a8f

p_teichmann

p_teichmann

2019-05-29 16:12

developer   ~52179

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28896

c_schmitz

c_schmitz

2019-05-29 16:39

administrator   ~52223

Version 3.17.4+190529 released

Related Changesets

LimeSurvey: master 5c9aa865

2019-05-15 14:26:10

p_teichmann

Details Diff
Fixed issue 14514: Purpose of permission "update" - CPDB
Fixed issue: Administrators now have access to the CPDB if they have shared participants or have global Permissions 'read, create, update, delete', "global Permissions" > "shared Permissions"
Affected Issues
14514
mod - application/controllers/admin/participantsaction.php Diff File
mod - application/models/Participant.php Diff File
mod - application/models/ParticipantShare.php Diff File
mod - application/views/admin/participants/displayParticipants_view.php Diff File
mod - application/views/admin/participants/participantsPanel_view.php Diff File
mod - application/views/admin/participants/sharePanel_view.php Diff File
mod - application/views/admin/super/_configuration_menu.php Diff File
mod - application/views/admin/super/layout_main.php Diff File
mod - assets/scripts/admin/participantpanel.js Diff File

Issue History

Date Modified Username Field Change
2019-02-11 11:07 cdorin New Issue
2019-02-11 11:07 cdorin Status new => assigned
2019-02-11 11:07 cdorin Assigned To => markusfluer
2019-02-11 11:46 DenisChenu Note Added: 50490
2019-02-11 12:05 cdorin Summary Purpose of permission "updated" - CPDB => Purpose of permission "update" - CPDB
2019-02-11 18:38 markusfluer Note Added: 50506
2019-02-11 19:29 DenisChenu Note Added: 50507
2019-02-12 16:49 cdorin Priority none => normal
2019-02-12 16:49 cdorin Severity minor => major
2019-04-11 11:59 LouisGac Assigned To markusfluer => LouisGac
2019-04-30 10:18 cdorin Assigned To LouisGac => p_teichmann
2019-05-15 14:35 p_teichmann Status assigned => resolved
2019-05-15 14:35 p_teichmann Resolution open => fixed
2019-05-15 14:35 p_teichmann Fixed in Version => 3.17.x
2019-05-15 14:35 p_teichmann Note Added: 51950
2019-05-15 14:36 p_teichmann Relationship added related to 14017
2019-05-15 14:36 p_teichmann Relationship added related to 14513
2019-05-29 16:12 p_teichmann Changeset attached => LimeSurvey master 5c9aa865
2019-05-29 16:12 p_teichmann Note Added: 52179
2019-05-29 16:39 c_schmitz Note Added: 52223
2019-05-29 16:39 c_schmitz Status resolved => closed