View Issue Details

IDProjectCategoryView StatusLast Update
14017Bug reports[All Projects] User/User groupspublic2019-05-29 16:39
ReportercdorinAssigned Top_teichmann 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.13.x 
Target VersionFixed in Version3.17.x 
Summary14017: CPDB - view permission - user
Description

Text: Permission to create participants in the central participants database (for which all permissions are automatically given) and '''view''', update and delete participants from other users.

I wanted to offer to one my friends access to the CPDB. I granted him all the permissions that correspond to CPDB. However, he was still not able to see the participants from the CPDB. Also tested this functionaliy -> is it a bug?

Was this always the case? If yes, the text misleading because it says that you can "view... participants from other users".

Of course, he can see the CPDB participants if he gets the superadmin permission.

P.s. Offering him the view permission for label sets and surveys works fine. Seems that this issue exists only with CPDB.

TagsNo tags attached.
Complete LimeSurvey version number (& build)irrelevant
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionirrelevant
Server OS (if known)irrelevant
Webserver software & version (if known)irrelevant
PHP Versionirrelevant

Relationships

related to 14513 closedp_teichmann Permissions on shared participants (CPDB) 
related to 14514 closedp_teichmann Purpose of permission "update" - CPDB 

Activities

Mazi

Mazi

2018-10-23 15:52

partner   ~49413

I can confirm this issue using 3.14.9+180917.

As an admin user I can call the CPDB screen just fine but a user with view/edit/update rights gets an error message, see screenshot.



user_rights_cpdb.jpg (29,917 bytes)
user_rights_cpdb.jpg (29,917 bytes)
image003.jpg (16,465 bytes)
image003.jpg (16,465 bytes)
dominikvitt

dominikvitt

2018-10-25 15:06

developer   ~49438

@Mazi:
This error message you're having was resolved in version 3.15.0+181008.
https://github.com/LimeSurvey/LimeSurvey/commit/bb814dd89258abf967a424099389403e75a4fa41

DenisChenu

DenisChenu

2018-10-25 15:11

developer   ~49439

PS : the CPDB Permission have strange rights since start … if i remind only shared user are shown to other user, and then only CRUD Permission is apply

Maybe some user think it's an issue if it's update.

I really think it's a bad permission system Survey permission are really better BUT … update can broke some system (when i update Survey global permission : this permission was never used …)

dominikvitt

dominikvitt

2018-10-25 16:03

developer   ~49443

CPDB only lists participants in following cases:

  • user1 is survey owner AND he uses "Add participants to central database " function to add it to CPDB, user1 can see his own participants
  • user1 is survey owner AND he uses "Share this participant" function to share it to user2, user2 would be able to see shared participants

Behaviour of latest LS version 3.15.1 regarding CPDB functionality is exactly the same as in LS version 2.73.0.

cdorin

cdorin

2019-02-11 10:03

manager   ~50487

@c_schmitz, shall we leave it as it is (see @dominikvitt's comment)? If yes, I consider that the text from user permissions related to CPDB should be changed from:

" Permission to create participants in the central participants database (for which all permissions are automatically given) and view, update and delete participants from other users "

to

"Permission to create participants in the central participants database (for which all permissions are automatically given) and view, update, and delete participants shared by other users" ?

Or shall we change the way in which the CPDB permissions work? Once a user gets view/read CPDB rights, he/she can see (and edit if other rights are given) participants that are not shared by other users.

cdorin

cdorin

2019-02-11 10:27

manager   ~50488

Hey @markusfluer. This is the default behaviour in CPDB

p_teichmann

p_teichmann

2019-05-08 17:33

administrator   ~51840

https://github.com/LimeSurvey/LimeSurvey/commit/70d03f7ba093700c28f3727cd04760558dea17bb

c_schmitz

c_schmitz

2019-05-29 16:39

administrator   ~52238

Version 3.17.4+190529 released

Issue History

Date Modified Username Field Change
2018-08-30 14:39 cdorin New Issue
2018-10-23 15:52 Mazi File Added: user_rights_cpdb.jpg
2018-10-23 15:52 Mazi File Added: image003.jpg
2018-10-23 15:52 Mazi Note Added: 49413
2018-10-25 14:57 dominikvitt Assigned To => dominikvitt
2018-10-25 14:57 dominikvitt Status new => assigned
2018-10-25 15:06 dominikvitt Note Added: 49438
2018-10-25 15:11 DenisChenu Note Added: 49439
2018-10-25 16:03 dominikvitt Status assigned => resolved
2018-10-25 16:03 dominikvitt Resolution open => no change required
2018-10-25 16:03 dominikvitt Note Added: 49443
2019-02-11 10:03 cdorin Note Added: 50487
2019-02-11 10:27 cdorin Assigned To dominikvitt => markusfluer
2019-02-11 10:27 cdorin Status resolved => feedback
2019-02-11 10:27 cdorin Resolution no change required => reopened
2019-02-11 10:27 cdorin Note Added: 50488
2019-02-12 16:51 cdorin Relationship added related to 14513
2019-04-30 10:15 cdorin Assigned To markusfluer => p_teichmann
2019-04-30 10:15 cdorin Status feedback => confirmed
2019-05-08 17:33 p_teichmann Status confirmed => resolved
2019-05-08 17:33 p_teichmann Resolution reopened => fixed
2019-05-08 17:33 p_teichmann Note Added: 51840
2019-05-08 17:34 p_teichmann Fixed in Version => 3.17.x
2019-05-15 14:36 p_teichmann Relationship added related to 14514
2019-05-29 16:39 c_schmitz Note Added: 52238
2019-05-29 16:39 c_schmitz Status resolved => closed