View Issue Details

IDProjectCategoryView StatusLast Update
14476Bug reports[All Projects] Central participant databasepublic2019-04-30 09:11
Reportermadvet Assigned ToDenisChenu  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14476: token_id' doesn't have a default value- Not possible to add central participants to survey
Description

Tried to add participants to a survey from the central database. i get an error
Error: Could not copy attributes to tokens: file D:\inetpub\wwwroot\Survey\application\models\Participant.php, line 1707; Could not update token attribute value: CDbCommand failed to execute the SQL statement: SQLSTATE[HY000]: General error: 1364 Field 'token_id' doesn't have a default value

Steps To Reproduce

as above

Additional Information

none

TagsNo tags attached.
Complete LimeSurvey version number (& build)LimeSurvey version 3.15.8 LimeSurvey build 190130
I will donate to the project if issue is resolvedNo
BrowserChrome Version 71.0.3578.98 (Official Build) (64-bit)
Database & DB-Versionno idea where to find this
Server OS (if known)Windows NT ELS-INTERNET 6.1 build 7601 (Windows Server 2008 R2 Standard Edition Service Pack 1) i586
Webserver software & version (if known) Microsoft-IIS/7.5
PHP Version 5.6.21

Relationships

child of 14479 new Participant invalid email allowed and no error management 

Activities

DenisChenu

DenisChenu

2019-01-31 14:22

developer   ~50365

For the DB : you can click on limesurvey number version at bottom

madvet

madvet

2019-01-31 14:36

reporter   ~50368

Database driver version
mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $
Database server info
Uptime: 587787 Threads: 1 Questions: 13697346 Slow queries: 2 Opens: 1510 Flush tables: 1 Open tables: 1503 Queries per second avg: 23.303
Database server version
Uptime: 587787 Threads: 1 Questions: 13697346 Slow queries: 2 Opens: 1510 Flush tables: 1 Open tables: 1503 Queries per second avg: 23.303

Is that what you need?

madvet

madvet

2019-01-31 14:38

reporter   ~50369

It seems to allow adding of some participants one at a time. it ner allows more than one and some just refuse to be added to the survey. Not sure if this makes any sense.

madvet

madvet

2019-01-31 14:43

reporter   ~50370

Sorry about this. There are 2 participants that give me the error. I added all the other's one by one. I am not sure what is causing this but it is a massive pain. I am going to try to recreate the two participants and see if it still has an issue.

madvet

madvet

2019-01-31 14:57

reporter   ~50372

I think I found why I am getting the error. The two that could not be added had a ";" in the email field. Once I removed the ; they could be added. When I was doing bulk adding of people it was just an error.

Not sure if you guys could improve the error message?

DenisChenu

DenisChenu

2019-01-31 17:01

developer   ~50375

I just test with test1@example.org;test2@example.org on a mysql DB : it's OK.



madvet

madvet

2019-02-01 10:11

reporter   ~50383

I suspect they worked because the 2nd email did not have a ; at the end of it. These ones will not work



Limemails.JPG (26,931 bytes)
Limemails.JPG (26,931 bytes)
LimemailsError.JPG (33,727 bytes)
LimemailsError.JPG (33,727 bytes)
DenisChenu

DenisChenu

2019-02-01 10:28

developer   ~50384

Confirm the issue :

  1. participant rules lack of LSYii_EmailIDNAValidator for email
  2. token have LSYii_EmailIDNAValidator for email
  3. Then broken email broke update of token

Made a quick fix and open another issue

DenisChenu

DenisChenu

2019-02-01 10:51

developer   ~50385

Just a better error message (validate token before think it's OK and show the error validation)
https://github.com/LimeSurvey/LimeSurvey/commit/a8f0e520981384423d90ad0525b089b2df5d7b17

madvet

madvet

2019-02-01 10:53

reporter   ~50386

Thank you

Issue History

Date Modified Username Field Change
2019-01-31 14:16 madvet New Issue
2019-01-31 14:22 DenisChenu Note Added: 50365
2019-01-31 14:36 madvet Note Added: 50368
2019-01-31 14:38 madvet Note Added: 50369
2019-01-31 14:43 madvet Note Added: 50370
2019-01-31 14:57 madvet Note Added: 50372
2019-01-31 17:01 DenisChenu File Added: Capture d’écran du 2019-01-31 17-01-06.png
2019-01-31 17:01 DenisChenu Note Added: 50375
2019-02-01 10:11 madvet File Added: Limemails.JPG
2019-02-01 10:11 madvet File Added: LimemailsError.JPG
2019-02-01 10:11 madvet Note Added: 50383
2019-02-01 10:28 DenisChenu Note Added: 50384
2019-02-01 10:28 DenisChenu Assigned To => DenisChenu
2019-02-01 10:28 DenisChenu Status new => assigned
2019-02-01 10:49 DenisChenu Relationship added parent of 14479
2019-02-01 10:50 DenisChenu Relationship deleted parent of 14479
2019-02-01 10:50 DenisChenu Relationship added child of 14479
2019-02-01 10:51 DenisChenu Status assigned => resolved
2019-02-01 10:51 DenisChenu Resolution open => fixed
2019-02-01 10:51 DenisChenu Fixed in Version => 3.15.x
2019-02-01 10:51 DenisChenu Note Added: 50385
2019-02-01 10:53 madvet Note Added: 50386
2019-04-30 09:11 c_schmitz Status resolved => closed