View Issue Details

IDProjectCategoryView StatusLast Update
14449Feature requests[All Projects] Pluginspublic2019-05-10 15:34
ReporterDenisChenuAssigned ToDenisChenu 
PrioritynoneSeverityfeature 
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary14449: Question template : unable to make a complete system due to lack of information
Description

I try to find a way to have same system than 2.6 with display-columns (css) see : https://bugs.limesurvey.org/view.php?id=14202

But totally unable to do this because i have no way to have number of answer/subquestions and if question is mandatory or not and if question have other

TagsNo tags attached.

Relationships

duplicate of 14228 new Survey Theme need more information 
related to 14202 new Readd "column style" css for multiple column but in attribute 

Activities

DenisChenu

DenisChenu

2019-01-25 10:17

developer   ~50304

@LouisGac & @c_schmitz : i think it's an issue and can be fixed in 3.X : ok for this or not ? Only for develop ?

The fix can be done here : https://github.com/LimeSurvey/LimeSurvey/blob/master/application/helpers/qanda_helper.php#L5666
But need update at all call of this.

I think minimal must be
$oQuestion->attaributes;
array of $answer->attributes
array of $subQuestion-attributes
and array of all core attributes.

DenisChenu

DenisChenu

2019-01-25 10:20

developer   ~50306

  1. Current oQuestion with current language
  2. oSubquestions with current language
  3. oAnswers with current language
  4. theme + core attribute with current language (no need to test utf8, for example attribute.other_replace_text directly (this a must have for core too))

Issue History

Date Modified Username Field Change
2019-01-25 10:14 DenisChenu New Issue
2019-01-25 10:14 DenisChenu Relationship added related to 14202
2019-01-25 10:14 DenisChenu Relationship added related to 14228
2019-01-25 10:17 DenisChenu Note Added: 50304
2019-01-25 10:20 DenisChenu Note Added: 50306
2019-05-10 15:33 DenisChenu Relationship deleted related to 14228
2019-05-10 15:33 DenisChenu Relationship added duplicate of 14228
2019-05-10 15:34 DenisChenu Assigned To => DenisChenu
2019-05-10 15:34 DenisChenu Status new => closed
2019-05-10 15:34 DenisChenu Resolution open => duplicate