View Issue Details

IDProjectCategoryView StatusLast Update
14239Bug reports[All Projects] Conditionspublic2019-04-30 09:10
ReportergeraldCAssigned Todominikvitt 
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version3.13.x 
Target VersionFixed in Version 
Summary14239: Creation of conditions doesn't work
Description

Creating conditions doesn't work correctly. After trying to create one condition, one has to repeat the process with the same choices to see the condition.
LS 3.15.1

Steps To Reproduce
  1. Create question q1 (for instance "how old?")
  2. Create question q2
  3. Try to create a condition by clicking on "Set conditions", then :
    3b. For the "Question" part, select "q1: how old?"
    3c. For the "Answer" part, select "Constant" and type a number (33)
    3d. Click on "Add condition" at the bottom of the page
  4. The Conditions designer appears but shows an empty Box entitled "Default scenario" ! No conditions seems to have been memorized.
TagsNo tags attached.
Complete LimeSurvey version number (& build)LS 3.15.1
I will donate to the project if issue is resolvedNo
BrowserN/a
Database & DB-VersionN/a
Server OS (if known)N/a
Webserver software & version (if known)N/a
PHP VersionN/a

Relationships

related to 14045 assignedmarkusfluer Set Condition issue 
related to 14140 assignedmarkusfluer Inconsistent behaviour on 'Set Conditions' 
related to 13940 assignedmarkusfluer Admin Question and Condition Pages not loading correctly (3.14.1) 

Activities

dominikvitt

dominikvitt

2018-11-12 10:57

developer   ~49609

It seems to be working as expected on the latest version 3.15.4.
It may be fixed in the meantime.
You should upgrade to the latest LS version and then try to reproduce it again.

See attached screenshot to see my result.

dominikvitt

dominikvitt

2018-11-12 10:58

developer  

jelo

jelo

2018-11-19 11:31

partner   ~49694

Please update demo.limesurvey.org to 3.15.4.
If this fixes a few more bugtickets can be closed.

Issue History

Date Modified Username Field Change
2018-11-12 09:04 geraldC New Issue
2018-11-12 10:53 dominikvitt Assigned To => dominikvitt
2018-11-12 10:53 dominikvitt Status new => assigned
2018-11-12 10:57 dominikvitt Status assigned => resolved
2018-11-12 10:57 dominikvitt Resolution open => unable to reproduce
2018-11-12 10:57 dominikvitt Note Added: 49609
2018-11-12 10:58 dominikvitt File Added: Screenshot_2018-11-12_10-52-51.png
2018-11-19 11:31 jelo Note Added: 49694
2018-11-19 11:31 jelo Relationship added related to 14045
2018-11-19 11:32 jelo Relationship added related to 14140
2018-11-19 11:32 jelo Relationship added related to 13940
2019-04-30 09:10 c_schmitz Status resolved => closed