View Issue Details

IDProjectCategoryView StatusLast Update
14149Bug reportsSurvey takingpublic2019-09-16 09:36
ReporterWitz Assigned Tomarkusfluer 
Status assignedResolutionopen 
Product Version3.1.x 
Summary14149: question index/allow jumping is not working

I set 'Show question index / allow jumping' to Full. Question Index is showing on the survey but a user cannot jump the question. I tried it on the Demo site just in case and it's not working on it either so I believe it's a bug on this version.

Steps To Reproduce

Just try Question index with Full. You cannot jump the question. It goes one page forward only.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.11+180926
I will donate to the project if issue is resolvedNo
Database & DB-VersionSQL Server 10.0
Server OS (if known)Windows
Webserver software & version (if known)IIS 7.5
PHP Version5.6.30


related to 13860 closedmarkusfluer Unable to use button index with ajax mode 
has duplicate 15216 closedLouisGac ajax mode : full index broken 
related to 14616 closedLouisGac Disable AJAXMode by default or deactivate AJAXMode completly 




2018-10-17 10:00

developer   ~49345

Maybe same issue then here :

Did you try with ajax mode deactivated ?



2018-10-17 16:20

reporter   ~49352

No I didn't. As I mentioned initially it's happening at the Limesurvey Demo site too,

Please try it yourself at the Demo site.



2018-10-17 17:21

reporter   ~49353

I have found more clues. It's happening when the theme was extended.

It's working fine with a standard theme and themes that were extended before with a previous version. The theme extended newly with a current my version is making this problem even though I just extended the theme without any change on it.



2018-10-17 17:48

developer   ~49354

Last edited: 2018-10-17 17:53

View 2 revisions

Ok, even with Vanilla : i can confirm

Reproductibility : import




2018-10-19 13:55

developer   ~49370

Issue in ajaxfy.js :

Put a comment on this line : fixed



2018-10-19 16:04

reporter   ~49373

Do you mean comment out line 137 on LimeSurvey/themes/survey/vanilla/scripts/ajaxify.js?

I commented out this line and extended a Theme from bootswatch but it's still not working for me.



2018-10-19 16:57

developer   ~49380

Maybe another issue ? It work for me …
But for me : it don't work with current vanilla …



2018-10-21 14:37

reporter   ~49390

seems to be same as bug # 13930
de-activating Ajax did not fix the problem on my side.



2018-10-21 19:36

developer   ~49391

deactivating ajax didn't unload ajaxfy … is loaded even if ajax mode is off.

After updating : remind to reset the asset (in global setting)



2019-09-03 19:02

partner   ~53405

A customer of mine has reported the same issue.

It works fine at my system with Ajax mode being disabled. So let's finally implement to work around that!



2019-09-16 09:36

partner   ~53575

@c_schmitz, this was just reported by another customer. If Ajax mode is enabled, the index is broken. Please enforce that someone finally takes care of

Issue History

Date Modified Username Field Change
2018-10-16 20:15 Witz New Issue
2018-10-17 10:00 DenisChenu Note Added: 49345
2018-10-17 16:20 Witz Note Added: 49352
2018-10-17 17:21 Witz Note Added: 49353
2018-10-17 17:48 DenisChenu Note Added: 49354
2018-10-17 17:48 DenisChenu Status new => confirmed
2018-10-17 17:53 DenisChenu Note Edited: 49354 View Revisions
2018-10-19 13:54 DenisChenu Assigned To => markusfluer
2018-10-19 13:54 DenisChenu Status confirmed => assigned
2018-10-19 13:55 DenisChenu Note Added: 49370
2018-10-19 16:04 Witz Note Added: 49373
2018-10-19 16:57 DenisChenu Note Added: 49380
2018-10-21 14:37 dlaroche Note Added: 49390
2018-10-21 19:36 DenisChenu Note Added: 49391
2019-09-03 18:59 Mazi Relationship added related to 13860
2019-09-03 19:00 Mazi Relationship added related to 14616
2019-09-03 19:02 Mazi Note Added: 53405
2019-09-03 19:31 DenisChenu Relationship added has duplicate 15216
2019-09-16 09:36 Mazi Note Added: 53575