View Issue Details

IDProjectCategoryView StatusLast Update
13860Bug reports[All Projects] Survey takingpublic2018-07-25 19:33
ReporterDenisChenuAssigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status feedbackResolutionreopened 
Product Version3.13.x 
Target VersionFixed in Version 
Summary13860: Unable to use button index with ajax mode
Description

Button index didn't do action in ajaxmode (OK without ajaxmode)

Steps To Reproduce

Import included theme + survey
Launch survey, move next , try to use index

Additional Information

Issue is here : https://github.com/LimeSurvey/LimeSurvey/commit/d40dae716d5d7a58623a8ad334fd17625b8183a7#r29640118

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.13.2 github
I will donate to the project if issue is resolvedNo
BrowserFF
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 13910 closedmarkusfluer Unable to use saveall button 

Activities

DenisChenu

DenisChenu

2018-07-10 11:14

developer  

indextop_fruity.zip (135,480 bytes)
limesurvey_survey_SampleFullIndexAjaxMode.lss (362,061 bytes)
markusfluer

markusfluer

2018-07-10 14:02

manager   ~48485

Since this is somehow customized, I don't think it is a real bug.
Ajaxmode is experimental and so we cannot guarantee everything stays at it is.
Also this seems to only affect your customized theme.
The issue, btw is solved with a simple js snippet in your customisation.
See here: https://github.com/LimeSurvey/LimeSurvey/blob/master/assets/packages/limesurvey/survey.js#L157

DenisChenu

DenisChenu

2018-07-10 16:25

developer   ~48487

Last edited: 2018-07-10 16:27

View 2 revisions

Then: LimeSurvey usage is «don't touch anything»

We add twig system but : if you update a little : you must update totally …

Previous system didn't have know issue : YOU remove it without issue … i'm OK to fix issue if there are some but need a mantis, real report and some lss example …

PS : look at forum for "more next button", "index at other place"
About index : the last one is here : https://www.limesurvey.org/forum/design-issues/115844-move-the-question-index

markusfluer

markusfluer

2018-07-11 17:32

manager   ~48493

LimeSurvey usage is not don't touch anything, it is only the ajax mode and thus the specific file ajaxify.js, that is subject to change still.
We are looking for the most specific and most stable solution to get things going and the ajax-mode still is experimental.
I'm really sorry, this is affected. I will make sure to put every issue I find and fix into the bugtracker. I really don't want to fight about this.
I will check to revert the change, but I'm pretty sure the issues with IE11 and Edge will come up again then.

Issue History

Date Modified Username Field Change
2018-07-10 11:14 DenisChenu New Issue
2018-07-10 11:14 DenisChenu File Added: indextop_fruity.zip
2018-07-10 11:14 DenisChenu File Added: limesurvey_survey_SampleFullIndexAjaxMode.lss
2018-07-10 11:14 DenisChenu Assigned To => markusfluer
2018-07-10 11:14 DenisChenu Status new => assigned
2018-07-10 14:02 markusfluer Note Added: 48485
2018-07-10 14:07 markusfluer Status assigned => closed
2018-07-10 14:07 markusfluer Resolution open => won't fix
2018-07-10 16:25 DenisChenu Status closed => feedback
2018-07-10 16:25 DenisChenu Resolution won't fix => reopened
2018-07-10 16:25 DenisChenu Note Added: 48487
2018-07-10 16:27 DenisChenu Note Edited: 48487 View Revisions
2018-07-11 17:32 markusfluer Note Added: 48493
2018-07-25 19:33 DenisChenu Relationship added related to 13910