View Issue Details

IDProjectCategoryView StatusLast Update
13936Bug reports[All Projects] Theme editorpublic2019-05-29 16:39
ReporterDenisChenuAssigned ToDenisChenu 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.17.x 
Summary13936: Bootswatch inherit everyting to no: deactivate container
Description

When you deactivate ajaxMode for a survey with Bootswatch this deactivate container.

Steps To Reproduce

Just check "Inherit everything" to no with a bootsrap model.

Additional Information

container are nnot in options of bootswatch … since vanilla is the parent : it's needed ( options must use array_merge_recursive)

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 13930 assignedmarkusfluer Question index doesn't jump back or forth when using survey with barely customised theme 

Activities

DenisChenu

DenisChenu

2018-08-02 18:50

developer  

segui

segui

2018-08-07 19:31

reporter   ~48749

Why was this marked as "unable to reproduce" and resolved? DenisChenu obviously reproduced it, and steps are in ticket 13930.

LouisGac

LouisGac

2018-08-08 10:48

manager   ~48751

because I could not reproduce on a fresh installation.
I'll have a look to 13930 right now.

c_schmitz

c_schmitz

2018-09-03 17:14

administrator   ~48954

Version 3.14.8+180829 released

DenisChenu

DenisChenu

2018-09-03 18:33

developer   ~48956

Last edited: 2018-09-03 18:37

View 3 revisions

I still don't see how to have (without update bootswatch theme)
bootswatch core theme + Show popups to None (for example) + container (not fluid)

(even after reset bootswatch + vanilla + bootswatch : no way to have container (not fluid) + Show popups to Off

DenisChenu

DenisChenu

2018-09-03 18:34

developer  

DenisChenu

DenisChenu

2018-09-03 18:34

developer  

limesurvey_survey_794683.lss (28,518 bytes)
DenisChenu

DenisChenu

2019-01-31 14:55

developer   ~50371

Screencast for proof of reproductability
https://framadrop.org/r/DnvvM5JBo1#a0Hd1jshANXgg71An7JSPMf6UJqaATiX+SndwS0W8AI=
https://framadrop.org/r/sD7_f_O3Rl#C64eshtk0GPGI7zaB1IE3R2BpSI8EzqWge12M8x3+v0=

DenisChenu

DenisChenu

2019-05-02 14:40

developer   ~51725

Proof with last git version …



simplescreenrecorder-2019-05-02_14.39.02.webm (753,201 bytes)
DenisChenu

DenisChenu

2019-05-03 08:36

developer   ~51746

https://github.com/LimeSurvey/LimeSurvey/commit/a873e84392f69bfc6af95809f07a1c6a245a084f

DenisChenu

DenisChenu

2019-05-29 16:12

developer   ~52196

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28929

c_schmitz

c_schmitz

2019-05-29 16:39

administrator   ~52207

Version 3.17.4+190529 released

Related Changesets

LimeSurvey: master a873e843

2019-05-02 17:46:06

DenisChenu


Committer: Dominik Vitt Details Diff
Fixed issue 13936: Bootswatch inherit everyting to no: deactivate container (#1196)

Dev: just add the option from vanilla in bootswatch
Dev: quick fix since it was always reproducible
Affected Issues
13936
mod - themes/survey/bootswatch/options/options.twig Diff File

Issue History

Date Modified Username Field Change
2018-08-02 18:50 DenisChenu New Issue
2018-08-02 18:50 DenisChenu File Added: Capture du 2018-08-02 18-45-56.png
2018-08-06 10:33 LouisGac Sticky Issue No => Yes
2018-08-07 12:28 LouisGac Assigned To => LouisGac
2018-08-07 12:28 LouisGac Status new => resolved
2018-08-07 12:28 LouisGac Resolution open => unable to reproduce
2018-08-07 12:28 LouisGac Sticky Issue Yes => No
2018-08-07 19:31 segui Note Added: 48749
2018-08-08 10:48 LouisGac Note Added: 48751
2018-09-03 17:14 c_schmitz Note Added: 48954
2018-09-03 17:14 c_schmitz Status resolved => closed
2018-09-03 18:33 DenisChenu Status closed => feedback
2018-09-03 18:33 DenisChenu Resolution unable to reproduce => reopened
2018-09-03 18:33 DenisChenu Note Added: 48956
2018-09-03 18:34 DenisChenu File Added: Capture du 2018-09-03 18-32-42.png
2018-09-03 18:34 DenisChenu File Added: limesurvey_survey_794683.lss
2018-09-03 18:34 DenisChenu Note Edited: 48956 View Revisions
2018-09-03 18:37 DenisChenu Note Edited: 48956 View Revisions
2018-09-10 11:05 LouisGac Status feedback => acknowledged
2019-01-31 14:55 DenisChenu Note Added: 50371
2019-05-02 14:40 DenisChenu File Added: simplescreenrecorder-2019-05-02_14.39.02.webm
2019-05-02 14:40 DenisChenu Note Added: 51725
2019-05-02 14:43 DenisChenu Relationship added related to 13930
2019-05-03 08:36 DenisChenu Assigned To LouisGac => DenisChenu
2019-05-03 08:36 DenisChenu Status acknowledged => resolved
2019-05-03 08:36 DenisChenu Resolution reopened => fixed
2019-05-03 08:36 DenisChenu Fixed in Version => 3.17.x
2019-05-03 08:36 DenisChenu Note Added: 51746
2019-05-29 16:12 DenisChenu Changeset attached => LimeSurvey master a873e843
2019-05-29 16:12 DenisChenu Note Added: 52196
2019-05-29 16:39 c_schmitz Note Added: 52207
2019-05-29 16:39 c_schmitz Status resolved => closed