View Issue Details

IDProjectCategoryView StatusLast Update
13862Bug reports[All Projects] _ Unknownpublic2018-11-12 16:16
ReportertizianomuellerAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status resolvedResolutionunable to reproduce 
Product Version3.12.x 
Target VersionFixed in Version 
Summary13862: Answer is ignored the first time after resuming a survey
Description

When resuming a survey, the answer for the current page is ignored when trying to go to the next page.
This generates an error if the question is mandatory and the user has to enter the answer a second time.

Steps To Reproduce
  1. Create a single choice question in a survey with "Resume later" enabled (plus tokens)
  2. Answer until this question
  3. Close the browser
  4. Re-enter the survey via the invite link
  5. Give the answer
  6. Click "Next"
  7. Get the error message "This question is mandatory" with nothing selected
  8. Give the answer again
  9. Click next again
Additional Information

This is really annoying in combination with bug 13861

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.12.3
I will donate to the project if issue is resolvedNo
BrowserChromium
Database & DB-VersionHosted on LimeQuery.org
Server OS (if known)Hosted on LimeQuery.org
Webserver software & version (if known)Hosted on LimeQuery.org
PHP VersionHosted on LimeQuery.org

Activities

LouisGac

LouisGac

2018-07-30 18:35

manager   ~48628

I just would like to thank you tizianomueller for all those excellent bug reports for the "resume survey" functionality .

dominikvitt

dominikvitt

2018-11-12 16:16

developer   ~49615

This issue is already fixed, I'm unable to reproduce it.

Issue History

Date Modified Username Field Change
2018-07-10 21:11 tizianomueller New Issue
2018-07-30 18:35 LouisGac Note Added: 48628
2018-08-28 11:51 LouisGac Assigned To => dominikvitt
2018-08-28 11:51 LouisGac Status new => assigned
2018-11-12 16:16 dominikvitt Status assigned => resolved
2018-11-12 16:16 dominikvitt Resolution open => unable to reproduce
2018-11-12 16:16 dominikvitt Note Added: 49615