View Issue Details

IDProjectCategoryView StatusLast Update
13861Bug reports[All Projects] _ Unknownpublic2019-04-19 11:49
ReportertizianomuellerAssigned ToDenisChenu 
PrioritynoneSeveritytweak 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary13861: "Resume later" clears current answer
Description

When clicking "Resume later" in a survey where the Resume Later functionality plus tokens is activated, the current answer is cleared.

Steps To Reproduce
  1. start survey via invite link
  2. answer question
  3. click "Resume Later"
  4. the page gets reloaded without the answer for the current question
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.12.3
I will donate to the project if issue is resolvedNo
BrowserChromium, Firefox
Database & DB-VersionHosted on LimeQuery.org
Server OS (if known)Hosted on LimeQuery.org
Webserver software & version (if known)Hosted on LimeQuery.org
PHP VersionHosted on LimeQuery.org

Relationships

related to 14444 closedcdorin disappearing answers upon continue later, js execution disabled. Images not loading in edge browser 

Activities

tizianomueller

tizianomueller

2018-07-10 21:15

reporter   ~48489

It seems to depend on how the question was reached: if the question was opened via the invite-link and the resume-later feature, directly clicking "Resume Later" will clear the answer, while when reaching the question from a previous one, the answer is correctly saved.

LouisGac

LouisGac

2018-07-30 18:35

manager   ~48627

this one is an old one and hard to fix one.

Mazi

Mazi

2018-08-17 15:11

partner   ~48820

Well, deleting answers should be prevented in any case! The work-flow described above ("Click invitation link, click save and resume -> data deleted") may not be that uncommon so I vote for fixing this.

LouisGac

LouisGac

2018-09-27 17:32

manager   ~49156

yes I agree, we have two requests about it on the LimeSurvey Professional Hosting. I'll take some time tomorow to see if I can fix without to much refactorisation.

dtpacribb

dtpacribb

2018-11-26 16:43

reporter   ~49786

Any progress on this? Looks like it's still occurring on 3.15.5+181115

DenisChenu

DenisChenu

2019-01-31 14:30

developer   ~50366

I just test with last version

With no link between answer and token : enter toto + toto, save : get back to survey with a javascript alert (if ajax activated, OK without)

With token answer persistance : seems there are an issue : save form is shown even if not needed (i report the issu).

c_schmitz

c_schmitz

2019-04-18 14:46

administrator   ~51522

Afaik this is fixed by now. DEnis, can you test again, please?

DenisChenu

DenisChenu

2019-04-19 11:49

developer   ~51539

Fixed or can not reproduce.

I report another issue with ajax mode and js issue.

Issue History

Date Modified Username Field Change
2018-07-10 21:06 tizianomueller New Issue
2018-07-10 21:15 tizianomueller Note Added: 48489
2018-07-30 18:34 LouisGac Sticky Issue No => Yes
2018-07-30 18:35 LouisGac Note Added: 48627
2018-08-17 15:11 Mazi Note Added: 48820
2018-09-27 17:32 LouisGac Note Added: 49156
2018-11-26 16:43 dtpacribb Note Added: 49786
2019-01-31 14:30 DenisChenu Note Added: 50366
2019-01-31 14:33 DenisChenu Relationship added related to 14444
2019-04-18 14:46 c_schmitz Note Added: 51522
2019-04-19 11:49 DenisChenu Assigned To => DenisChenu
2019-04-19 11:49 DenisChenu Status new => closed
2019-04-19 11:49 DenisChenu Resolution open => fixed
2019-04-19 11:49 DenisChenu Note Added: 51539