View Issue Details

IDProjectCategoryView StatusLast Update
13829Bug reports[All Projects] Survey designpublic2019-05-23 09:57
ReporterefingdmiAssigned Toc_schmitz 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.13.x 
Target VersionFixed in Version3.17.x 
Summary13829: Save new question results in blank page and shows errors
Description

Save new question: blank page + error when open a working page again
Save and New: error that question could not be created, but it was created

Steps To Reproduce

Create new Survey: fine
create new question Group: fine
create new question: enter Details -> press save - result: blank page
(blank_page.png)

If you go back to the landing page then, you will see the red "Question could not be created" message but looking into the survey shows, that the question was created.
(question_not_saved.png)

If I try it now with save and new, I will see the same "Question could not be created" message but the question is displayed in the structure view on the left side.
(save_and_new.png)

Additional Information

At the Moment it seems that mssql and LimeSurvey hate each other :(

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.13.0
I will donate to the project if issue is resolvedNo
BrowserFirefox 61.0
Database & DB-Version MS SQL Server 2016
Server OS (if known) Windows Server 2012 R2 64Bit
Webserver software & version (if known)Apache Apache 2.4.33 (64bit)
PHP VersionPHP 7.2.6 (64bit)

Activities

efingdmi

efingdmi

2018-06-29 10:39

reporter  

blank_page.png (6,743 bytes)
blank_page.png (6,743 bytes)
question_not_saved.png (40,496 bytes)
question_not_saved.png (40,496 bytes)
save_and_new.png (47,403 bytes)
save_and_new.png (47,403 bytes)
c_schmitz

c_schmitz

2018-06-29 11:07

administrator   ~48395

I cannot reproduce this issue. Please activate debug mode in /applicaton/config/config.php and see if you get some error text.

efingdmi

efingdmi

2018-06-29 13:52

reporter   ~48404

unfortunately not

I tried it with MySQL - there everthing is fine but e.g. one difference is the URL
Example: check the URL of the white page - it Ends with gid/7/qid, using MySQL it is gid/7/qid/7

Unfortunately I have to use MSSQL

It seems there are a lot of errors with MSSQL at the Moment where LS says that something could not be saved but it actually is saved (e.g. https://bugs.limesurvey.org/view.php?id=13752)
We can't find any Problems on DB side - the date gets written fine, just LS shows errors (or blank page)

c_schmitz

c_schmitz

2018-06-29 14:02

administrator   ~48406

Last edited: 2018-06-29 14:03

View 2 revisions

That sounds like a good hint:

Try the following: Open /controllers/admin/database.php, around line 1264 there are the following lines:

        $oQuestion->save();
        if ($oQuestion) {
            $this->iQuestionID = $oQuestion->qid;
        }

replace it with

        $bResult=$oQuestion->save();
        if ($bResult==true) {
            $this->iQuestionID = $oQuestion->qid;
        }

Let us know if it fixes the error.

efingdmi

efingdmi

2018-06-29 14:14

reporter   ~48408

Changed database.php, restarted Apache, restarted browser - sadly no change at all :(

c_schmitz

c_schmitz

2018-06-29 14:44

administrator   ~48411

How does your freetds.conf look like?

efingdmi

efingdmi

2018-06-29 15:20

reporter   ~48414

Do i need freetds for Windows? I checked the LS manual again but I can just find Linux related comments about freetds

If you give some more information I will do what I need to do here.

efingdmi

efingdmi

2018-07-13 07:18

reporter   ~48503

Seems to be solved in 13.2

Issue History

Date Modified Username Field Change
2018-06-29 10:39 efingdmi New Issue
2018-06-29 10:39 efingdmi File Added: blank_page.png
2018-06-29 10:39 efingdmi File Added: question_not_saved.png
2018-06-29 10:39 efingdmi File Added: save_and_new.png
2018-06-29 11:06 ollehar Assigned To => c_schmitz
2018-06-29 11:06 ollehar Status new => assigned
2018-06-29 11:07 c_schmitz Status assigned => feedback
2018-06-29 11:07 c_schmitz Note Added: 48395
2018-06-29 13:52 efingdmi Note Added: 48404
2018-06-29 13:52 efingdmi Status feedback => assigned
2018-06-29 14:02 c_schmitz Note Added: 48406
2018-06-29 14:03 c_schmitz Note Edited: 48406 View Revisions
2018-06-29 14:14 efingdmi Note Added: 48408
2018-06-29 14:44 c_schmitz Note Added: 48411
2018-06-29 15:20 efingdmi Note Added: 48414
2018-07-13 07:18 efingdmi Note Added: 48503
2019-05-23 09:57 c_schmitz Status assigned => closed
2019-05-23 09:57 c_schmitz Resolution open => fixed
2019-05-23 09:57 c_schmitz Fixed in Version => 3.17.x