View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
13702Bug reportsPluginspublic2018-08-07 17:01
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.7.x 
Fixed in Version3.13.x 
Summary13702: beforeCloseHtml event removed
DescriptionSee https://manual.limesurvey.org/BeforeCloseHtml
No event like this in 3.0
Steps To Reproducegrep -ri beforeCloseHtml * ;)

Usage : render a warning for maintenance mode (for example)
TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)3.8.0 git
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database type & versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 13889 new Feature requests Allow plugin to extend twig file 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

LouisGac

LouisGac

2018-05-23 10:39

developer   ~47722

Denis, can your twig replacement plugin be considerate as a fix for this bug?
DenisChenu

DenisChenu

2018-05-24 18:26

developer   ~47805

Not really : because we can not "append" something to a existing twig file easily.

If we add something with "append" on twig renderer : it's fix the issue with maintenance mode or when user want to add HTML/twih on public page, but not "do something without showing HTML (log ? I donr't know current usage of beforeCloseHtml except adding HTML).

Maybe we need something for twig allowing expand to existing twig , but need to be cached (else : lot of memory if there are an event for each twig file)
DenisChenu

DenisChenu

2018-05-24 18:27

developer   ~47806

See : https://github.com/LimeSurvey/LimeSurvey/pull/1079 related pull request too
LouisGac

LouisGac

2018-05-25 10:24

developer   ~47807

Twig Blocks should make it easier
https://twig.symfony.com/doc/2.x/tags/extends.html
DenisChenu

DenisChenu

2018-05-26 18:40

developer   ~47865

Last edited: 2018-05-26 18:42

View 3 revisions

You added : getPluginsData https://github.com/LimeSurvey/LimeSurvey/blob/fa236596754dc6917aa4fb65108d7087594e7190/application/core/LSETwigViewRenderer.php#L296

It's done only for layout ? Right ?

Currently i redo renderMessage helper plugin to add an empty layout (to have somethong similar of renderPartial)
With getPluginsData : the string of plugin is added core string , then after html was closed … no ?

DenisChenu

DenisChenu

2018-05-26 19:37

developer   ~47866

Since getAllContent return array of string made by plugins https://github.com/LimeSurvey/LimeSurvey/blob/fa236596754dc6917aa4fb65108d7087594e7190/application/libraries/PluginManager/PluginEventContent.php#L51

The event beforeTwigRenderTemplate didn't allow plugin to add content to sTwigBlocks …
DenisChenu

DenisChenu

2018-07-14 19:23

developer   ~48515

https://github.com/LimeSurvey/LimeSurvey/pull/1097

user70560

2018-07-19 08:55

  ~48534

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27638
markusfluer

markusfluer

2018-08-07 17:01

administrator   ~48717

Release 3.14.2+180807

Related Changesets

LimeSurvey: master eb78d265

2018-07-19 08:55:32

user70560


Committer: GitHub Details Diff
Fixed issue 13702: beforeCloseHtml event removed

Dev: Readded in render function
Dev: Whitelisting available controller (only public)
Affected Issues
13702
mod - application/core/LSYii_ClientScript.php Diff File

Issue History

Date Modified Username Field Change
2018-05-22 16:23 DenisChenu New Issue
2018-05-23 10:39 LouisGac Assigned To => DenisChenu
2018-05-23 10:39 LouisGac Status new => assigned
2018-05-23 10:39 LouisGac Note Added: 47722
2018-05-24 18:26 DenisChenu Note Added: 47805
2018-05-24 18:27 DenisChenu Note Added: 47806
2018-05-25 10:24 LouisGac Note Added: 47807
2018-05-26 18:40 DenisChenu Note Added: 47865
2018-05-26 18:40 DenisChenu Note Edited: 47865 View Revisions
2018-05-26 18:42 DenisChenu Note Edited: 47865 View Revisions
2018-05-26 19:37 DenisChenu Note Added: 47866
2018-06-26 09:52 DenisChenu Assigned To DenisChenu =>
2018-06-26 09:52 DenisChenu Status assigned => new
2018-07-14 19:23 DenisChenu Note Added: 48515
2018-07-14 19:23 DenisChenu Assigned To => LouisGac
2018-07-14 19:23 DenisChenu Status new => assigned
2018-07-14 19:24 DenisChenu Status assigned => feedback
2018-07-19 08:55 user70560 Changeset attached => LimeSurvey master eb78d265
2018-07-19 08:55 user70560 Note Added: 48534
2018-07-19 08:55 user70560 Assigned To LouisGac => user70560
2018-07-19 08:55 user70560 Resolution open => fixed
2018-07-19 14:38 DenisChenu Assigned To user70560 => DenisChenu
2018-07-19 14:38 DenisChenu Status feedback => resolved
2018-07-19 14:38 DenisChenu Fixed in Version => 3.13.x
2018-07-20 16:35 DenisChenu Relationship added related to 13889
2018-08-07 17:01 markusfluer Status resolved => closed
2018-08-07 17:01 markusfluer Note Added: 48717