View Issue Details

IDProjectCategoryView StatusLast Update
13340Bug reports[All Projects] Data Entry (non public)public2018-02-19 14:01
ReporterJamesHarrisHKIAssigned Toolle 
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version3.3.x 
Target VersionFixed in Version3.3.x 
Summary13340: Pressing Enter key clears form
DescriptionIn surveys that have a short or long free text field, pressing Enter in these fields clears all the fields in the current question group. This prevents the user from entering multi-line information such as addresses.

This problem seems specific to the Vanilla and Bootswatch themes.
Steps To Reproduce1. Create a new survey
2. Create a question group
3. Add a long free text question
4. Add a short free text question
5. Go to Settings -> General settings and change the Template to "vanilla" or "bootwatch"
6. Click "Preview survey"
7. Click "Next" to enter the survey
8. Type something into either question box (or both boxes) and press Enter. Fields on the page will be cleared.
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.3.0+180209
I will donate to the project if issue is resolvedNo
BrowserFirefox and Chrome
Database & DB-Version347
Operating System (Server)Windows Server 2008
Webserver software & versionApache/2.4.23 (Win64)
PHP Version7.0.9

Relationships

duplicate of 13234 closedmarkusfluer Focus in text fields when pressing return 

Activities

pgs

pgs

2018-02-13 01:04

reporter   ~46405

corresponds with 13234?
https://bugs.limesurvey.org/view.php?id=13234
olle

olle

2018-02-13 16:56

administrator   ~46412

Please, in the future, always attach a survey which reproduces the issue.
olle

olle

2018-02-13 16:59

administrator   ~46413

Cannot reproduce. More info, like video or screenshot?
JamesHarrisHKI

JamesHarrisHKI

2018-02-13 17:13

reporter   ~46415

Here's the survey I created to demonstrate this problem: http://uksurveys.hkipop.com/index.php/397881?newtest=Y&lang=en

survey_archive_397881.lsa (2,895 bytes)
olle

olle

2018-02-14 12:43

administrator   ~46445

Sorry, still cannot reproduce. Tested with Firefox and Chromium on my machine.

Can you enable debug = 2 in config.php, please? Also, click F12 to check for errors in the browser control.
JamesHarrisHKI

JamesHarrisHKI

2018-02-14 17:25

reporter   ~46476

Debug is set to 2. On pageload, I get this message in the console: "JQMIGRATE: Migrate is installed, version 3.0.0" Reproducing the bug does not produce a message in the console.

Here's a video demonstrating the problem: https://i.imgur.com/WcsmocY.gifv

This is very strange - you're saying that when you visit http://uksurveys.hkipop.com/index.php/397881?newtest=Y&lang=en and type some text and press Enter, the page functions as intended? You may need to wait a couple seconds to see the form reset, as shown in the video. We've tried this on a few computers here, in Chrome and Firefox, and the bug always reproduces.

I've also just noticed that if I press Enter twice, I get this message in a modal dialog: "Please use the survey navigation buttons or index. It appears you attempted to use the browser back button to re-submit a page."
olle

olle

2018-02-14 17:38

administrator   ~46480

Do you have Ajax mode enabled? Go to theme options and check (don't inherit options).

I can reproduce on your survey, but not on my machine.
YuVeRe

YuVeRe

2018-02-14 18:01

reporter   ~46482

I have the same problem in my survey.
JamesHarrisHKI

JamesHarrisHKI

2018-02-15 17:37

reporter   ~46541

Ah! The "vanilla" theme has Ajax mode enabled, and my survey was set to inherit that. Disabling Ajax mode makes the problem go away.
olle

olle

2018-02-19 14:01

administrator   ~46579

Markus fixed this for duplicate issue 13234.

Issue History

Date Modified Username Field Change
2018-02-13 00:07 JamesHarrisHKI New Issue
2018-02-13 01:04 pgs Note Added: 46405
2018-02-13 16:56 olle Note Added: 46412
2018-02-13 16:59 olle Status new => feedback
2018-02-13 16:59 olle Note Added: 46413
2018-02-13 17:13 JamesHarrisHKI File Added: survey_archive_397881.lsa
2018-02-13 17:13 JamesHarrisHKI Note Added: 46415
2018-02-13 17:13 JamesHarrisHKI Status feedback => new
2018-02-14 12:43 olle Note Added: 46445
2018-02-14 12:43 olle Assigned To => olle
2018-02-14 12:43 olle Status new => feedback
2018-02-14 17:25 JamesHarrisHKI Note Added: 46476
2018-02-14 17:25 JamesHarrisHKI Status feedback => assigned
2018-02-14 17:38 olle Note Added: 46480
2018-02-14 17:38 olle Status assigned => confirmed
2018-02-14 18:01 YuVeRe Note Added: 46482
2018-02-15 13:43 olle Status confirmed => feedback
2018-02-15 17:37 JamesHarrisHKI Note Added: 46541
2018-02-15 17:37 JamesHarrisHKI Status feedback => assigned
2018-02-19 14:01 olle Note Added: 46579
2018-02-19 14:01 olle Status assigned => closed
2018-02-19 14:01 olle Resolution open => duplicate
2018-02-19 14:01 olle Fixed in Version => 3.3.x
2018-02-19 14:01 olle Relationship added duplicate of 13234