View Issue Details

IDProjectCategoryView StatusLast Update
13234Bug reports[All Projects] Survey designpublic2018-02-19 15:06
ReporterpgsAssigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionreopened 
Product Version3.0.x 
Target VersionFixed in Version3.4.x 
Summary13234: Focus in text fields when pressing return
Description

Hello,

when pressing Enter after typing in a text input field (some users in the wild do this, our pretesters did not come up with this idea), focus is not kept in the text field.

With a single line text filed, pressing Return results in a behaviour like one pressed the browsers back button. In Firefox and Chrome LS intercepts with a "Don't use your browsers navigation" message. In IE the previous survey page is retrieved.

With a multiple line text field, in Firefox, Chrome, IE the field is blanked.

I Think thi would not occure if while pressing Enter the focus would be kept in the field. Focus should only leave the field when pressing Tab or when cklicking outside.

Tagsfocus, text field
Complete LimeSurvey version number (& build) 3.0.5+180118
I will donate to the project if issue is resolvedNo
BrowserFF, IE, Chrome
Database & DB-VersionMariaDB 10.1.26
Operating System (Server)Debian 9
Webserver software & versionApache2 2.4.25-3
PHP Version7.0+49

Relationships

has duplicate 13340 closedolle Pressing Enter key clears form 

Activities

c_schmitz

c_schmitz

2018-01-24 16:23

administrator   ~46023

Ideally, nothing should happen if someone pressed Enter, except if it is a multiline text field.

zbm

zbm

2018-01-29 22:19

reporter   ~46143

I also experience this issue in my surveys.

Version 3.0.5+180118

In multiline text boxes, hitting the "return" key it refreshes the page of the survey you are on. This leads to all the previous inputs on that page of the survey being lost.

markusfluer

markusfluer

2018-02-02 16:28

manager   ~46224

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26315

zbm

zbm

2018-02-02 23:13

reporter   ~46238

I updated that file and it didn't fix anything.

markusfluer

markusfluer

2018-02-03 11:51

manager   ~46239

Have you flushed your cache?
inside of your limesurvey installation folder run php application/commands/console.php flushassets

pgs

pgs

2018-02-05 11:45

reporter   ~46251

Hello,

updated the file, flushed the cache. Works not as intended: When pressing Retsurn while in a text field, now the actual page gets reloaded.

zbm

zbm

2018-02-05 18:09

reporter   ~46271

Even before the fix, the issue for me was that it always refreshed the page.

zbm

zbm

2018-02-06 14:50

reporter   ~46281

Why would this issue get closed if we are still seeing the problem?

markusfluer

markusfluer

2018-02-06 15:09

manager   ~46283

Are you using the default templates and the current version?

pgs

pgs

2018-02-08 02:57

reporter   ~46301

Default templates, current versuion ( Version 3.2.1+180207). Still refreshing the page after a minmal delay after pressing resturn when in multiple line textfield.

olle

olle

2018-02-13 16:54

administrator   ~46411

Reopened issue since it's not resolved.

markusfluer

markusfluer

2018-02-15 13:32

manager   ~46522

Ok i found the issue.
Pjax is incorrectly submitting on any enter inside of the page.
Fixed now.

markusfluer

markusfluer

2018-02-15 13:32

manager   ~46523

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26478

Related Changesets

LimeSurvey: master a20d36e7

2018-02-02 16:28:36

markusfluer

Details Diff
Fixed issue 13234: Focus in text fields when pressing return
mod - themes/survey/vanilla/scripts/theme.js Diff File

LimeSurvey: master a5565ec1

2018-02-15 13:31:50

markusfluer

Details Diff
Fixed issue 13234: Focus in text fields when pressing return
mod - application/views/admin/survey/breadcrumb.php Diff File
mod - assets/packages/pjax/min/pjax.combined.min.js Diff File
mod - assets/packages/pjax/min/pjax.min.js Diff File
mod - assets/packages/pjax/pjax.js Diff File
mod - themes/survey/vanilla/scripts/theme.js Diff File

Issue History

Date Modified Username Field Change
2018-01-22 17:21 pgs New Issue
2018-01-22 17:21 pgs Tag Attached: text field
2018-01-22 17:21 pgs Tag Attached: focus
2018-01-24 16:23 c_schmitz Note Added: 46023
2018-01-29 22:19 zbm Note Added: 46143
2018-02-02 16:28 markusfluer Changeset attached => LimeSurvey master a20d36e7
2018-02-02 16:28 markusfluer Note Added: 46224
2018-02-02 16:28 markusfluer Assigned To => markusfluer
2018-02-02 16:28 markusfluer Resolution open => fixed
2018-02-02 16:29 markusfluer Status new => resolved
2018-02-02 16:29 markusfluer Fixed in Version => 3.1.x
2018-02-02 23:13 zbm Note Added: 46238
2018-02-03 11:51 markusfluer Note Added: 46239
2018-02-05 11:45 pgs Note Added: 46251
2018-02-05 18:09 zbm Note Added: 46271
2018-02-06 12:01 olle Status resolved => closed
2018-02-06 12:01 olle Fixed in Version 3.1.x => 3.2.x
2018-02-06 14:50 zbm Note Added: 46281
2018-02-06 15:09 markusfluer Note Added: 46283
2018-02-08 02:57 pgs Note Added: 46301
2018-02-13 16:53 olle Status closed => new
2018-02-13 16:53 olle Resolution fixed => reopened
2018-02-13 16:54 olle Note Added: 46411
2018-02-13 16:59 olle Assigned To markusfluer =>
2018-02-15 13:32 markusfluer Note Added: 46522
2018-02-15 13:32 markusfluer Changeset attached => LimeSurvey master a5565ec1
2018-02-15 13:32 markusfluer Note Added: 46523
2018-02-15 13:32 markusfluer Assigned To => markusfluer
2018-02-15 13:32 markusfluer Status new => resolved
2018-02-19 14:01 olle Relationship added has duplicate 13340
2018-02-19 15:06 olle Status resolved => closed
2018-02-19 15:06 olle Fixed in Version 3.2.x => 3.4.x