View Issue Details

IDProjectCategoryView StatusLast Update
13156Bug reports[All Projects] Survey takingpublic2018-01-15 11:28
ReportercookiemonsterAssigned ToLouisGac 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary13156: Some Variables are not working in ongoing survey: ASSESSMENT_CURRENT_TOTAL and TOKEN:TOKEN
DescriptionSome Variables are not working in ongoing survey: ASSESSMENT_CURRENT_TOTAL and TOKEN:TOKEN
Steps To Reproducecreate a question with ASSESSMENT_CURRENT_TOTAL and TOKEN:TOKEN
Instead of a value there is just ASSESSMENT_CURRENT_TOTAL and TOKEN:TOKEN
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.0.1+171228
I will donate to the project if issue is resolvedNo
BrowserFirefox 57.0.4 (64-Bit)
Database & DB-Versionlibmysql - 5.5.54
Operating System (Server)Ubuntu
Webserver software & versionApache/2.4.7
PHP Version5.5.9

Relationships

related to 13180 closedmarkusfluer Variables don't work in END_URL 

Activities

LouisGac

LouisGac

2018-01-10 17:50

developer   ~45551

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=25962
cookiemonster

cookiemonster

2018-01-11 08:01

reporter   ~45554

no idea how to follow that fix - my replacements_helper just has 413 lines (maybe something missing?)
If I redo your steps in my file the placeholder isn't shown anymore, but the variable is empty
cookiemonster

cookiemonster

2018-01-11 08:04

reporter   ~45555

now I got it - you fixed the assessments themselves, but as variables in questions or random text it doesn't work
token:token doesn't work there as well, so seems to be a general issue wit Variables - can confirm though: assessments themselves are fixed
LouisGac

LouisGac

2018-01-11 10:13

developer   ~45557

"If I redo your steps in my file"?
You should take some time to learn to use git, it's pretty easy once you get it:
https://www.youtube.com/watch?v=HVsySz-h9r4

I fixed a similar bug before your fix, so you're missing a lot of things:
https://bugs.limesurvey.org/view.php?id=13134

The fix I pushed is for variables in question text ($qa[0]['text'])
https://github.com/LimeSurvey/LimeSurvey/commit/cd2341a82471975d376abf0c00db2612fd16eca2
LouisGac

LouisGac

2018-01-11 10:14

developer   ~45558

and, thank you for your bug report: very useful
+1
cookiemonster

cookiemonster

2018-01-15 08:51

reporter   ~45596

just updated to 3.0.3 to be sure I didn't do something wrong.
{TOKEN:TOKEN} is still shown in the survey instead of the actual token (I use it in the end URL to restart the survey with the same token)
cookiemonster

cookiemonster

2018-01-15 08:55

reporter   ~45597

can confirm it's just in the end url - is this planned or still a bug?
LouisGac

LouisGac

2018-01-15 10:01

developer   ~45598

it will be fixed in next release
c_schmitz

c_schmitz

2018-01-15 10:37

administrator   ~45638

Version 3.0.3 released.

Related Changesets

LimeSurvey: master 5e0de720

2018-01-10 17:49:20

LouisGac

Details Diff
fixed issue 13156: Some Variables are not working in ongoing survey: ASSESSMENT_CURRENT_TOTAL and TOKEN:TOKEN
mod - application/helpers/replacements_helper.php Diff File

Issue History

Date Modified Username Field Change
2018-01-10 10:56 cookiemonster New Issue
2018-01-10 17:50 LouisGac Changeset attached => LimeSurvey master 5e0de720
2018-01-10 17:50 LouisGac Note Added: 45551
2018-01-10 17:50 LouisGac Assigned To => LouisGac
2018-01-10 17:50 LouisGac Resolution open => fixed
2018-01-10 17:50 LouisGac Status new => resolved
2018-01-11 08:01 cookiemonster Note Added: 45554
2018-01-11 08:04 cookiemonster Note Added: 45555
2018-01-11 10:13 LouisGac Note Added: 45557
2018-01-11 10:14 LouisGac Note Added: 45558
2018-01-15 08:51 cookiemonster Note Added: 45596
2018-01-15 08:55 cookiemonster Note Added: 45597
2018-01-15 10:01 LouisGac Note Added: 45598
2018-01-15 10:36 c_schmitz Product Version => 3.0.1
2018-01-15 10:36 c_schmitz Fixed in Version => 3.0.3
2018-01-15 10:37 c_schmitz Status resolved => closed
2018-01-15 10:37 c_schmitz Note Added: 45638
2018-01-15 11:28 LouisGac Relationship added related to 13180